Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
?
Solved

Cannot connect via telnet or ftp to Linux 9 box

Posted on 2004-08-11
4
Medium Priority
?
2,379 Views
Last Modified: 2012-05-05
I setup a Linux 9 server and and am trying to connect to it via telnet and ftp. For some reason it's not working.

When I try to connect via telnet I get the following error:

could not open connection to the host, on port 23: connect failed.

When I try to connect via ftp I get: unknown error number.

I'm a novice Linux person so please go easy on me :-) simple answers are encouraged.

Thanks,

John
0
Comment
Question by:jhieb
  • 2
4 Comments
 
LVL 40

Accepted Solution

by:
jlevie earned 500 total points
ID: 11779038
I'm guessing that "linux 9" is probably RedHat 9. If so the failure could be from the firewall installed by default during the OS installation. The default firewall rule set will prevent any connections to outside to the box. You can, for the purposes of testing, disable the firewall with '/sbin/service iptables stop'

Another possibility is that you haven't installed and/or enabled a telnet or FTP server. Neither will be installed unless you chose a Server or Everything configuration, and even then they won't be enabled by default. If /sbin/chkconfig --list' doesn't show a telnet or FTP service the packages (telnet-server or vsftpd) aren't installed and you'll need to install them from the distribution CD's. If the services are listed you can enable each with chkconfig.
0
 
LVL 1

Author Comment

by:jhieb
ID: 11779154
Thanks. It doens't show FTP as a service so I'll check the installation. Telnet was installed so I started it with chkconfig. Works great. Does this mean it will automcatically start now when I reboot or do I need to change something else?
0
 
LVL 40

Expert Comment

by:jlevie
ID: 11779657
When enabled via chkconfig the service will be available for subsequent boots
0
 

Expert Comment

by:theneeraj
ID: 11830295
disable the firewall service in your redhat .

#chkconfig iptables off
 or use
#ntsysv
and scroll down to uncheck the iptables and reboot.
0

Featured Post

VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Linux users are sometimes dumbfounded by the severe lack of documentation on a topic. Sometimes, the documentation is copious, but other times, you end up with some obscure "it varies depending on your distribution" over and over when searching for …
In my business, I use the LTS (Long Term Support) versions of Linux. My workstations do real work, and so I rarely have the patience to deal with silly problems caused by an upgraded kernel that had experimental software on it to begin with from a r…
Learn how to get help with Linux/Unix bash shell commands. Use help to read help documents for built in bash shell commands.: Use man to interface with the online reference manuals for shell commands.: Use man to search man pages for unknown command…
Learn how to find files with the shell using the find and locate commands. Use locate to find a needle in a haystack.: With locate, check if the file still exists.: Use find to get the actual location of the file.:
Suggested Courses
Course of the Month13 days, 23 hours left to enroll

581 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question