Solved

Belkin F5D7010 PCMCIA card + Mandrake 10 + ndiswrapper = despair

Posted on 2004-08-11
8
314 Views
Last Modified: 2010-03-18
Hi,

I have had no replies on the Mandrake forum about this setup and I really hope someone here can help out.  I have the aforementioned card with 3 different sets of drivers installed via ndiswrapper 0.9. The card gets a very faint light to both LEDs when inserted, but this does not change throughout the ndiswrapper procedure.

I have put the line 'alias wlan0 ndiswrapper' into modprobe.conf, but wlan0 never comes up. the command 'cardctl ident' returns 'Socket 0: no product info available'

The card is recognised by ndiswrapper (and appears in the hardware manager), but I think the problem is that ndiswrapper is not doing anything once loaded. I have tried every bit of debugging I've found on various forums, but nothing seems to work.

Some say that modprobe.conf should have another line invoking /sbin/loadndisdriver with the vendor/chipset IDs obtained from lspci, but elsewhere it is said that newer versions of ndiswrapper don't need this.

It is suggested that I should have a file called

/etc/sysconfig/network-scripts/ifcfg-wlan0

but I don't and I also wouldn't know how to create one.

There are so many unknowns for me in this one. I'm just hoping for some straightforward advice I can follow, ideally from someone who has overcome similar problems and knows how they did it. I will supply further info and console-dumps as needed.

Please help, this is truly driving me batty.
0
Comment
Question by:Havin_it
  • 3
  • 2
  • 2
8 Comments
 
LVL 14

Expert Comment

by:pablouruguay
Comment Utility
i dont know but i use this scirtpt for wireless try it



[root@sony wireless_tools.26]# cat /root/wep.sh
#!/bin/sh

PATH=/sbin:/usr/sbin:${PATH}

sudo insmod ndiswrapper  # loads also the XP MS-windows driver if installed

INTF="wlan0"
SSID="WEPSITE"
KEY="aEf54CDFeyytrrd5efacbbea5"
MODE="Managed"

echo "Starting wireless on interface $INTF ...."

sudo iwconfig $INTF mode $MODE ESSID $SSID
sudo iwconfig $INTF key $KEY
sleep 3
sudo dhcpcd $INTF

# This part is just to check the settings in case of trouble :
iwconfig $INTF
ifconfig $INTF
route -n
cat /etc/resolv.conf
0
 
LVL 14

Expert Comment

by:pablouruguay
Comment Utility
im sorry you need to install the wireless_tools for that...

http://www.hpl.hp.com/personal/Jean_Tourrilhes/Linux/wireless_tools.26.tar.gz



i answer this question in the same day .. :)
0
 
LVL 10

Author Comment

by:Havin_it
Comment Utility
insmod? I'm not sure about this; the ndiswrapper docs say to use modprobe ndiswrapper.

Apparently ndiswrapper 0.4 is preinstalled with Mandrake 10, so I've taken steps to remove it fully - this involved removing lines regarding ndiswrapper from /lib/modules.dep

I then started from scratch with the ndiswrapper 0.9 RPM, but modprobe ndiswrapper returned FATAL: no such module

Removed that and built 0.9 from source. This time modprobe caused a freeze, though the card's power LED came up bright, which was a first. Seems like progress?
0
Highfive + Dolby Voice = No More Audio Complaints!

Poor audio quality is one of the top reasons people don’t use video conferencing. Get the crispest, clearest audio powered by Dolby Voice in every meeting. Highfive and Dolby Voice deliver the best video conferencing and audio experience for every meeting and every room.

 
LVL 10

Author Comment

by:Havin_it
Comment Utility
Okay, I have got it fixed up now.  The problem was with artifacts left by an earlier version of ndiswrapper (preinstalled with the OS) so once I'd cleaned everything up it worked like a charm.

Applying for PAQ.
0
 
LVL 10

Author Comment

by:Havin_it
Comment Utility
What he said. ee_ai_construct has also advised me that a explanation of the solution should be given, so permit me to be a little more exhaustive:

The reason ndiswrapper was detecting the card but not able to properly use it, was because the actual kernel module was the old version 0.4 which (unknown to me at that point) is a preinstalled part of MDK 10.

Removing the files mentioned in the manpage is not sufficient, because that leaves the modules in the kernel-source-directory, namely

/lib/modules/<kernel-version>/misc/ndiswrapper.ko
/lib/modules/<kernel-version>/kernel/3rdparty/ndiswrapper/ndiswrapper.ko.gz

Also removed the paths to these files from /lib/modules/modules.dep then installed new version (0.9). I did it from source, but with the old-version problem sorted, an RPM install would probably be fine too.

After installing the driver files copied from the WinXP CD (bcmwl5.inf, bcmwl5.sys and bcmwl5.cat), did a restart (for paranoia reasons), ran the command modprobe ndiswrapper, and got a complete system freeze. Restarted again (not much choice), but this time didn't insert the card until AFTER modprobing. Power light on, good. iwconfig returns a full interface description for wlan0, better. Go to my hotspot and try to bring up a web page. I can, and fast too. BEST!

I'm now thinking this Q should be PAQ'd rather than deleted, because many forum postings (and ndiswrapper's own pages) fail to be specific about the issue of removing the rogue kernel modules. Hope it saves someone the fortnight of hopelessness I went through!
0
 

Expert Comment

by:ee_ai_construct
Comment Utility
excellent write up.  this is a much better way to close a question
thank you havin_it
0
 

Accepted Solution

by:
ee_ai_construct earned 0 total points
Comment Utility
Closed, 500 points refunded.
ee_ai_construct (replacement part #xm34)
Community Support Moderator
0

Featured Post

Windows Server 2016: All you need to know

Learn about Hyper-V features that increase functionality and usability of Microsoft Windows Server 2016. Also, throughout this eBook, you’ll find some basic PowerShell examples that will help you leverage the scripts in your environments!

Join & Write a Comment

Suggested Solutions

I have seen several blogs and forum entries elsewhere state that because NTFS volumes do not support linux ownership or permissions, they cannot be used for anonymous ftp upload through the vsftpd program.   IT can be done and here's how to get i…
Note: for this to work properly you need to use a Cross-Over network cable. 1. Connect both servers S1 and S2 on the second network slots respectively. Note that you can use the 1st slots but usually these would be occupied by the Service Provide…
This video gives you a great overview about bandwidth monitoring with SNMP and WMI with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're looking for how to monitor bandwidth using netflow or packet s…
This tutorial demonstrates a quick way of adding group price to multiple Magento products.

743 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

11 Experts available now in Live!

Get 1:1 Help Now