Fixing the "." zone under forward lookup zones in DNS.

I have walked into a client that has Win2K Servers installed and the DNS on the DC is setup with the "." zone under forward lookup zones.  How do I fix this?  Is it a reinstall?  I am fairly new to DNS.

Thanks,
John

Question: What are the common mistakes that are made when administrators set up DNS on network that contains a single Windows 2000 or Windows Server 2003 domain controller?

Answer: The most common mistakes are:
The domain controller is not pointing to itself for DNS resolution on all network interfaces.
*** The "." zone exists under forward lookup zones in DNS.
Other computers on the local area network (LAN) do not point to the Windows 2000 or Windows Server 2003 DNS server for DNS.
wsurferdudeAsked:
Who is Participating?
 
BigC666Connect With a Mentor Commented:
howdy,

that's the root zone, if you want to remove it right click and do so.
that's the default with a fresh server install, ther are many issues that call for ti's removal
hope that this helps
0
 
jdeclueCommented:
While I am here... I concur.. BigC's gotcha covered.

J
0
 
Debsyl99Connect With a Mentor Commented:
Hi
Big C's right (and this is just an expansion - not to be accepted as an answer) - You just right-click on the "." zone, and hit delete. The "." zone means that it's configured as root server for the domain - that's great until you want to resolve anything out side of the domain ie internet access, as with the "." zone in place it won't look any further than that dns server for name resolution. Removal of the "." zone allows you to configure forwarders - (right-click on the domain forward lookup zone, properties, forwarders) usually your isp's dns servers. The clients then are configured to have the local dc/dns server as their primary name server, the dc/dns server then forwards any dns queries that it cannot resolve to the isp's nameservers.

Deb :))


0
 
wsurferdudeAuthor Commented:
Thanks to all of you!  Didn't know if zapping the "." zone would affect the rest of the notwork, but went on your advise and killed the "." zone, restarted the dns service and voila... the cached lookups and name servers started populating, logins were 10 times faster and also solved problems with assigning rights to hosts.  Question for Deb:  I tried to configure forwarders by right clicking on the dns server name and selecting properties, but forwarding was greyed out, so I set the external DNS servers in the ip settings of the DC/DNS server (Alternate DNS server).  Does the greyed out forwarding tab suggest another problem with DNS??

Thanks,

John
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.