Solved

Displaying a staic screen (console) either image or text rather that prompting login

Posted on 2004-08-12
2
196 Views
Last Modified: 2013-12-15
I am building a Linux server that I do not want the end user to mess with. I would rather that when the computer first boots up, it displays a splash screen rather than everything it is doing (that would be nice but not necessary) and then at the end when the server is running, to just display either a splash screen, or a formated text display rather than a login prompt. (I know, and most heavy user know they can Alt-f2, 3, 4, 5, 6 to another console for the login, but for console 1, I would like just to display the screen. (I have seen packaged products that do this such as eSoft instagate software). We are maintaining the server remotely (telnet, rsh, ftp etc...) so I do not want to mess up those features, just the initial boot for console 1.

Thanks in advance.
0
Comment
Question by:dwanders
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
2 Comments
 
LVL 3

Accepted Solution

by:
dufduf earned 250 total points
ID: 11788517
http://www.bootsplash.org/ helps with the splash screen. I know practically nothing about it, but I guess their website tells something. I only know, that it involves a kernel patch and some userspace stuff. If you don't feel like that, you could edit your init scripts and redirect all output >/dev/null.

If you don't want to allow console access, you can do it by editing /etc/inittab. Mine has lines like these, and yours should include something similar:

id:2:initdefault:
[lots of lines cut]
1:23:respawn:/sbin/getty 38400 tty1
2:23:respawn:/sbin/getty 38400 tty2

These tell that /sbin/getty is run on vc's 1 and 2, if runlevel is 2 or 3, and that normal boot defaults to runlevel 2 (initdefault). Now change the default runlevel to eg. 4, and after next reboot you won't get login screens at all. If you need to get console access, you have to boot the machine into single-user mode. What users will see is the output of the last init script and init telling that there are no more processes.

man init
man inittab
0
 
LVL 51

Expert Comment

by:ahoffmann
ID: 11799111
or simply disable getty (mingetty, vboxgetty, whatever) in /etc/inittab
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Daily system administration tasks often require administrators to connect remote systems. But allowing these remote systems to accept passwords makes these systems vulnerable to the risk of brute-force password guessing attacks. Furthermore there ar…
If you have a server on collocation with the super-fast CPU, that doesn't mean that you get it running at full power. Here is a preamble. When doing inventory of Linux servers, that I'm administering, I've found that some of them are running on l…
This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.
How to Install VMware Tools in Red Hat Enterprise Linux 6.4 (RHEL 6.4) Step-by-Step Tutorial

696 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question