Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 163968
  • Last Modified:

Remove Open File -Security Warning

Everytime i open a file (usually a .BAT or .VBS) from a network path i get a Security Warning that ask me if i want to run this file. Is there a way to remove this security warning and just have the computer run the application using Group Policies?
0
gbarrientos
Asked:
gbarrientos
1 Solution
 
Fatal_ExceptionCommented:
Is the warning originating from your AV software or Windows?  If AV, such as a Symantec product, you can configure it there to allow scripts to execute..
0
 
gbarrientosAuthor Commented:
Not Antivirus....Windows XP
0
 
sramesh2kCommented:
Known issue. Add the target computer to the Trusted Zone (or Intranet Zone) in Internet Explorer
0
VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

 
gbarrientosAuthor Commented:
if thats the only fix....Is it possible to trust the whole domain?
0
 
sramesh2kCommented:
Good point! Will see if there is any other workaround.
0
 
gbarrientosAuthor Commented:
It seems that if i type in the fqdn as a trusted zone everything seems to work fine. However, and im not sure if this should be another question, i want to set this setting for the whole domain. As in i want every workstation in my domain to trust my domain, is this possible using Group Policies?
0
 
sramesh2kCommented:
You should be able to accomplish this easily via GP, or using a REG

It's stored in this part of the registry.

HKEY CURRENT USER\Software\Microsoft\Windows\CurrentVersion\Internet
Settings\ZoneMap\Domains

But, the key also contains the Trusted, Restricted, Intranet Zone domains listings. You need to segregate the Restricted Sites alone by reading the DWORD value in the right-side.

-or-
Use thuis utility ExportZone which exports the Restricted/Trusted Sites list to two separate REG files.
http://www.mvps.org/sramesh2k/ExportZone.htm
0
 
gbarrientosAuthor Commented:
So i am guessing the only way to do this via GP is to scipt a  registry change?
0
 
sramesh2kCommented:
Per GP, PeteLong or any server guys will have a good idea. I hadn't had hand-on with the GP much. Will see if I can get more details on this.
0
 
sramesh2kCommented:
Option 2: Using an ADM template

Windows 2000: Distributing registry edits via Group Policy:
http://www.experts-exchange.com/Operating_Systems/Win2000/Q_21024408.html
0
 
caitsith1Commented:
The only thing I can officially say,  is it is only MSIE that tacks on the "open file - security warning" to downloaded exes.  I recommend either switching to another browser, such as mozilla,  or at the least,  live with one more warning, and get a download manager utility such as getright.  exes and other executables will not have the warning attached, if downloaded through a different browser, or with a download manager.   There might be an option to turn the warning off, for MSIE, but I still have to figure that out.
0
 
gbarrientosAuthor Commented:
Clicking yes to the security warning is not really my problem, but rather that the program that i have created for our organization will once in a while launch .vbs, .bat, or .exe files silently and it turns out that becase the program does this sliently the security warning does not actually pop-up to the user....however the application sits there and waits for the answer. This application works fine when sitting locally on the HDD, but halts without error when on the files are on a network share (This is on a Windows XP Machine). On a windows 2000 machine the program works fine weather its on the network share of sotred locally.
0
 
gbarrientosAuthor Commented:
It turns out that by adding the FQDN as a trusted intranet zone the application works fine and i dont receive any security warninings when executing files from a share. The problem now is getting this setting into all my workstations. But  i suppose that would be another questions. Thanx everyone for all your help.
0
 
sramesh2kCommented:
You're most welcome, gbarrientos.
0
 
gregtampaCommented:
To disable the warning start the Group Policy Editor (Start > Run, type
-gpedit.msc- and press OK) and go to:

-User Configuration > Administrative Templates > Windows Components >
Attachment Manager- then set -Inclusion list for low file types- to
Enabled and enter the file types you don't want to be warned about in
the box (for example: .exe).
--just an update for the windows xp sp2 and later users.
0
 
dzeluffCommented:
Had the same issue when trying to install a .MSI file through a VBS logon script.  Simple fix was to do a right click on the file on the server, properties and under the General Tab at the bottom there was a 'Unblock' button.  Click it to remove the warning.  Once you Unblock it the button will no longer appear.  

 Dan Z
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Tackle projects and never again get stuck behind a technical roadblock.
Join Now