Unable to compile JSP under embedded Tomcat

Posted on 2004-08-13
Medium Priority
Last Modified: 2011-09-20

I have a struts-based application running within embedded Tomcat - it works fine on my machine. However, when I move it to another machine and try to run it I get an error from ONE of the jsps - others run fine. The error I get is:
org.apache.jasper.JasperException: Unable to compile class for JSP

No Java compiler was found to compile the generated source for the JSP.
This can usually be solved by copying manually $JAVA_HOME/lib/tools.jar from the JDK
to the common/lib directory of the Tomcat server, followed by a Tomcat restart.
If using an alternate Java compiler, please check its installation and access path.


note The full stack trace of the root cause is available in the Apache Tomcat/5.0.25 logs.

My JSP file is:

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<%@ taglib uri="/WEB-INF/struts-html.tld" prefix="html" %>
<%@ taglib uri="/WEB-INF/struts-bean.tld" prefix="bean" %>
<%@ taglib uri="/WEB-INF/struts-logic.tld" prefix="logic" %>

<html:html locale="true">
<logic:notPresent name="vstaff" scope="application">
      <logic:redirect href="initialise.do"/>
<%@ page
import = "uk.co.xks.vtrack.forms.SigninForm, uk.co.xks.vtrack.forms.StaffForm, java.util.Enumeration, java.util.Vector"
contentType="text/html; charset=ISO-8859-1"
<% Vector vstaff = (Vector) getServletContext().getAttribute("vstaff"); %>

<META http-equiv="Content-Type" content="text/html; charset=ISO-8859-1">
<META name="GENERATOR" content="IBM WebSphere Studio">
<META http-equiv="Content-Style-Type" content="text/css">
<LINK href="theme/vtrack.css" rel="stylesheet" type="text/css">
<TITLE><bean:message key="index.title"/></TITLE>

<h4><bean:message key="index.welcome"/></h4>

<table width="100%" cellpadding="8" border="0" rules="rows" align="center">
<tr height="20"><td colspan="3"></td></tr>
<tr><td width="20%" valign="top"><html:img srcKey="image.company_logo" altKey="image.company_logo.alt"/></td>
<td align="center"><h1><bean:message key="index.signin"/></h1><h5><bean:message key="index.info"/></h5>
<html:form action="signin.do" focus="visitorName">
<tr valign="top"><td width="50%" align="right"><h3><bean:message key="index.name"/></h3></td>
<td width="50%"  align="left"><input type="text" name="visitorName" size="30" tabindex="1"></td></tr>
<tr valign="top"><td width="50%" align="right"><h3><bean:message key="index.company"/></h3></td>
<td width="50%"  align="left"><input type="text" name="companyName" size="30" tabindex="2"></td></tr>
<tr valign="top"><td width="50%" align="right"><h3><bean:message key="index.car_reg"/></h3></td>
<td width="50%"  align="left"><input type="text" name="carRegistration" size="30" tabindex="3"></td></tr>
<tr valign="top"><td width="50%" align="right"><h3><bean:message key="index.visiting"/></h3></td>
<td width="50%" align="left">
<html:select property="visitingName">
<html:options collection="vstaff" labelProperty="staffName" property="staffId"/></html:select></td></tr>
<tr align="center">
<td align="right"><html:submit><bean:message key="button.signin" /></html:submit></td>
<td align="center"><html:reset><bean:message key="button.reset" /></html:reset></td>

<table><tr height="70"><td></td></tr></table>

<table width="100%" cellpadding="8" border="0" rules="rows" align="center">
<tr align="center">
<td><h1><bean:message key="index.logout1"/> <a href="listvisitors.do"><bean:message key="index.logout2"/></a></h1></td>

<table width="100%" border="0" rules="rows" align="center">
<tr valign="bottom">
<td align="center"><html:img srcKey="image.spare_logo1" altKey="image.spare_logo1.alt"/></td>
<td align="center"><html:img srcKey="image.spare_logo2" altKey="image.spare_logo2.alt"/></td>
<td align="center"><html:img srcKey="image.spare_logo3" altKey="image.spare_logo3.alt"/></td>
<td align="center"><html:img srcKey="image.spare_logo4" altKey="image.spare_logo4.alt"/></td>


As I said, other JSPs in the application work fine, so I ssumed it might be a typo but I've checked and checked and cannot find one (all "" ; etc are okay as far as I can tell). I've included the tools.jar in my classpath (set in a bat file when the app runs).

Does anyone have any ideas?
Question by:stevebeech
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 7
  • 4
LVL 11

Expert Comment

ID: 11791635
Please try tomcat suggestion

>>This can usually be solved by copying manually $JAVA_HOME/lib/tools.jar from the JDK
>>to the common/lib directory of the Tomcat server, followed by a Tomcat restart.

You may include this jar file to classpath or set it in bat file but it does not match exactly with what Tomcat suggest.

Author Comment

ID: 11791687
There is no /common directory in Embedded Tomcat - I've copied it to /lib but this doesn't work.

LVL 11

Expert Comment

ID: 11791723
Do you have this directory "C:\Program Files\Apache Software Foundation\Tomcat 5.0\common\lib" ?
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

LVL 11

Expert Comment

ID: 11791727
Or TOMCAT_HOME\common\lib

what version of tomcat are you using?

Author Comment

ID: 11791751
Its Embedded Tomcat version 5.0.25

The directory structure is:

LVL 11

Expert Comment

ID: 11791760
I'm 5.0.25 too but I have ?
LVL 11

Expert Comment

ID: 11791765
try to reinstall with full package.

Author Comment

ID: 11791823
Are you using standard version 5.0.25 or 5.0.25-embed?

I've reinstalled this embedded version and still don't get a /common folder.

Author Comment

ID: 11808860
I think that's a different version - not the embedded one.

I've managed to solve this problem anyway - I just re-ordered some of the tags on my JSP page - moved the meta tags above the struts logic tags and it all works okay.

Thanks anyway for your help.

LVL 11

Expert Comment

ID: 11808894
That's ok :)

Accepted Solution

RomMod earned 0 total points
ID: 11853489
The question has been PAQ'd and the 250 points have been refunded.
Community Support Moderator

Featured Post

New benefit for Premium Members - Upgrade now!

Ready to get started with anonymous questions today? It's easy! Learn more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

An introduction to the wonderful sport of Scam Baiting.  Learn how to help fight scammers by beating them at their own game. This great pass time helps the world, while providing an endless source of entertainment. Enjoy!
What's worse than having your data encrypted by ransomware? Getting attacked by a so-called "wiper," which simply destroys the data and offers you no hope of ever seeing it again.
If you’ve ever visited a web page and noticed a cool font that you really liked the look of, but couldn’t figure out which font it was so that you could use it for your own work, then this video is for you! In this Micro Tutorial, you'll learn yo…
This is my first video review of Microsoft Bookings, I will be doing a part two with a bit more information, but wanted to get this out to you folks.

764 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question