• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 550
  • Last Modified:

How to do network via a router ?


I have a Windows XP Desktop, a Windows 2000 Desktop and a ME Laptop connected with each other via a D-Link router.

Each of these 3 machines has ZoneAlarm firewall and Symantec Antivirus installed.

They have the same workgroup name. XP machine has a shared folder; the other two have shared drives. They can connect to Internet.

They however do not see each other!

Help!

Calvin
0
cthai_exp
Asked:
cthai_exp
2 Solutions
 
sirbountyCommented:
Suggestions/steps for setting up your XP network can be found here: http:Q_21014637.html#11268699
Troubleshooting steps are listed here: http:Q_21014637.html#11268884

Try setting up the computer names in your LMHOSTS file (xp/2k in Start->Run->%systemroot%\system32\drivers\etc as lmhosts.sam | ME, I think is just in C:\windows)

Reboot and see if you can ping them now...
You might try disabling the firewalls to see if that resolves it - if so, just need some tweaking on zone alarm
0
 
drewtarvinCommented:
Make sure File/Print sharing is enabled on all of the computers.  You can check this by right-clicking on My Network Places, going to properties and looking at what services are installed.  Also, check ZoneAlarm's settings to make sure that it is not blocking any necessary information.  Also make sure the Windows built-in firewall is disabled, under the properties as mentioned above.
0
 
OllienCommented:
Hi, I have found that personal firewalls on individual networked computers don't go with Microsoft Local Area Networks (incl. file and printer sharing).

First, check if you can PING the other computers.  Pinging sends a packet to another computer to check for communication (to 'see' each other).  Start > Run > type cmd > Enter > type ping (remote computer name here) > enter.  The results will show communication (if any), and how long the response took (normally a few milliseconds on small LAN's).

That being sucessful, try disabling the firewalls on the computers you wish to share files between.  From experience this has solved the problem.  If you are using the computers only in this network then they are protected by a NAT firewall on the D-Link router, only reciprocated communication will get through it.

There is an alternative by opening up certain ports in your ZoneAlarm firewalls, but i'm not sure of what they are.

Good Luck
0
 
w00pieCommented:
if you have the ip's direct and they do ping eachother you might try opening a DOS prompt and using:  net view \\ip_of_computer   and see what share directories it sees.  can also use
net use <driver letter to assign> \\<ip pc>\sharename
and that will map the sharename as whatever drive letter you have

net view \\192.168.12.50
net use q: \\192.168.12.50\tmpshare

are some examples of seeing shares on a computer with that ip and then mounting a share that is labeled tmpshare to Q:
0
 
lopezcCommented:
the biggest clue you have is you installed zone alarm.

try lowering it's security settings.

if you know the identity (ip addresses) of the computers  let them pass through the firewall.

if you disable ZoneAlarm, can you see the shared folders?
0

Featured Post

Managing Security & Risk at the Speed of Business

Gartner Research VP, Neil McDonald & AlgoSec CTO, Prof. Avishai Wool, discuss the business-driven approach to automated security policy management, its benefits and how to align security policy management with business processes to address today's security challenges.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now