Solved

Problem with IDE device detection on Asus P5AD2

Posted on 2004-08-13
16
673 Views
Last Modified: 2012-06-21
(This is really long but please bear with me)

Last weekend I bought all the components to build a computer and have put them together, and everything was working fine, up to the point of detecting the IDE devices.  No matter what I try, I cannot get the computer to reliably detect and use the devices without giving an error.

I am trying to connect an optical drive (Creative) and a blank HDD (Seagate), so that I can boot up from the Windows XP CD in the optical drive to install the OS on my new system.

The motherboard is an ASUS P5AD2 Premium  
<http://usa.asus.com/prog/spec.asp?m=P5AD2%20Premium&langs=09>
There was an issue with the Intel ICH6 previously in these motherboards, but I have confirmed that this has been fixed for my board.

It has a primary IDE connector and then two other separate IDE connectors for use in a RAID – but by default these are set to normal IDE and I have confirmed this in the BIOS setup.  The manual says that these can be used for normal IDE devices.
There is a limitation with the motherboard in that I have to plug the optical drive into the primary IDE or it cannot be used as a boot drive (which I need to install the OS).  The computer will detect the optical drive in the primary IDE, but will either not detect any other HDDs or it will detect them but give the error that they are "ATAPI Incompatible".  It only seems to detect the CD-ROM if I use the asus cable labelled "CD-ROM" and not if I use the HDD cable that has the differentiated plugs - blue, grey and black.

I know that each IDE channel has a master and slave (grey for master, black for slave), and that you cannot have two masters or two slaves on a channel.  I also know that I have to set the jumper on the devices correctly as either master or slave (ignoring cable select for the moment).  This is not the problem.

On one occasion only after trying repeated combinations with the IDE connectors I succeeded in getting the CD-ROM booted from the Windows XP disk and it started installing on the blank HDD, but after the hard disk formatting stage, the XP installation kept going back to the same screen again and again (asking if I wanted to install windows on the same partition – I pressed “c” to continue and then after loading all the drivers and files it goes back to the same screen asking if I want to continue by installing Windows on the partition.. again and again ).  After much searching the web I discovered that this was because the HDD was greater than 137Gb.  Apparently the HDD must be less than that figure for XP to install correctly.

So I then bought a SATA HDD (120Gb only) and connected it, thinking that this would be easier than the PATA drive, but it too is not recognized.  At one stage it made repeated clicking noises but that was all.

I have tried resetting the BIOS to defaults, but this has not improved the problem.

Does anyone have any ideas?  Any help would be greatly appreciated.

Andrew.

0
Comment
Question by:andrewdonaldson
16 Comments
 
LVL 10

Accepted Solution

by:
Dynamic1 earned 125 total points
ID: 11793581
You need to install the riad drivers when loading windows XP hit F6 and add drivers give me a few minutes and I will find your drivers.
0
 
LVL 11

Assisted Solution

by:DoTheDEW335
DoTheDEW335 earned 125 total points
ID: 11793637
as far as the SATA HDD , if it's not recognized and is making loud repeated clicking noises I would probably return it (Test it on another PC if possible 1st) Have you made sure your SATA is enabled in the bios?  Is the ITE8212F Controller set to  IDE mode? and Silicon Image Controller set to SATA  mode for the SATA to work without raid? last but not least is  Report IDE error enabled to see if it's reporting anything to you reguarding the trouble your having?

I'm reading from the manual just to shoot out some ideas

Source :
http://www.asus.com/pub/ASUS/mb/socket775/P5AD2/e169_p5ad2premium.pdf

0
 
LVL 10

Expert Comment

by:Dynamic1
ID: 11793638
http://www.asus.com/support/download/selectftp.aspx?l1_id=1&l2_id=22&l3_id=1&m_id=1&f_name=3114IDE_RAID.zip~zaqwedc This is the silicon image raid driver. http://www.asus.com/support/download/item.aspx?ModelName=P5AD2%20Premium Here are all of your other drivers. Press F6 to load mass storage driver when it asks usually a few minutes or less into install. Load the silicon Image mass storage driver weather you are running in raid or not you need this driver. Enjoy your new system looks like a nice board.
0
 
LVL 2

Expert Comment

by:Aramis11
ID: 11793651
Why do you need to boot from the disk drive in order to install the OS?  Could you not start it with a floppy including drivers for it?  An XP rescue disk made on another machine may suffice.  [If no note made of other comments it is because none are posted yet; last time three wedged in front later.]
0
 
LVL 11

Expert Comment

by:DoTheDEW335
ID: 11793654
you should have all raid options in the bios changed to either IDE mode or whatever the manual says since your not using raid at all.
0
 
LVL 10

Expert Comment

by:Dynamic1
ID: 11793670
If he is using a Sata drive it has to go on a raid channel on that board.
0
How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

 
LVL 69

Expert Comment

by:Callandor
ID: 11793671
By the way, it sounds like you have two different cables - the one designated CDROM is a 40-wire cable, and the other one is an 80-wire cable.  You should be able to hook up the hard drive and CDROM on the 40-wire cable, but the 80-wire cable can only work with hard drives.
0
 
LVL 10

Expert Comment

by:Dynamic1
ID: 11793692
Also Andrew I do not think the 236GB thing is a problem I have a 200GB as a master in one of my systems no problems. But I do know ASUS and they usually make it so you have to load several Drivers on there high end boards for the HDDs to work example Windows XP on P4C800 Deluxe you have to load 2 Sata Drivers or no go.
0
 
LVL 10

Expert Comment

by:Dynamic1
ID: 11793697
Whoops 136GB :>)
0
 
LVL 31

Expert Comment

by:rid
ID: 11793956
About jumpering:
Cable Select (CS) is one method of determining master and slave relationship on an IDE channel. To use CS, the IDE controller must understand it, you should have a proper cable AND your drives MUST be jumpered for CS. The end connector is for the master drive (or single), the middle connector is for the slave.

Having the CD unit and the master HD on the same channel (primary) shouldn't be a problem, unless ASUS has chosen to incorporate a non-standard IDE controller on this MB.

Check jumpering and that the IDE cable is the right way around (the correct end goes to the MB).
/RID
0
 
LVL 11

Expert Comment

by:DoTheDEW335
ID: 11794057
I was just reading off the manual for the settings. you can completly remove the raid function . That all I was refering to. If the drive is detected in the XP setup then he wont need to d/l and use the F6 function to install the raid drivers. XP does have default ones. (Especially if your using the latest XP setup cd w/ SP1 included)
>>So I then bought a SATA HDD (120Gb only) and connected it, thinking that this would be easier than the PATA drive, but it too is >>not recognized.  At one stage it made repeated clicking noises but that was all.

Where is it not recognized ? in the Bios or windows setup?
0
 
LVL 10

Expert Comment

by:Dynamic1
ID: 11794546
DEW I know most asus boards with multiple raid controllers need that driver for SATA operation P4C800 DELUXE was one example even with XP SP1. Mabye they have changed now. I am not too familiar with Intels newest chipset yet waiting for the bugs to be worked out. And the prescott is real unimpressive to me so far as the northwood outperforms it and runs cooler. I went crazy with the P4C800 Deluxe when it came out trying to get it to work. Soultion was to load both raid drivers under mass storage controllers. Then it was fine. And I was only running a single drive.
0
 
LVL 22

Expert Comment

by:pjedmond
ID: 11797684
Just done one almost identical to this:

First in the BIOS there is a setting por the Promise SATA controller - The choice is RAID or IDE. - If you only have one drive installed, or if you are not planning  on using RAID set it to IDE.

Second - On the motherboard CD drivers disk there is a folder for drivers. In the promise ATA folder I seem to remember there were 2 sum folders one for RAID and one for IDE. In each of these folders there is a folder for each operating system, however there is also a floppy driver disk maker! Use this to make a driver floppy disc (it's the same floppy for all proposed OSes as you'll see once you've created it).

Once you've started to boot from the XP CD, insert the floppy, and press F6 when asked if you are wanting to install any other drivers.

Finally, it then asks you to identify any additional drives that you want to add a little later on in the boot process. Check that these match what you think should be there.

HTH:)
0

Featured Post

What Is Threat Intelligence?

Threat intelligence is often discussed, but rarely understood. Starting with a precise definition, along with clear business goals, is essential.

Join & Write a Comment

I use more than 1 computer in my office for various reasons. Multiple keyboards and mice take up more than just extra space, they make working a little more complicated. Using one mouse and keyboard for all of my computers makes life easier. This co…
Moving your enterprise fax infrastructure from in-house fax machines and servers to the cloud makes sense — from both an efficiency and productivity standpoint. But does migrating to a cloud fax solution mean you will no longer be able to send or re…
Sending a Secure fax is easy with eFax Corporate (http://www.enterprise.efax.com). First, Just open a new email message.  In the To field, type your recipient's fax number @efaxsend.com. You can even send a secure international fax — just include t…
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.

706 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

20 Experts available now in Live!

Get 1:1 Help Now