Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

BGP with ISDN Backup

Posted on 2004-08-13
8
Medium Priority
?
974 Views
Last Modified: 2013-12-29
I have a problem with BGP and ISDN backup. What I want to achive is:

1. When the main link fails (in this case Frame Relay) - the eBGP route dies and I have a floating static with AD 200 pointing to Dialer1.
2. I then want Dialer 1 to dial the Main HQ Router - which it does.
3. I want the main link to then come back up - and for the peering to est and for the route from centre to come accross Frame Relay main link to Remote (this router). Which it doesnt????

Does anyone know why. I have denied BGP on the BRI interface and Dialer with an ACL (so that BGP doesnt keep the ISDN link up - like a passive-interface command in EIGRP - which you cant have on BGP).

Can anyone help???
0
Comment
Question by:c1sc0m4n
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 3
8 Comments
 
LVL 15

Expert Comment

by:scampgb
ID: 11793851
Hi

I can't think of any reason why this wouldn't work - I've done it with EIGRP with no trouble.

Just to clarify, the router is doing the dial-up in the event of the Frame Relay failure, but not hanging up when the FR is back?

Now for a few questions :)

When the frame-relay circuit comes back, does the router interface come up properly?
Can you ping the remote frame-relay interface OK?
What does the routing table (show ip route) show as your default route once the frame-relay is back?

If you could post the relevant parts of the config, that would help.

Thanks
Steve
0
 

Author Comment

by:c1sc0m4n
ID: 11794072
Yeh basically when main WAN link is restored (bareing in mind that I have continuous ping between two laptops) the ISDN just will not cancel call and re route traffic.

Yep main s0 int comes up fine
Im using IP unnumbered with loopback 0 - can ping fine
Route is still same:  B x.x.x.x/24 [20/0] via 172.16.1.10, 00:19:26

Intresting - if i turn cont ping off  - therefore no traffic over isdn - isdn shuts BRI/Dialer int down and traffic will then go over Serial 0 with no problems and without re-opening isdn call.

I too have had EIGRP working perfectly like this - i think its a weird BGP thing and maybe timers or something???

Configs are as follows:

Centre:

Current configuration : 2178 bytes
!
version 12.3
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname Tipton
!
boot-start-marker
boot-end-marker
!
username France password 7 123456
no aaa new-model
ip subnet-zero
no ip domain lookup
!
frame-relay switching
isdn switch-type basic-net3
!
interface Loopback0
 ip address 172.16.1.10 255.255.255.255
!
interface Loopback1
 no ip address
!
interface Ethernet0
 description Ethernet Interface to Paris LAN
 ip address x.x.x.x 255.255.255.0
!
interface Serial0
 no ip address
 encapsulation frame-relay IETF
 no fair-queue
 frame-relay lmi-type ansi
 frame-relay intf-type dce
 !
interface Serial0.1 point-to-point
 ip unnumbered Loopback0
 no cdp enable
 frame-relay interface-dlci 101
!
interface BRI0
 description ISDN Backup to Tipton
 ip unnumbered Loopback0
 encapsulation ppp
 dialer pool-member 1
 isdn switch-type basic-net3
 ppp authentication chap
 ppp multilink
!
interface Dialer1
 description Dialer to Tipton
 ip unnumbered Loopback0
 encapsulation ppp
 dialer pool 1
 dialer remote-name France
 dialer idle-timeout 60
 dialer string 532 (internal PBX)
 dialer load-threshold 5 either
 dialer-group 1
 ppp multilink
!
router bgp 100
 no synchronization
 bgp log-neighbor-changes
 network x.x.x.x
 neighbor 172.16.1.40 remote-as 400
 neighbor 172.16.1.40 ebgp-multihop 255
 neighbor 172.16.1.40 update-source Loopback0
 no auto-summary
!
ip route 0.0.0.0 0.0.0.0 1.1.1.1
ip route x.x.x.x 255.255.255.0 Dialer1 200
!
access-list 100 permit ip any any
access-list 101 deny   tcp any any eq bgp
dialer-list 1 protocol ip list 100
!
!
access-list 100 permit ip any any
access-list 101 deny   tcp any any eq bgp - not applied but has been and still the same :-(
access-list 101 permit ip any any
dialer-list 1 protocol ip list 100

Vice Versa for Remote.



0
 

Author Comment

by:c1sc0m4n
ID: 11794083
I realise my description is wrong on the Dialer ;-) - just ignore.
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 15

Accepted Solution

by:
scampgb earned 500 total points
ID: 11794372
Hi

Unfortunately BGP isn't my strong point, but I've got an observation that might point you in the right direction.

You have both the S0 interface and the Dialer configured as unnumbered, bound to Loopback0

This essentially means that they've got the same IP address.

When S0 goes down, the Dialer kicks in as it's the only valid route.
When S0 comes back, there's still traffic travelling down BRI0.

The traffic will still be getting to the correct next-hop.

When there's no traffic, the BRI0 is idle and shuts down.  At this point, and further traffic would go the S0 route.

Sorry that I can't give you a definitive answer, but I think that the problem is related to the above.

Are you able to configure different private addresses on the dialer and S0?
This is what I do to avoid confusion (because I'm a bear of very little brain).

Steve
0
 

Author Comment

by:c1sc0m4n
ID: 11795818
I will try that on Monday when I'm back at work :-/. Think you could be right - changing to a static IP may work or use another loopback.

I cant seem to find any info on BGP with backup ISDN on the net at all?

Anyway - thanks again I'll keep you posted.
0
 
LVL 4

Expert Comment

by:celsmk
ID: 11800185
Bare in mind is that BGP is keen of keeping routes out of flapping, therefore, if route selection criteria is matched between 2 links, it will keep the older stable one in place.

You will find the solution here at this thread: http://www.experts-exchange.com/Networking/Broadband/ISPs/Q_21074656.html
Use MED to sort out what is the preferred outbound interface.

Remember also that the same will apply to the router(s) on the other side of the links (main and backup).
0
 

Author Comment

by:c1sc0m4n
ID: 11808546
I created another loopback and everything worked fine - just goes to show what a fresh pair of eyes checking over your config can do. Thanks Steve.

Thankyou clesmk for the advice too - although I think this is more for a multihomed scenerio.
0
 
LVL 15

Expert Comment

by:scampgb
ID: 11809026
Glad I could help.  Thanks for the "A" :)
0

Featured Post

[Webinar] Lessons on Recovering from Petya

Skyport is working hard to help customers recover from recent attacks, like the Petya worm. This work has brought to light some important lessons. New malware attacks like this can take down your entire environment. Learn from others mistakes on how to prevent Petya like worms.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This program is used to assist in finding and resolving common problems with wireless connections.
This article is in regards to the Cisco QSFP-4SFP10G-CU1M cables, which are designed to uplink/downlink 40GB ports to 10GB SFP ports. I recently experienced this and found very little configuration documentation on how these are supposed to be confi…
Internet Business Fax to Email Made Easy - With eFax Corporate (http://www.enterprise.efax.com), you'll receive a dedicated online fax number, which is used the same way as a typical analog fax number. You'll receive secure faxes in your email, fr…
Monitoring a network: why having a policy is the best policy? Michael Kulchisky, MCSE, MCSA, MCP, VTSP, VSP, CCSP outlines the enormous benefits of having a policy-based approach when monitoring medium and large networks. Software utilized in this v…

636 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question