Solved

Hyper Threading will not enable in BIOS

Posted on 2004-08-13
16
3,719 Views
Last Modified: 2012-06-27
okie people, i'm really at a loss on this one and hope you guys can help me out!
i've done pretty much everything i can think of but i'm willing to try anything encase i missed an important step.
So here goes,

Motherboard, P4S800D-E.  I just upgraded the CPU from a 2.6 Northwood (non-ht, stepping C1) to a 2.8 prescott (HT, stepping C0)

Windows XP pro was installed on a partition with the northwood CPU and worked a like a dream.
After the CPU upgrade everything worked except the hyper threading.
Bios version 1004 was install then upgraded to 1006 after the new CPU was installed.
Windows device manager saw 2 x 2.8 Intel CPU's but Sisoft sandra/CPUID/task manager and Intels Hyperthreading diagnostics tool all said HT was turned off.

At this point i checked the BIOS POST screen, and only 1 CPU was listed, but the HT enabled option was still enabled, i tried turning this option off, rebooting then turn it back on again, but no difference.

Intels hyper threading utility tells me that the CPU is fine and HT enabled, but the motherboard and BIOS are not setup, however i later found out that Intel will only say the motherboard is working if its an intel based chipset, but the BIOS should say its ok.

okie, now i try a clean install of XP SP2 on a different partition, makeing sure i hit F5 to change the ACPI settings to enable uniprocessor with HT and ACPI Support, and again the same problem.

From what i have seen, the BIOS should detect 2 CPU's, and it doesnt, windows does detect 2 of them but for some unknown reason does not use them, perhaps im using the wrong HAL?

On my main OS i am unable to simply "update" the HAL in device manager as it only lists simple PC and my current config. On the other OS i am able to change to MPS, but this results in windows failing to boot, this i believe is because HT isnt MPS

Now, the way i see it is, there can only be a number of problems here.
1 BIOS is screwed  (i've tired old and new versions)
2 BIOS has wrong information (couldn't see any more options)
3 CPU doesnt work in HT mode (supplier tested before hand and said it worked)
4 motherboard chip-set not designed for "this" CPU (family and stepping is supported by Asus)
5 Windows setting incorrect (where do i start!)
6 ACPI / HAL information wrong (hum..)
7 Its all just wrong and wasnt ment to be!

as i said before, i've done pretty much everything i can think of, but please dont assume that i wouldnt of missed an important step!

Hope you can help

Darren
0
Comment
Question by:Darren_T8082
  • 5
  • 4
  • 3
  • +3
16 Comments
 
LVL 69

Expert Comment

by:Callandor
Comment Utility
The BIOS does not detect 2 cpus, but there should be a message in the BIOS that hyperthreading is enabled (it is on my Abit IC7-G board).  If you bring up task manager, you should see two graphs in CPU usage history if hyperthreading is working.  It's as simple as that.
0
 
LVL 1

Author Comment

by:Darren_T8082
Comment Utility
From some screen shots that i have seen, during POST it lists the name of the CPU and Speed it runs at, twice when HT is enabled.  Task manager, as i explained, only shows 1 CPU not 2,  but device manager see's both, Intels own utility says there is a problem

"ADVISORY! The Hyper-Threading Technology Test Utility

was unable to identify if all the core components are present, turned on or functional in this system.

Without all required components, Hyper-Threading Technology is not fully enabled."

now, i suspect it might have somthing to do with the HAL or BIOS but have not found the way to fix this yet.
0
 
LVL 69

Expert Comment

by:Callandor
Comment Utility
When you put in the new cpu, did you reset the BIOS?  That's a good practice, to make sure that old values are not left from the old setup.
0
 
LVL 1

Author Comment

by:Darren_T8082
Comment Utility
yup, clearned CMOS (and removed the battery for good measure) a number of times and with every change of BIOS, its as if the BIOS doesnt support the microcode for this CPU but i find that hard to believe since its listed in there support  section.
0
 
LVL 1

Expert Comment

by:ericcode
Comment Utility
Hyper Threading is the Technology that allows the 2 x CPU to appear in Windows Hardware manager. The Bios will see 1 cpu.
I am running a;
Gigabyte 8kpnxp
3.2Ghz pentium IV with HT
2 Gigs of Dual DDR 400

Also if Task Manager Shows 2 windows for CPU (in the performance tab) usage and they both show some movement its working. HT remindes me of some Video Cards with 2 CPUs on them.
From what you describe I believe it's just a problem that the Industry Cause.

Your BIOS will show 1 CPU. (Theres only one there :)  )
Windows will see 2.

Bit of a hack but it works. Kinda. Task Manager Doesn't lie, if Windows sees 2 CPUs HT is on and working. Especially if you Actually see 2 processors processing information in Task Manager > Preformance > CPU Usage.
0
 
LVL 1

Author Comment

by:Darren_T8082
Comment Utility
hum, intresting, okie if that is the case then something must be wrong with windows, Device manager shows 2 CPU's task manager doesnt...... Sisoft tells me it is disabled as does CPU-Z,  I'll put down Intels hyperthreading utility error down to it not being an Intel chipset..... assuming the BIOS is fine as is the CPU that only leaves windows and its HAL, and of course my original problem of getting it to work :)

although im sure i saw pics from reviewers when HT came about, showing 2 cpu's....just finished repacking my windows XP CD to SP2, i'll give it ago once more, in the intrest of my sanity which HAL should i be using? or shall i leave it to windows to decide!

0
 
LVL 10

Expert Comment

by:Dynamic1
Comment Utility
Task manager should show 2 CPUs. With Hyperthreading on. Something is AMUCK.
0
 
LVL 10

Accepted Solution

by:
Dynamic1 earned 500 total points
Comment Utility
Darren not to knock you mobo but personally I do not like sis chipsets and I would bet it is the bios-chipset that is causing the confusion. Is there a chipsewt driver update to go with that bios. I know sis does it a little different that intel chipsets.
0
Maximize Your Threat Intelligence Reporting

Reporting is one of the most important and least talked about aspects of a world-class threat intelligence program. Here’s how to do it right.

 
LVL 1

Expert Comment

by:ericcode
Comment Utility
Be very Carful in checking Task Manager. It only a thin grey line that devides the CPU USAGE HISTORY. Double check that. PAGEFILE USAGE HISTORY is full length and shows only one window.    2 CPU USAGE windows Very close together. It could look like 1 on a fuzzy screen. But if It's not there and Device Man shows 2 then something is up. But like you said, BIOS is Ok. Just double check that HT is Enabled and bios is done. Windows however will take some work.
Check System Information (In Accessories > System Tools) and in the Summary it should show 2 proccessor entries as well.
Another good tatic to try would be get a small HDD and Do a fresh OS install with WinXP pro. Maybe Upgrading from 1 to 2 cpu as apposed to turning on and off HT?
You got a wierd problem now. Try a fresh OS and that is a good control to test against.
0
 
LVL 69

Expert Comment

by:Callandor
Comment Utility
For another check, if you download Everest http://www.lavalys.com/index.php?page=product&view=1&subpage=5, under Motherboard->CPU, there will be a CPU#0 and CPU#1 for a hyperthreading system running.
0
 
LVL 2

Expert Comment

by:joey_the_ass
Comment Utility
Also, in windows XP task manager while showing the performance tab go on the toolbar to
view go to CPU history and make sure "one graph per CPU" is checkmarked.
0
 
LVL 2

Expert Comment

by:The_Maverick
Comment Utility
I'd be surprised if you were able to get Hyper-threading to work without reinstalling the OS - as I'd think that a HT aware HAL (Hardware Abstraction Layer) (the bit that interfaces the OS to the physical hardware present) would be different from what's loaded at present.

Can you do a quick/dirty install to another HDD?
0
 
LVL 1

Author Comment

by:Darren_T8082
Comment Utility
Sorted,  i dug up the Intel white paper on hyper-threading, as it turns out it needs ACPI 2.0 support for it to function.  The BIOS settings for this motherboard allow ACPI to be turned on but all so for version 2.0 to be turned of at the same time, by default it turns off version 2.  
Intels hyper-threading util, detects that the BIOS is fine now, although it still says the board doesnt support (this im 100% sure is because its not an intel board)

It might be unrelated but it may also have an effect, in that i rebuilt my Windows XP pro SP1 CD to SP2

I could test this to find out which one coursed it to stop by disabling ACPI V2 in the bios but frankly....its working and i'd rather not tempt fait!

Thanks for all your help guys, only thing is who to "accept" Dynamic1  and The_Maverick where the closest, Dynamic1 in that i tried the BIOS one more time and just so happened to read the white-paper before, and The_Maverick for somehow reminding me to rebuild my XP CD for a new install.

Anyway to split it?
0
 
LVL 10

Expert Comment

by:Dynamic1
Comment Utility
Yeas you can split it accepted and assisted. So I am curious sorry if i dont totally understand the above post so HT is working now?  Gotta love those sis chipsets :>) Glad to help ,Joe
0
 
LVL 1

Author Comment

by:Darren_T8082
Comment Utility
whoops i think i just messed that up...sorry!

ah yes its working a dream, my seventeen or bust score has increased by another 100,000 cEM/s
taking it to 860,000 cEM/s, im not sure how this can work, since according to there own website that means im using the equivalent of a 9.4 GHz CPU, but hay ho, the results are accurate and its flying!   Now all i need is to get rid of some of this heat from my prescott,

Actually the P4S800D-E deluxe has been 1st rate, with no problems up until now, using my original northwood and my p4s533 i was getting roughly half the cEM/s then with the same northwood on the P4S800, its memory bandwidth is slightly slower than an 875 but most of the other stats are about the same...cept £100 less :)

anyhow, thanks for the help guys!
0
 
LVL 10

Expert Comment

by:Dynamic1
Comment Utility
Darren Get the Zlaman CPNS 7000 CU/AL your prescott will love you for it and it is almost silent. Well here is the all copper one. http://www.newegg.com/app/ViewProductDesc.asp?description=35-118-109&depa=0 Check it out best on market.
0

Featured Post

Do You Know the 4 Main Threat Actor Types?

Do you know the main threat actor types? Most attackers fall into one of four categories, each with their own favored tactics, techniques, and procedures.

Join & Write a Comment

Suggested Solutions

The Rasberry PI is a low cost piece of hardware that you can have a lot of fun with through experimenting and building/working on projects like media players, running a low cost computer, build data loggers etc. - see: https://www.raspberrypi.org
In this article we have discussed the manual scenarios to recover data from Windows 10 through some backup and recovery tools which are offered by it.
This video discusses moving either the default database or any database to a new volume.
In this tutorial you'll learn about bandwidth monitoring with flows and packet sniffing with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're interested in additional methods for monitoring bandwidt…

772 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

11 Experts available now in Live!

Get 1:1 Help Now