Hiding my network places in the file open dialog box

I have a windows 2000 domain running AD with group policy implemented.  When users on the domain run any program in MS office and they go to file-->open they are able to see my network places and are able to expand it and see all machines in the domain.   How do I disable my network places from appearing in the MS office file-->open dialog box using group policy?
GPEARL383Asked:
Who is Participating?
 
oBdAConnect With a Mentor Commented:
If I set the three policies I mentioned before, the "Network Neighborhood" symbol still shows up in the drop down box, but it's completely empty, and you can't browse anymore (tested it in Word and Excel XP).
However, all those settings affect only the Explorer. If people can get access to a command prompt, they can still map drives. The best way to secure shares is to set the proper NTFS permissions; then they can access the share all they want, it won't help much ...
0
 
oBdACommented:
You can remove the network neighborhood by activating the following policies:
User Configuration\Administrative Templates\Windows Components\Windows Explorer
* Remove options "Map network drive" and "Delete network drive"
* Don't show "Workgroup Contents" in Network Neighborhood
* Don't show "Entire Network" in Network Neighborhood
(Note that these are not the exact names, as I am not using an English version).

In addition, you can remove the complete "Places" bar with
User Configuration\Administrative Templates\Windows Components\Windows Explorer\Standard Dialog
* Remove places bar in standard dialogs
0
 
gidds99Commented:
You can hide this via the registry:

http://www.winguides.com/registry/display.php/542/

This one may be relevant to your situation also:

http://www.winguides.com/registry/display.php/862/

Hope this helps.
0
Improved Protection from Phishing Attacks

WatchGuard DNSWatch reduces malware infections by detecting and blocking malicious DNS requests, improving your ability to protect employees from phishing attacks. Learn more about our newest service included in Total Security Suite today!

 
GPEARL383Author Commented:
oBda - I tried to modify the GP settings like you said but the problems still exist.  Users can gain access when they are in an office program like word, open a file and then select the dropdown list.  Do you think these setting need to be modifyed in the MS OFFICE group policy templates?
0
 
oBdACommented:
Which Office version is this? I have a custom policy template someplace with which you can set the Office places bar.
0
 
GPEARL383Author Commented:
office 2000
0
 
GPEARL383Author Commented:
This is whats happening: say a user is in excel2000, they go to file-open and then the file dialog box comes up.  When they go to the dropdown list to select what drive they want eg (the network drive, their H:\ drive which is home folder etc...) it will also come up with my network places etc.  Here it what is causing the problem...becasue if you select my network places certain users are able to see machines in domain including our servers.  From there if there are shared drives (that are not admin shares $) they are able to see shared drives and can gain access to info i dont want them to have....what do you think about this.  

Another thing i just relized is that this is just happening in excel...not other office programs....do you think this could be in the excel group policy template.  I have them installed and configured but maybee i missed something in the excel template???
0
 
oBdACommented:
Save this as PlacesBar.adm (or whatever.adm), import it into the GPO of your choice. Note that these are not "real" group policies, it's what Microsoft calls in changing terms "preferred settings", "branding", or "tattoing", as these changes are written to the registry outside of the \policies\ keys. This means that settings configured with this template will *not* simply "go away" (like group policies) if you set the policy to "not configured", these settings need to be explicitly undone, as back in NT4 and system policies.
If you see only the folders in the GP editor, but no policies to configure, you need to highlight the "Administrative Templates" key, then go to the "View" menu and uncheck "Show group policies only".
As usual: No warranties included, use it at your own risk, test it before you apply it in earnest:

====8<----[PlacesBar.adm]----
CLASS USER

CATEGORY "Additional Settings"

  CATEGORY "Microsoft Office 2000"

    CATEGORY "Places Bar"

      POLICY "Use small symbols"
        KEYNAME "Software\Microsoft\Office\9.0\Common\Open Find\Places"
        VALUENAME "ItemSize"
        VALUEON NUMERIC 0
        VALUEOFF NUMERIC 1
      END POLICY ; "Use small symbols"

      POLICY "Hide Desktop Icon"
        KEYNAME "Software\Microsoft\Office\9.0\Common\Open Find\Places\StandardPlaces\Desktop"
        VALUENAME "Show"
        VALUEON NUMERIC 0
        VALUEOFF DELETE
      END POLICY ; "Hide Desktop Icon"

      POLICY "Hide Favorites Icon"
        KEYNAME "Software\Microsoft\Office\9.0\Common\Open Find\Places\StandardPlaces\Favorites"
        VALUENAME "Show"
        VALUEON NUMERIC 0
        VALUEOFF DELETE
      END POLICY ; "Hide Favorites Icon"

      POLICY "Hide 'My Documents' Icon"
        KEYNAME "Software\Microsoft\Office\9.0\Common\Open Find\Places\StandardPlaces\MyDocuments"
        VALUENAME "Show"
        VALUEON NUMERIC 0
        VALUEOFF DELETE
      END POLICY ; "Hide 'My Documents' Icon"

      POLICY "Hide Network Icon"
        KEYNAME "Software\Microsoft\Office\9.0\Common\Open Find\Places\StandardPlaces\Publishing"
        VALUENAME "Show"
        VALUEON NUMERIC 0
        VALUEOFF DELETE
      END POLICY ; "Hide Network Icon"

      POLICY "Hide Recent Icon"
        KEYNAME "Software\Microsoft\Office\9.0\Common\Open Find\Places\StandardPlaces\Recent"
        VALUENAME "Show"
        VALUEON NUMERIC 0
        VALUEOFF DELETE
      END POLICY ; "Hide Recent Icon"

    END CATEGORY ; "Places Bar"

  END CATEGORY ; "Microsoft Office 2000"

END CATEGORY ; "Additional Settings"
====8<----[PlacesBar.adm]----
0
 
GPEARL383Author Commented:
Im going to test out what you gave me in my test envir.  But for now i agree that i am just going to set NTFS permissions and they wont be able to go anywhere...Thanks for input

GSP
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.