[Webinar] Streamline your web hosting managementRegister Today

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 308
  • Last Modified:

Help: Cisco 2620, configuration file cannot be saved?

Dear Experts,

I managed to break into my Cisco router using the Cisco recovery technique. I now got my Cisco reseted with a very basic cofiguration such as secret password, hostname, and ip address...

I then issued "wr" or "write memory" or "copy running-config startup-config" to save the above newly input configuration into NVRAM.

Each time, the router got power off and up again, then my router always could not find the configuration file on VRAM as it always prompted me to start input the configuration file from scratch.

FYI, I have also tried to enter the configurtion throgh the wizard and at the end it asked me to save configuration by pressing "2". Neither of this method can help as long as the router got power off and back on everything in term of configuration got missed all the time.

Your advice would be very much appreciate.

My IOS version is 12.1

Rgds,
Sot
0
sthay
Asked:
sthay
1 Solution
 
Don JohnstonInstructorCommented:
You need to set the config register back to 2102.

Router#config t
Router(config)#config-register 0x2102
Router(config)#end

-Don
0
 
sthayAuthor Commented:
Dear Don,

Perfect answer and thanks for your prompted reply.

I followed your instruction but I can you tell me abit more about what is "config-register 0x2102" does?

Thanks again
Sot
0

Featured Post

Never miss a deadline with monday.com

The revolutionary project management tool is here!   Plan visually with a single glance and make sure your projects get done.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now