• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 19742
  • Last Modified:

Error AMQ8101: WebSphere MQ error (893) has occured. (when creating an MQ Manager)

I am a little new to unix, and brand new to WebSphere MQ.  I intalled WebSphere MQ v5.3 on my unix server and cannot create an MQ manager.  I get the following error when running the command crtmqm -q mq1  -  AMQ8101:  WebSphere MQ error (893) has occured.  I have googled the error and found one solution, but I don't understand it.  I need to get this fixed in a hurry!

The solution was:
"The system I originally wanted to install MQ on has experienced both of these faults. The second system I installed on also suffered the same fate. The third system was an older Mandrake installation which worked fine but for other reasons was somewhat awkward to use. Having compared the trace above with a successful one taken from the third machine, I discovered that the next thing "crtmqm" did was to go and start looking for the NIS+ libraries. Sure enough, "/etc/nsswitch.conf" had the relevant "nisplus" entries for "passwd" and "group". If the "nisplus" keyword is added to "passwd" and "group" on the two systems which previously failed to work, both start working and the "crtmqm" command completes successfully."

I went into the file nssswitch.conf, but it did not have the "nisplus" entry.

Also in the solution, there is a claim that: "This error is not caused by the NPTL library as has been suggested elsewhere."

If anyone has any idea, please let me know!
1 Solution

I am not sure what cause your problem,but you can check Your windown's regedit.

there is not any QMGR_NAME in QueueManager Folder. This maybe cause your problem ,You can remove QueueManager Folder. Then ReCreate QueueManager.

Best of luck...
pretzyl1Author Commented:
I found out what I did wrong.  Simply, I didn't set the system file correctly for the semaphores.  Also .. I didn't reboot after I changed them, so after I did that it works using the default port 1414.

I am running MQ on Solaris and am having another problem.  Adding one message to the queue is fine, but when I try to add more they don't show up until I restart MQ.  To set up MQ, I created an MQ Manager, Local Queue, and then started the Listener.  
One other problem I am having is setting the port for the Listener to be on.  I've used -p port_number, but when I run an application, it gets an error saying it can't find the MQ Manager.  I checked to make sure the Manager's name, Queue name, and port number were correct also.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

The 14th Annual Expert Award Winners

The results are in! Meet the top members of our 2017 Expert Awards. Congratulations to all who qualified!

Tackle projects and never again get stuck behind a technical roadblock.
Join Now