"RPC server is unavailable" during Windows XP Print

We are using a Windows XP machine as a server to a number of Windows XP clients. The server's resources include a printer which works correctly from all clients but one.

The problem client is different from the rest because it is to have access to the server's printer only. As a result, there are no entries in the client's "User Accounts/Manage My Network Passwords". (The other clients do have an entry for the server machine here).

When we try to print from the problem client, we get the error: "The RPC server is unavailable." I have searched both here and in the Microsoft knowledge base without success.

The problem client is unusual in one other respect as well. Clicking "My Network Places/Entire Network/<server name> produces a password challenge, where it doesn't on the other machines. In other words, the problem client can't even *see* the shareable resources on the server.

The shared printer has all permissions enabled for the "Everyone" user.

Thank you for your assistance.
dangouldAsked:
Who is Participating?
 
bbaoConnect With a Mentor IT ConsultantCommented:
dangould, i think you might get me wrong, the checklist should be done on the problematic client, not that printer server running XP.
0
 
ahmedbahgatCommented:
is that machine workgroup is the same as the others?

cheers
0
 
dangouldAuthor Commented:
Yes, the problem client is in the same workgroup as the others including the server. I also ran the "Network Setup Wizard" on the client to see if it could fix the problem without success.
0
Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

 
ahmedbahgatCommented:
you may need to reapply XP sp2

cheers
0
 
dangouldAuthor Commented:
The client machine is running XP SP1A, so I don't think that is an issue here. Besides, with full access to the server machine, printing works as expected.
0
 
nazirahmedCommented:
dangould
i think its user names and password issue. You mentioned you are using a xp box as server, do the problem machine has same user accounts with identical passwords as the xp server?
0
 
dangouldAuthor Commented:
I'm not really sure what you mean here. The server has only an "admin" account, after all this is not a domain server.

The problem client has one account with admin privileges, just like the machines that can print successfully.
0
 
nazirahmedCommented:
Dangould
can you please confirm if you can access the xp server which is hosting the printer thorugh unc path or through its IP eg. \\10.10.10.1 ro \\servername and see if you can see all the shares. According to your above posts, you have managed to map to the printer but you get error when you try to print, see if you can map to it again. another thing is to make sure the password for both users is same, as you said the problem machine has same user as the xp server. For a check, try enabling guest account on xp server and see how it goes.
0
 
bbaoIT ConsultantCommented:
1) make sure the RPC service is running well
2) make sure "File and Printer Sharing for Microsoft Networks" component is check in the network properties
3) make sure the Workstation and Server services are running well

invoking "NET START" command in command prompt window will tell you which services are loaded and running

hope it helps,
bbao
0
 
dangouldAuthor Commented:
nazirahmed: The printing machine is running DHCP, so I don't know it's IP address in advance. I liked your idea about the Guest account so enabled it on the server. No luck. I also set a password on the guest account (net user guest *), then entered that password in "Manage My Network Passwords" on the client. Also no luck. I then added "MACHINE\Guest" and "MACHINE\Guests" to the printer sharing list on the server. Still no go.

0
 
nazirahmedCommented:
dangould, did you enabled guest account on the machine hosting the printer? you dont need to change the passwords for guest accounts on any machine, this is creating further complications.  try sharing a test folder on the server and see if you can access it from the problem machine, are you printing to the printer over th UNC path that is \\servername\printersharename OR printing over tcp/ip?
0
 
nazirahmedConnect With a Mentor Commented:
did you had chance to double check the postings of bbao?
0
 
dangouldAuthor Commented:
nazirahmed: I don't think bbao's posting applies here as other clients can print without a problem.

As for the guest account, I did some additional research on this since my last posting. Here's what Microsoft Press has to say about the guest account in "Windows XP Inside Out":

"The Guest account is also used for access to shared network resources on your computer when Simple File Sharing is enabled. "

I have Simple File Sharing turned off on the printer serving machine.

To answer your last question, I am referencing the printer by it's UNC designation. We are using DHCP here, so it's IP address is unknown.

0
 
dangouldAuthor Commented:
bbao: I did misunderstand your posting on the checklist. All of that was Ok.

Since my last post, I have solved the problem as follows:

On the server:
1) Set up a new security group called "Print Users".
2) Add one user to this group called "Print User". Assign a password.
3) On the server's file share, add this new group, and check "Deny" for all shared access.

On the client:
4) To "Accounts/User/Manage My Network Passwords" add SERVERNAME\Print User and provide the password established at the server in 2) above.
5) Reset the client.

This arrangement allows the client to print on the server, but without access to the server's file resources.

I don't understand the need for step 3) above, the new group should have automatically been denied. However, without the explicit deny, the printing client could still access the server's shares.

Since no one had the correct answer, I decided to split the points equally between nazirahmed and bbao. Thanks to both of you for taking an interest in this annoying problem.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.