• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 379
  • Last Modified:

Getting IGRP to work

I used to have RIP (w/ default routes entered) and everything worked great. I have disabled RIP and I am now trying IGRP and running into some problems.

Here is my network schematic:  http://mvpbaseball.cc/post.jpg

--I am running RIP on my cable router ( Built in by default, I cant turn it off

--I am running IGRP on router 2501a and 2501b.

--I have a default route entered in 2501 a of . Without this entered, 2501a could not ping WAN

--I have a default route entered in 2501b of

The problem is with router 2501b. I cannot ping the cable router from router 2501b. Any ideas?

Here is the sh ip ro of 2501b:

RouterB#sh ip ro
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is to network is variably subnetted, 2 subnets, 2 masks
C is directly connected, Serial0
C is directly connected, Serial0
I [100/8576] via, 00:00:08, Serial0
C is directly connected, Ethernet0
S* [1/0] via

  • 4
  • 3
1 Solution
Don JohnstonInstructorCommented:
The cable router doesn't have a route to the network. Back when you were running RIP, it learned it through 2501A.


Add a default route to the Cable Router for the and network


Redistribute the IGRP routes into RIP at the 2501A.

dissolvedAuthor Commented:
My cable router is having a fit about static routes. Currently it isnt keeping any in its table for some reason.

Please elaborate on Redistribution of the IGRP routes into RIP. I have heard about this, but have never really been told what it entails.

ps: My cable router only supports RIP. Not IGRP, is this going to be a problem?
Don JohnstonInstructorCommented:
On the 2501A:

Router#config t
Router(config)#router rip
Router(config-router)#redist igrp <as#>

Since you're using default routes on both Cisco's, you won't need to redistribute the rip routes into igrp.

Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

dissolvedAuthor Commented:
Check this out:

I've been experimenting all night. And I've found, I can only get my network fully operational when I am using RIP and default routes. Anything less WILL NOT work

 I tried IGRP (removed rip and default routes first) and it didnt work. So I put the default routes back and it still didnt work. Problem being , network couldnt ping the WAN. Any ideas?

Do they even use IGRP in companies ? Or do they use mostly OSPF nowadays?

dissolvedAuthor Commented:
Also, I tried IGRP and RIP together. Caused some conflicts. As soon as I disabled IGRP everything worked like a charm.
What version oif the iOS are you running. 12.2 has trouble doing IGPR to RIP.
Try using EIGPP.

Don JohnstonInstructorCommented:
"Do they even use IGRP in companies ? Or do they use mostly OSPF nowadays?"

Fewer and fewer. Cisco will stop supporting IGRP in upcoming IOS versions. I think I heard 12.3.

dissolvedAuthor Commented:
You're right. Just checked. EIGRP took over in 12.3
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

  • 4
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now