Solved

File Sharing Problem

Posted on 2004-08-15
18
267 Views
Last Modified: 2010-03-18
Hi,
I'm having a problem with file sharing on my pc. I'm hosting a home network. My pc is providing internet connection to the other PCs. The problem is that i'm able to provide the internet connection but not file sharing. Other computers on the network can't access shared files on my PC while i can access their files. The message says that users do not have permission access my pc.
Hope anyone could help with this.

u can also have a look at the message i'm getting when i try to access my pc from other PCs on the network here:
 http://img.photobucket.com/albums/v339/slimfady/problem.jpg

Thanx
0
Comment
Question by:slimfady
  • 6
  • 4
  • 3
  • +2
18 Comments
 
LVL 57

Expert Comment

by:Pete Long
ID: 11805044
Networking XP

*****Most Networking Problems with XP*****

Are caused by Firewalls (either hardware or software)
If you have Zone Alarm, Black ICE Defender etc turn them off! If the problem goes away, you need to reconfigure the firewall. Also Windows XP by default has a built in firewall (ICF) to disable
1.  Open Network Connections (Click Start, click Control Panel, and then double click Network Connections.)
 
2.  Click the Dial up, LAN or High–Speed Internet connection that you want to protect, and then, under Network Tasks, click Change settings of this connection.
 
3.  On the Advanced tab, under Internet Connection Firewall, select the following:  Clear the Protect my computer and network by limiting or preventing access to this computer from the Internet check box. This disables the firewall; your computer and network are then vulnerable to intrusions.


*****Full Walkthrough of networking XP Home*****

How to Set Up a Small Network with Windows XP Home Edition (PART 1)
http://support.microsoft.com/default.aspx?kbid=813936
How to Set Up a Small Network with Windows XP Home Edition (PART 2)
http://support.microsoft.com/default.aspx?kbid=813937
How to Set Up a Small Network with Windows XP Home Edition (PART 3)
http://support.microsoft.com/default.aspx?kbid=813938
How to Set Up a Small Network with Windows XP Home Edition (PART 4)
http://support.microsoft.com/default.aspx?kbid=813939
How to Set Up a Small Network with Windows XP Home Edition (PART 5)
http://support.microsoft.com/default.aspx?kbid=813940
How to Set Up a Small Network with Windows XP Home Edition (PART 6)
http://support.microsoft.com/default.aspx?kbid=814003
How to Set Up a Small Network with Windows XP Home Edition (PART 7)
http://support.microsoft.com/default.aspx?kbid=814004
How to Set Up a Small Network with Windows XP Home Edition (PART 8)
http://support.microsoft.com/default.aspx?kbid=814005



Adding XP to a network

http://www.practicallynetworked.com/sharing/xp/addxp.htm

Windows XP Network troubleshooting

http://www.practicallynetworked.com/sharing/troubleshoot/
0
 
LVL 12

Expert Comment

by:Gary Dewrell
ID: 11805059
Hi slimfady,

I found this article which seems to describe a simular issue.

Sometimes Internet Explorer doesn't recognize the internet connection exists. First thing to do when this happens is to check Internet Options>connections and be sure "Never Dial a Connection" is selected.

There is a trick I found on the Internet I use myself because I got this message constantly. It involves renaming a file. However, if you have multiple user profiles set up this won't be something to consider. The file Loadwc.exe loads the user profile information for Internet Explorer.


Find loadwc.exe and rename it DonotLoadwc.exe

Open the registry and Navigate to:
HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\WebCheck
Look for these two entries in the right pane. Double
click on each and modify its value to No
LoadSens
LoadLCE

That's it.

God Bless
0
 
LVL 12

Expert Comment

by:Gary Dewrell
ID: 11805065
slimfady,
sorry posted to the wrong message. Man thats 3 times in 3 days. I need a vacation!
0
Visualize your virtual and backup environments

Create well-organized and polished visualizations of your virtual and backup environments when planning VMware vSphere, Microsoft Hyper-V or Veeam deployments. It helps you to gain better visibility and valuable business insights.

 

Author Comment

by:slimfady
ID: 11805108
Hi PeteLong,
It doesn't seem that the problem is a firewall problem. The network was working properly with zonealarm. Anyway, i tried to shutup zonealarm and i disabled the windows built-in firewall and didn't make any difference. A firewall problem won't let the internet connection to be shared as well. Other computers can even disconnect my internet connection when i give them the access. So, it's just with file sharing.

thanx
0
 
LVL 57

Expert Comment

by:Pete Long
ID: 11805149
did you check parts 6 and 7 above?
0
 

Author Comment

by:slimfady
ID: 11805860
Hi Pete,
steps 6 & 7 are the basic way to start file sharing. That's what i usually do whenever i start a network. The problem is that the sharing service has stopped working, only on my pc. Other computers on the network can still access each other and i can access those computers.

The message i get is similar to the one in step 7 (permission denied). But i get that message when other computers click on my pc's name in the workgroup list as u see in the picture i included. All the computers in the network including mine, has the same network domain (192.168.0.0).

This problem could be solved if i can find a way to reset all the network settings on my windows installation as if i just installed windows.
0
 
LVL 12

Expert Comment

by:PCableGuy
ID: 11806704
Hi slimfady,

I noticed in your .jpg that it says the Server service is not started. Did you check to see if Server is started in Servcies?

Start - Run - Services.msc
0
 

Author Comment

by:slimfady
ID: 11807045
hi PcableGuy,
yeah, server is started in services.
0
 
LVL 57

Expert Comment

by:Pete Long
ID: 11807941
on both PC's?
0
 
LVL 18

Expert Comment

by:crissand
ID: 11811514
If the pc that is not sharing resources is Windows XP Professional, enable simple file sharing and be sure that guest account is not disabled. If you don't want to lower your security, you must declare in Local users the other users that want to connect to your shared resources, with their logon name and password, and add them to every shared resource permisiion and security.

If it's another OS, write it here and we'll try to help you.
0
 

Author Comment

by:slimfady
ID: 11813788
Hi,
Seerver is started on both PC's already. All Computers are using windows XP professional. Guest accound is enables. Acess is allowed to "Everyone" with no user name or login. I tried both with simple file sharing and without it. Didn't make any difference.
Anyone knows how to reset all the network settings? this file sharing used to work fine, but there's just something wrong.
0
 
LVL 18

Expert Comment

by:crissand
ID: 11813870
Start the server service on feedo-pc, as seen from message. Open the Nic properties and see to have installed and enabled File and printer sharing for Microsoft network.
0
 
LVL 12

Assisted Solution

by:PCableGuy
PCableGuy earned 250 total points
ID: 11817144
slimfady, this might be worth a try.

You might be able to track down or look for clues using Event Viewer. But, Local Security Policies on your XP Pro machine need to be setup properly to log events.

First steps:
Start - Run - secpol.msc
Local Security Policies Window should appear
Select Local Policies to see the Sub-Folders
Select Audit Policies
For each option in the right panel you can double-click on it to select Success or Failure logging

Make sure to Enable Success and Failure logging for (in the right panel):
Audit Logon Events
Audit Account Logon Events


Second Step - Access Feedo-PC
Try to access Feedo-pc
If a logon attempt is getting through, it will log the event in Event Viewer, under the Security Log


Third Step - Check for the presence of Logon Event
Check Event Viewer
Start - Run - eventvwr.msc
Select Security
Check the Security Log for Success Audit or Failure Audit

Also, the lack of a logon attempt in Event Viewer, may give a clue too.
0
 

Author Comment

by:slimfady
ID: 11820712
Hi Crissand,
the file sharing is enabled but still it won't work.
PCableGuy,
You were right, the login trial was recorded. But i couldn't understand the given error. You may want to have a look at it:
http://img.photobucket.com/albums/v339/slimfady/log.jpg

Thanx
0
 
LVL 18

Accepted Solution

by:
crissand earned 200 total points
ID: 11821363
The user have blank password.

Go to Start -> Programs -> Administrative Tools -> Local Security Policy -> Local Policies -> Security Options.

Find "Accounts: Limit local account use of blank passwords to console login only" and disable it.
0
 
LVL 12

Expert Comment

by:PCableGuy
ID: 11826432
I'm not sure exactly what the message means. But I suspect an authentication issue.

One thing to check is the Local Security Policy (or Settings) for Feedo-PC. Check the policy for "Access this computer from the network." If this incorrect, it can restrict access across a LAN.

Start - Run - secpol.msc
Select Local Policies to see the Sub-Folders
Select User Rights Assignment

Find in the right pane: Access this computer from the network
Select it, then inspect the list.

If the Everyone group is not in the list, try adding Everyone into the list to see if it changes the logons to Feedo-PC.
If that fixes it, you might want to adjust that list to best balance your security/access needs.
0
 

Author Comment

by:slimfady
ID: 11829901
Thanx a lot PCableGuy & Crissand,
I removed the limit on blank passwords and sharing went back to normal.
Also thanx for everyone else who contributed trying to find the solution.

Peace
0
 
LVL 12

Expert Comment

by:PCableGuy
ID: 11830374
OK, thnx for the points. Glad to hear its working...
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article is in response to a question (http://www.experts-exchange.com/Networking/Network_Management/Network_Analysis/Q_28230497.html) here at Experts Exchange. The Original Poster (OP) requires a utility that will accept a list of IP addresses …
An article on effective troubleshooting
Although Jacob Bernoulli (1654-1705) has been credited as the creator of "Binomial Distribution Table", Gottfried Leibniz (1646-1716) did his dissertation on the subject in 1666; Leibniz you may recall is the co-inventor of "Calculus" and beat Isaac…
Are you ready to implement Active Directory best practices without reading 300+ pages? You're in luck. In this webinar hosted by Skyport Systems, you gain insight into Microsoft's latest comprehensive guide, with tips on the best and easiest way…

740 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question