Solved

Slow connection speed using linksys WRT54GS router

Posted on 2004-08-15
11
2,711 Views
Last Modified: 2012-06-22
Hello all.  I recently bought a Linksys wireless router (WRT54GS) and wireless card (WPC54GS) for my home, both of which are 802.11g compliant (with Speedbooster).  My connection speed is extremely fast when connected directly to the cable modem.  When hardwired to the router, my speed remains reasonably fast.

The problem arises when I connect using my wireless card.  Connection speed falls from ~125 Mbps to an inconsistent 2-54 Mbps and appears to degrade over the course of several hours, although this too is inconsistent.  The interesting part is that for the first 2 days I had the router connected, my speed was consistently 125 Mbps.  After that, my connection speed has been all over the place... sometimes I even have trouble staying connecting.

Troubleshooting the problem I have ruled out any issues with TimeWarner, my firewall (BlackIce), or anti-virus software (Symantec).  My encryption is set for 128 bit WEP and while I had MAC on for a while, I've taken it off for now.  I don't believe the router location is causing the problem either b/c my signal strength remains "Excellent" to "Very Good."  I still have the same issues if I am 10 feet or 100 feet from the router.

Any thoughts on how to fix this?  Right now I'm ready to throw my Linksys router out the window!  Help...

Thanks.
Brian
0
Comment
Question by:yoda5
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 4
  • 3
11 Comments
 
LVL 1

Expert Comment

by:bladefist
ID: 11810677
You may have some interference.  Wireless telephones, microwaves, cell phones. There are tons of things that can affect it.  There is not a lot you can do if your in an area with all kinds of interference.  You can try changing the frequency or channel that the router sends/receives at just incase your interfering with any other nearby wireless routers. Hope this helps.

PS. I have the same router, and It works pretty good...So blame the router just yet
0
 

Author Comment

by:yoda5
ID: 11813662
Assuming interference is the problem, wouldn't that negatively affect my signal strength?  I was assuming this to be the case.  Let me know if I'm wrong.  I've tried several different channels but I haven't gone through and tried all 11 yet...
0
 
LVL 1

Accepted Solution

by:
bladefist earned 400 total points
ID: 11813972
No.  It doesnt have to affect your signal strength.  At my work, we had great signal strength, but everything was running soooo slow. It took us 6 months to figure out we had inteference in our coverage area. We were lucky enough that changing channels solved the problem. You may not be that lucky. I run that exact router at my house, and it works okay. It's upstairs away from anything that could interfere w/ it.  So try changing the channels, and play w/ some of the settings on the router. Disable wep and stuff like that while testing. WEP could slow things down.
0
How Do You Stack Up Against Your Peers?

With today’s modern enterprise so dependent on digital infrastructures, the impact of major incidents has increased dramatically. Grab the report now to gain insight into how your organization ranks against your peers and learn best-in-class strategies to resolve incidents.

 
LVL 28

Assisted Solution

by:mikebernhardt
mikebernhardt earned 100 total points
ID: 11814078
Remember the following:
1.  802.11g has a maximum speed of 54Mpbs. Each step downward is signal strength is also a negotiated step downward in speed between your card and the router.
2. That 54Mbps includes all the wireless overhead. In terms of your actual data, you shouldn't expect more than 30 Mbps of actual IP data.
3. Now start taking off percentages for signal strength.
4. If you have any kind of interference, as mentioned earlier, it won't affect your signal strength. But it will cause corrupted wireless frames, requiring lots of data retransmission. If just 1/2 of the frames had to be retransmitted only once, that cuts your bandwidth by 25%.

You can see that if you had some kind of radio interference going on, you could end up with the results you're experiencing. Try
0
 
LVL 28

Expert Comment

by:mikebernhardt
ID: 11814093
sorry! Try changing channels as suggested, and hopefully you'll get a lot better performance. But also let go of the expectation that you should have anything close to wired speeds on your wireless network.
0
 

Author Comment

by:yoda5
ID: 11814105
Okay.  I will try tonight and see what happens.  Also, when I start testing all the new settings, when, if ever, do I need to reboot the router and/or my PC?  I was never 100% clear on this so in the past I have always powered down the cable modem for 1 min (per TimeWarner's recommendation albeit timely) and rebooted my PC to pick up any changes.  I want to ensure I am properly testing before assuming that a setting does not work but I also want to minimize any unnecessary delays.
0
 
LVL 28

Expert Comment

by:mikebernhardt
ID: 11814406
If you're just messing with your wireless speed, you definitely don't need to reboot the cable modem. Is your PC getting it's DHCP settings from the router or from Time Warner? Normally it's from the router itself. Normally you don't need to reboot the router but you may need to reboot the PC depending on what you're doing.
0
 
LVL 1

Expert Comment

by:bladefist
ID: 11814410
you wont have to reboot the router. Infact, dont do that. When you save changes that requires the router to reboot, it will do it for you. you'll notice your connection drop for a second...and next thing you know...things are fine

You shouldnt need to reboot your PC ever.  However, if you right click on network places, go to your connect, right click, and push disable...wait a second...then push enable...It will do the same affect as rebooting your pc, w/o all the hassle.  The only time you need to reboot your cable modem is when you change settings in the router that 'matter' to the cable modem. Like MAC addresses, or hmm...im drawin a blank...not a whole lot of reasons to reboot the cable modem really. Unless obviously, you are having problems w/ your cable internet, and its not your routers fault.
0
 

Author Comment

by:yoda5
ID: 11817057
ok... now i'm a little confused re: mikebernhardt's comments.  so what exactly does the ole' linksys "speedbooster" technology do?  i thought the normal 802.11g protocol was 54 Mbps and speedbooster pushed it beyond that limit.  the reason i assumed i was getting a 125 Mbps connection speed before is b/c my "wireless network connection status" window told me that was the case.  i am under the assumption that this reading is more or less accurate.  is it not?  fyi, now that i am playing with my channel settings again, i am getting 125 Mbps readings again, just like i had for the first two days i had the router up and running.  i'm keeping my fingers crossed that this doesn't degrade w/in the next hour since i just changed the settings 5 min ago...
0
 
LVL 1

Expert Comment

by:bladefist
ID: 11821185
It would seem the speedbooster technology is just a way of reducing the overhead involved with transmitting wireless packets. So the speedbooster clumps the packets together in some way...blah blah.  Speedbooster isn't going to do you any good if you have interference.  And since your network is slow at 10 feet, im guessing you have some major inteference.  Let me know how the channel changin goes
0
 

Author Comment

by:yoda5
ID: 11821507
the channel changing seemed to work for the 2 hrs i was online last night but i'm still a bit skeptical since the first go around my connection speed was great for the first 2 days before it started to decline.  i'll keep my fingers crossed.  i should have gone through all of the channels upfront to search for the best connection (i went through 3 of 11) but i was under the impression that signal strength would drop with an increase in interference.  at any rate, thanks for the help guys!  great job!
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Provide internet access from one windows PC to another 16 147
BGP Local Preference 5 77
Cisco RV320 Gateway to Gateway connected but not passing traffic 6 59
wifi security 11 41
It happens many times that access list (ACL) have to be applied to outgoing router interface in order to limit some traffic.This article is about how to test ACL from the router which is not very intuitive for everyone. Below scenario shows simple s…
Tired of waiting for your show or movie to load?  Are buffering issues a constant problem with your internet connection?  Check this article out to see if these simple adjustments are the solution for you.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

739 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question