Solved

Full Text Search Question again

Posted on 2004-08-15
8
195 Views
Last Modified: 2008-03-17
Hi All.

I need your guys help quickly

Our FTS query, had decided to be uncooperative and not work on our live SQL box:

SELECT HotelSearchLookup.Hotel_Code, A.Rank
FROM   HotelSearchLookup AS HotelSearchLookup
INNER JOIN CONTAINSTABLE(HotelSearchLookup, *, 'アグラ空港')  AS A ON HotelSearchLookup.ID = A.[KEY]
GROUP BY HotelSearchLookup.Hotel_Code, A.Rank
ORDER BY A.Rank Desc

This works fine on the development box, in any language we see fit to throw at it. I have looked and looked and cant find any differences between the two servers. I have even copied the noise word files between the two. It still returns the following on the live box only:

"Execution of a full-text operation failed. A clause of the query contained only ignored words. "

Where should i be looking for differences between the two machines, i have tried many things:

sp_MShelpcolumns 'HotelSearchLookup'
xp_MSfulltext
sp_help_fulltext_columns

All giving me the same results on each box.

English is ok, as is any other roman char set, but Japanese and chinese, all return the above error. Where should i be looking experts? I have also emptied the noise files for those langauges and rebuilt the catalog on serveral occasions.

Thanks

Stressed Eric...
 
0
Comment
Question by:gravity100
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 3
8 Comments
 

Author Comment

by:gravity100
ID: 11807106
The "アグラ空&#28207" is just the way this forum is displaying the japanese Char set by the way. Its not what we are searching for.

0
 
LVL 11

Expert Comment

by:Sven
ID: 11809108
If you do not need the FTS noise files, try to save them as empty files! You should not get the "ignored words" error again. Also if your are using japanese charset in the search, you should set the full text catalog to japanese!
0
 
LVL 75

Expert Comment

by:Anthony Perkins
ID: 11810264
I am going to have to pass on this question (and I think you know why)
0
Do you have a plan for Continuity?

It's inevitable. People leave organizations creating a gap in your service. That's where Percona comes in.

See how Pepper.com relies on Percona to:
-Manage their database
-Guarantee data safety and protection
-Provide database expertise that is available for any situation

 

Author Comment

by:gravity100
ID: 11816880
Hi

I have already emptied the noise files, and ran every check i can think of, to check both servers are identical (BTW, the server that works, i have not touched the noise files anyway). Sorry acperkins, i dont know why you want to pass on this question? Darthsonic, can you explain what you mean by setting the full text catalog to japanese?

Thanks
0
 
LVL 11

Expert Comment

by:Sven
ID: 11817881
Go to the table you are full text indexing and see the full text settings/properties. There you can change the standard language of the index from english or neutral to japanese!
0
 

Author Comment

by:gravity100
ID: 11819421
Hi Darthsonic

Thanks for this info, after much fiddling, i have manged to get it to work for now. I have indeed changed the word breaker to Japanese (this is what your referring to right?) I have read many posts saying if you do this, then the other languages wont work? Do you know if this is true, Ours seems to be working, but not 100% convinced of its accuracy anymore.

I am also puzzled, as to why, with no setting changes, using word breaker of US English (1033), we have no problem searching for japanese on our development box? Any ideas?

Points ready to be awarded....

Thanks.
0
 
LVL 11

Accepted Solution

by:
Sven earned 500 total points
ID: 11819440
Depends on noise files I think! If the files are empty, there should be lesser differences between the selected languages. The main difference is the conjunction of words. So if you select english and you are searching for "done" SQL should find "do", "does", "did" as well. If you are using different languages for your search I would prefer setting up more than one full text catalog, one for each language!
0
 

Author Comment

by:gravity100
ID: 11819589

Thanks for the support, to close this for all that follow;

I have a single lookup table that has all languages contained within it (i need that as i dont know what language the person is seaching in)
All the fields have a word breaker of Japanese
All noise files have been emptied.

The resulting Id's returned, are used to get the actual records in the language they are expecting. I.e if you search an english word in the japanese section it will return japanese results.

At the moment, it seems to be working, All languages. Very quick. (Chinese, Japanese French, Italian, English, German)

P.S i remove the noise words (i hope) from the query before they get to SQL, that was the best way for us to do it.

Thanks, enjoy your points...
0

Featured Post

How Blockchain Is Impacting Every Industry

Blockchain expert Alex Tapscott talks to Acronis VP Frank Jablonski about this revolutionary technology and how it's making inroads into other industries and facets of everyday life.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Recently we ran in to an issue while running some SQL jobs where we were trying to process the cubes.  We got an error saying failure stating 'NT SERVICE\SQLSERVERAGENT does not have access to Analysis Services. So this is a way to automate that wit…
In part one, we reviewed the prerequisites required for installing SQL Server vNext. In this part we will explore how to install Microsoft's SQL Server on Ubuntu 16.04.
Via a live example combined with referencing Books Online, show some of the information that can be extracted from the Catalog Views in SQL Server.
Using examples as well as descriptions, and references to Books Online, show the documentation available for datatypes, explain the available data types and show how data can be passed into and out of variables.

630 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question