Problem joining Windows 2000 Professional PC to Windows 2000 Advanced Domain Server

Dear Experts,

During the installation of a Domain Controller Server running Windows 2000 Advanced Server, I have trouble joining two PCs running Windows 2000 Professional to it, while the other two PCs and two Laptops running Windows XP Professional were easily configured to join to it. My colleague told me that he had the same problem when he was setting up a server at another location. But he played around with the settings and eventually the PCs joined the Domain. The problem is that he forgot what he did. Somehow it's something with Windows 2000 and Windows 2000 Advanced Server, because there was no problem at all to connect Windows 2000 PCs with Windows NT Domain Controller Server. Please show me the way.

Thanks a million.
Wang-Shu Tsai
TsaiAsked:
Who is Participating?
 
RanidaeConnect With a Mentor Commented:
Hi Tsai,

This smells of DNS issues.  Is DNS running on the Domain Controller?  If so, ensure your workstations are pointing to the DC for DNS.  You may want to check your DNS and ensure it is configured properly.  Pointing your 2k workstations to your ISPs DNS server typically doesn't work for numerous reasons.  

Check that out and see if it helps...
0
 
chadCommented:
Hi Tsai,

What kind of troubles are you having? are you getting error messages?  anything in event viewer on the server and client?
try adding the clients computers to ad before adding them to the domain from the client side.
is tcp/ip settings correct? can the clients ping the dc by name?
happy trails and good luck
KaBaaM
0
 
Rob StoneCommented:
Its probably a DNS issue.

Are the clients setup for DHCP and if so are the DNS settings correct (ie, do they point to the correct server)?

As KaBaaM said, we need more info on the errors before we can help you.
0
Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

 
TsaiAuthor Commented:
I am repasting the message because of those numbers which should be " and '.

>>>

The Server running Windows 2000 Advanced Server is configured as a domain controller (where the clients authenticate at the server), but DHCP is disabled/not installed. It’s IP address is set to static, and it is x.x.x.5 and subnet mask is 255.255.255.0. The clients have static IP addresses too, from x.x.x.11 to x.x.x.16, and with the same subnet mask.

To join Windows 2000 Professional PCs to the Windows NT Domain, normally we right click on “my computer”, then “properties”, then click on “Network Identification” tab, then select “Domain” under “Member of” frame, then enter the domain name and click “OK” button. After a while it should popup an authentication dialog box waiting for the user name and password. After entering the information and click “Ok”, for a few moment later a popup message saying “Welcome the domain” displays.

Similar steps apply to joining Windows XP Professional PCs to the Windows NT Domain.

Well, for joining PCs to Windows 2000 Advanced Server was where the problem started. Everything went well joining Windows XP Professional PCs. When I was joining Windows 2000 PCs, everything went well up to the point where the authentication dialog box appeared prompting for the user name and password. I entered the information and clicked “OK”. Then a moment later an error message popup saying that it can’t find the domain path/name. It does not make sense, because I tried entering a different domain name at the “Domain” input box under “Member of” frame, it immediately tells me that it can’t find the domain name before it brings up the authentication box.

I can ping the domain from Windows 2000 PCs, using the IP address. I did not try using the name of the server. I can even see the server and its shared folders by logging on to the Windows 2000 PC with the local user account, but of the same account name created on the server. So it seems like that the server is authenticating the users.

It might be a setting, or might be a bug between Windows 2000 Advanced Server - the domain controller and Windows 2000 Professional.

Thanks for your assistance. Very appreciated.
0
 
Rob StoneConnect With a Mentor Commented:
Yes, I'm about 95% sure its a DNS issue.

Try pinging the 2000 Servers DNS name and see if that works.

Do an IPCONFIG/ALL on the 2000 machines and compare it too the XP machines. Check what the DNS IP is pointing at.

You may also need to put the IP of the DNS Server in the HOSTS file on the 2000 clients. Only try this if the above is all OK.

On the DNS Snap in on the server check to see if its picking up the clients as well. It will have the XP machines and should have the 2000 machines too. If it hasn't, add one in there and see if that helps.
0
 
TsaiAuthor Commented:
To Kabaam: What is ad in your sentence "try adding the clients computers to ad before adding them to the domain from the client side"
0
 
TsaiAuthor Commented:
To Stoner79: When I use ipconfig on my computer (Windows XP Pro connecting to Windows NT Domain) all I see is:

>>>

Connection-specific DNS Suffix  . :
IP Address. . . . . . . . . . . . : 192.168.21.119
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . : 192.168.21.1

<<<

the address of "Connection-specific DNS Suffix" is not showing, even, on my computer, I manually enter the ip address of the DNS for "preferred DNS server" on "Internet Protocol (TCP/IP) Properties"
0
 
RanidaeCommented:
Try "ipconfig /all", it will then give you the DNS settings too.

Compare from an XP box to a 2k box.
0
 
chadCommented:
Sorry, ad = active directory.
at the domain controller add the computer as a client pc.  you do not need to have the computer connected to the network when you do this.  then boot the computer up and attempt to add it again.  The domain controller will already have the info and should be easier to authorize for addition to domain.
I agree with the others here though.... smells like a DNS fault ( oh no wait... that was lunch...ewww)
If it is a DNS problem, my suggestion will not help.

>>> I manually enter the ip address of the DNS
Are you using the ip address for YOUR DNS server on YOUR network?
I have seen multiple times lately, where folks will use the DNS settings from the ISP instead of the local server.
Your client pcs should not have any ISP infor anywhere in their configuration, only local settings.  Then set the DNS as a forwarder to ISP.
0
 
chadCommented:
oh... and thanks for deleting that one comment... I was getting dizzy trying to read it.  :-)
0
 
hobbyjpCommented:
Give this a try,
under properties for " My Computer" click  on the tab " Computer Name" Click change. Do not change the name but select more. put in the Dns Suffix of your domain. Then go to Network properties And select Advanced then Dns. Select " Append these DNS Suffixes In order" enter you fully qualified domain name like this .
Apples.tree.com
tree.com
.com

So that would be three different entries, Aslo select append this dns suffix and put in you FQDN. After you have done all of this reboot, then try to add the computer by putting in the full qualified domain name not just the abbriviation.
0
 
TsaiAuthor Commented:
Dear Experts,

I have tried all your suggestions, especially these main ones, but none of them worked. Sorry for the delay. My internet wasn't working properly for many days until now.

hobbyjp, I have not tried yours yet. I will try it soon.

1) Adding client computers to active directory and users… , then adding them to the Server did not work.
2) Checked tcp/ip using ipconfig /all on Windows 2000 and Windows XP PCs. It was set to obtain DNS address automatically so it was getting some weird DNS ip, because these computers are getting IE from a DSL modem. After I set DNS address on the Windows 2K PC to point to the server and I used ipconfig /all again, it was pointing to the server. But it still did not work. Pinging still works with ip or server name. By the way, the outputs for ipconfig /all on Windows 2K and XP are the same to their respective properties.
3) Without configure the DNS ip, I can still ping Server using the server name.
4) Checked whether DNS is running on the server. Yes, it is running on the server since setting Windows 2000 Advanced Server to be a domain controller it is mandatory that it runs DNS.
5) Checked whether Windows 2K clients are added to DNS on Active Directory and Users… No, there are only Windows XP clients. It makes sense though, because the Windows 2K clients had never been added to the Server.

Questions:
1) How do you put the IP of the DNS Server in the HOSTS file on the 2K clients? Is it by adding the DNS ip address to "preferred DNS server" on "Internet Protocol (TCP/IP) Properties"?
2) How to set DNS as a forwarder to ISP.

Can I have your email address so I can send two screen shots of when I was about to join the client to the Server and when it returned an error message. These screen shots should give you a clearer picture of the situation.
0
 
hobbyjpCommented:
well you can put the dns server in the host file by going to %system root%\winnt\system32\drivers\etc , inside the etc folder you will find a file named hosts, open this folder with notepad and add the dns servers name and ip address. inside the file there will be instructions on the format of this. if you also add your domain controller in this file this could also fix your problem. As far as setting DNS to foward onto other DNS servers you do this withing the console for dns. open DNS, under DNS there will be the name of your server, right click on this and go to properties. their you will see the tab for fowarders. just enable fowarders by checkign the box and adding the ip of your ISP.
0
 
TsaiAuthor Commented:
to hobbyjp:
how to go about to open DNS?
0
 
hobbyjpCommented:
to get to your DNS console, on your server go to start , settings, control panel,  administrative tools. inside this folder you will see DNS. Once there you will be able to perform the steps i mentioned.
0
 
TsaiAuthor Commented:
to Stoner79:
I have tried putting the dns server in the host file on Windows 2K Pro client, but no luck still.

to hobbyjp:
1) Thanks for showing me on how to put dns server in the host file.
2) I don't see DNS under administrative toos on Windows 2000 Advanced Server.
0
 
Rob StoneCommented:
Sounds like the DNS Service isn't running on the Server.

How many Servers do you have and what one is running DNS and/or WINS?

When you install and configure DNS it installs the DNS Snap in hobbyjp is talking about.

Did you have the IPCONFIG/ALL info from a machine that works and the machine that doesn't?
0
 
TsaiAuthor Commented:
To Hewittg, and all the experts:

Well, actually, no one has really answered my question. If all the experts who had attempted to answer my question confirm that it is a known DNS issue, then I can consider my question answered / problem solved. Then I can split the points to all the experts equally.

Thank you.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.