Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people, just like you, are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
Solved

Cisco Router: Bad mask /32 for address

Posted on 2004-08-16
7
4,703 Views
Last Modified: 2008-02-07
I'm having problems adding an single secondary IP address with a subnet of 255.255.255.255 to my ethernet1 interface on my SOHO 91 router.   When I attempt to add the "Ip I get Bad Mask /32 for address 64.83.x.x"  The method I'm using to add the IP is:

enable
interface ethernet1
ip address ip address 64.53.x.x 255.255.255.255 secondary

I can successfully add it with a mask of 255.255.255.0, but I'm not really wanting that since i have a block of 8 IP's not the whole range.  Here is my config:

!
! Last configuration change at 13:32:14 CST Mon Aug 16 2004 by router
! NVRAM config last updated at 13:32:16 CST Mon Aug 16 2004 by router
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname xxxxxx
!
logging queue-limit 100
!
clock timezone CST -6
ip subnet-zero
!
!
!
!
!
!
!
!
!
interface Ethernet0
 description Interal LAN
 ip address 192.168.2.252 255.255.255.0
 ip nat inside
 no cdp enable
 hold-queue 32 in
 hold-queue 100 out
!
interface Ethernet1
 description Internet
 ip address 64.53.x.x 255.255.255.0 secondary
 ip address 206.74.x.x 255.255.255.0
 ip nat outside
 duplex auto
 no cdp enable
!
ip nat inside source list 102 interface Ethernet1 overload
ip nat inside source static tcp 192.168.2.1 25 206.74.x.x 25 extendable
ip nat inside source static tcp 192.168.2.1 21 206.74.x.x 21 extendable
ip nat inside source static tcp 192.168.2.1 80 206.74.x.x 80 extendable
ip nat inside source static tcp 192.168.2.1 443 206.74.x.x 443 extendable
ip nat inside source static udp 192.168.2.1 53 206.74.x.x 53 extendable
ip classless
ip route 0.0.0.0 0.0.0.0 206.74.x.x
no ip http server
no ip http secure-server
!
access-list 102 permit ip 192.168.2.0 0.0.0.255 any
!
line con 0
 exec-timeout 120 0
 no modem enable
 stopbits 1
line aux 0
 stopbits 1
line vty 0 4
 access-class 23 in
 exec-timeout 120 0
 login local
 length 0
!
scheduler max-task-time 5000
!
end

0
Comment
Question by:microbolt
  • 3
  • 2
  • 2
7 Comments
 
LVL 43

Expert Comment

by:JFrederick29
ID: 11813639
A 255.255.255.255 mask dictates a single IP address, hence the reason you get a bad mask error.

If you have eight addresses, use a 255.255.255.248 mask.

ip address 64.53.x.x 255.255.255.248 secondary
0
 
LVL 4

Expert Comment

by:celsmk
ID: 11813654
If your intention is to connect your 64.53.x.x subnet of 8 hosts to your ethernet 1, you should configure "ip address 64.53.x.x 255.255.255.248 secondary".
0
 
LVL 6

Author Comment

by:microbolt
ID: 11813721
On the Block of IPS my range is from 112 to 119.  If I use 255.255.255.248 then would 112 become unusable?  Currently I amd able to use the IP if I assign it with a mask of 255.255.255.0.  I'm just going to be using these IPs for webservers and all eight of the IPs will be on the cisco router.  
0
Portable, direct connect server access

The ATEN CV211 connects a laptop directly to any server allowing you instant access to perform data maintenance and local operations, for quick troubleshooting, updating, service and repair.

 
LVL 43

Accepted Solution

by:
JFrederick29 earned 125 total points
ID: 11813761
Well, in that case, don't assign an IP address to your Ethernet1 interface.  It is not necessary.  Just setup your static NAT's for your webservers and you're all set.
0
 
LVL 4

Expert Comment

by:celsmk
ID: 11813835
If you use 255.255.255.248 netmask, you will not only loose 112, but also 119, yielding only 6 usable IP address, or 5, if you use it in ethernet 1.

I understood that you have those addresses in order to assign them to server. If this is true and you need more than 5 IP addresses from 64.53.xx.xx address range, I suggest you to use them for NAT.

With this, you would configure yours servers with 192.168.2.x 255.255.255.0 or 206.74.xx.xx 255.255.255.0 and configure NAT to map these IP addresses to be seem from outside as 64.53.xx.xx.

Also, if you really want to assign the router with a 64.53.xx.xx 255.255.255.255 IP address, do so in a loopback interface:
interface loopback 0
ip address 64.53.xx.xx 255.255.255.255
0
 
LVL 6

Author Comment

by:microbolt
ID: 11813934
Thanks for your guys help.  Celsmk is there a way I can give you some points too.  I was hoping I could give you an "assisted answer" like i've seen on some other posts.
0
 
LVL 4

Expert Comment

by:celsmk
ID: 11814472
microbolt,
JFrederick29 was a bit faster than me with all answers right on target, so do not sweat. :-)

Regards,

Celsmk

P.S.: Here is the FAQ with answer to your question:
The http://www.experts-exchange.com/Community_Support/help.jsp#hi69
0

Featured Post

Portable, direct connect server access

The ATEN CV211 connects a laptop directly to any server allowing you instant access to perform data maintenance and local operations, for quick troubleshooting, updating, service and repair.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

While it is possible to put two routes in place with the secondary having a higher metric, this may not always work. In the event of a failure that does not bring down the physical interface on the router the primary route is not removed. There is a…
I have seen some questions on problems with SSH/telnet access to Cisco routers that may occur despite the fact that from a PC connected to your LAN, Internet connectivity is in place and users can access Internet sites without any issues.  There are…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

809 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question