Solved

Tight VNC not working over http

Posted on 2004-08-16
5
652 Views
Last Modified: 2010-04-11
Ok I need to get to my pc va a web page from work so I installed tight VNC.  The regular vnc works but the web page doesn't I installed as a service also.  What happens is i go to the address:port# and it renenders the page but I get a box with a little red x in the top let cornor.  It is like it is not loading the applet I am using IE6.  the tight vnc link does show up in the bottom.  I tried to look up java applets in the browser but no help.  Is there a broweser setting I need to check?
0
Comment
Question by:ProgrammerGeek
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
5 Comments
 

Author Comment

by:ProgrammerGeek
ID: 11817176
Ok just tried it on another pc and it worked.  Someting is funny on this one I do have a google tool bar installed but I have narrowed it down to something different in IE.
0
 

Author Comment

by:ProgrammerGeek
ID: 11820184
just tried at work and I get the initional connection but then I get a error "could not connect to server: (myIP):5900"  But I am not using port 5900 I configured to port 24 and it connects on 24.  I am forced to go through a proxie to get out of work.  Any idears?
0
 
LVL 9

Expert Comment

by:fixnix
ID: 11820550
I've not used the web interface and shudder to even think about running vnc on public netwroks unless it's through an ssh tunnel, but nonetheless, If it's connecting on port 24 and giving a can't connect on 5900 error, it sounds like the way the web interface works it one of two ways:

1.  The web port is only for loading the java applet and the java applet then connects to the vnc port the same as if you were using the vncviewer.  (In which case you'd have to find another port you can get out on through your proxy and change the 5900 in tightvnc to whatever additional port you can use.  I suspect this is what's happening)

2.  Perhaps the java applet acts as a middle man and actually connects to the vnc server locally (much like running through an ssh tunnel) in which case you would need to check "allow loopback connection" on the tightvnc server.

If you have or can install an ssh client at work (like PuTTy), I would strongly suggest connecting to your home tightvnc machine through an ssh tunnel as it is far more secure that way and not terribly difficult to set up.  I can assist with that if you would like.
0
 

Author Comment

by:ProgrammerGeek
ID: 11820926
I have putty on my machine at work what steps do I nned to connect to my machine at home?  I am up for anything but keep in mind they do try and block me.  THat is why I was trying something that is http because I can surf the web.  One othere thing I was thinking of is maybe I have a web server set up is some how displaying the tightvnc through that and displaying the web page.
0
 
LVL 9

Accepted Solution

by:
fixnix earned 250 total points
ID: 11821246
http://pigtail.net/LRP/vnc/ lists all the steps for getting vnc through an ssh tunnel.

In a nutshell, You'll need to install the cygwin library and OpenSSH server (or any other ssh server for windows) on your home machine (instructions and links on above link), add users and start the sshd service on the home computer (instructions in the readme.txt or quickstart.txt or similar), and set the tightvnc server to "Accept loopback connections" and "Accept only loopback connections" to be sure it is not reachable by any other method.  You can still use port 5900 on the Tightvnc server without any issues with the work firewall.  All you need to hit out of work is port 22 for normal ssh traffic (can you use putty to connect to any other places on port 22?  If not you may need to configure the home sshd to use port 24 or whatever you can get out on).

At work on the putty client, the tunnel setup is pretty easy.

In the putty configuration, under the Connection/SSH/Tunnels section, add 5900 as a source port, 127.0.0.1:5900 as a Destination, and click Add.  Save that session and have at it!  Use putty to log in to your home machine using your windows username and password, then fire up the TightVNC viewer and point it to 127.0.0.1::5900 (remember to use :: and not : if using TightVNC.  If anyone else reads this and is using VNC, then you'd want to connect to 127.0.0.1:5900).

Let me know if you get stuck anywhere.  I set this up on machines all over town to save the drive out for a simple support call and it works great.

0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
svi stops eigrp advertisement 13 57
cannot view videos at msnbc 12 65
IP range 6 60
Isolated network on ESXi 6.5 8 44
Even if you have implemented a Mobile Device Management solution company wide, it is a good idea to make sure you are taking into account all of the major risks to your electronic protected health information (ePHI).
This article will inform Clients about common and important expectations from the freelancers (Experts) who are looking at your Gig.
Viewers will learn how to connect to a wireless network using the network security key. They will also learn how to access the IP address and DNS server for connections that must be done manually. After setting up a router, find the network security…
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.

756 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question