Solved

Cisco 2514 Router with Motorola Surfboard Cable Modem

Posted on 2004-08-17
8
1,117 Views
Last Modified: 2013-12-14
Hi guys,

I have one computer which is connected by Ethernet NIC to a Motorola Surfboard Cable modem to access the internet.
What I would like to do is to hook up a Cisco 2514 Router to the cable modem and PC and configure a firewall on the cisco router, still enabling internet access through the cable modem.
The router has a built in hub. Any help on how I could configure this would be great.
Thanks in advance.

Simon
0
Comment
Question by:Simon336697
  • 5
  • 3
8 Comments
 
LVL 43

Accepted Solution

by:
JFrederick29 earned 500 total points
ID: 11819394
Here is a basic config:

Ethernet0
ip address dhcp  <---if your provider uses dhcp
ip nat outside
ip access-group 101 in

Ethernet1
ip address 192.168.0.1 255.255.255.0
ip nat inside

ip nat inside source list 1 interface ethernet0 overload

access-list 1 permit 192.168.0.0 0.0.0.255

access-list 101 permit udp any eq 53 any          <--- Allow return DNS replies
access-list 101 permit tcp any any established   <--- Allow established TCP sessions from the inside network
access-list 101 permit icmp any any echo-reply  <--- Allow icmp replies back into your network

Access-list 101 is a basic ACL which will only allow DNS lookups and TCP sessions intitiated from the inside network back into your LAN.  Cisco makes an IOS firewall which can be used.  It provides greater flexibility.  If you need to permit other udp traffic, you'll need to add access-list entries using the correct ports.
0
 
LVL 43

Expert Comment

by:JFrederick29
ID: 11819490
Forgot a line:

ip route 0.0.0.0 0.0.0.0 ethernet0

Or if you know the next hop router at your ISP:

ip route 0.0.0.0 0.0.0.0 68.x.x.1  <---use correct IP address
0
 
LVL 1

Author Comment

by:Simon336697
ID: 11820772
Hi JFrederick29,

Really appreciate your help here mate.
Can you please just clarify a few things for me.

This is my setup at the moment.
   
          CAT5 Lead
PC------------------------Motorola Cable Modem-------------------Wall Socket

With the router included, would it look like the following?

           CAT5 Lead
PC-----------------------AUX1 of Router

Modem------------------AUX2 of Router

Of the above, which is Ethernet0 and Ethernet1 as you explain?

The IP Address information I have been given from my provider is as follows:

Ethernet adapter Local Area Connection:



        Connection-specific DNS Suffix  . : vic.assr.net.au

        Description . . . . . . . . . . . : Broadcom 440x 10/100 Integrated Controller
        Physical Address. . . . . . . . . : 00-0B-DB-2D-53-EG

        Dhcp Enabled. . . . . . . . . . . : Yes

        Autoconfiguration Enabled . . . . : Yes

        IP Address. . . . . . . . . . . . : 138.217.162.12

        Subnet Mask . . . . . . . . . . . : 255.255.252.0

        Default Gateway . . . . . . . . . : 138.217.160.1

        DHCP Server . . . . . . . . . . . : 172.18.17.80

        DNS Servers . . . . . . . . . . . : 61.9.128.14

                                            61.9.192.15
                                            61.9.128.15


I just need a bit of help in physically setting up the connections between the router, the modem and the PC, and then determining from what you say what ethernet interfaces belong to what.
I really appreciate your help JFrederick29.

Simon
0
What is SQL Server and how does it work?

The purpose of this paper is to provide you background on SQL Server. It’s your self-study guide for learning fundamentals. It includes both the history of SQL and its technical basics. Concepts and definitions will form the solid foundation of your future DBA expertise.

 
LVL 43

Expert Comment

by:JFrederick29
ID: 11820885
AUI1 would be Ethernet0 and AUI2 would be Ethernet1.

Plug the CAT5 cable from the cable modem (that is currently going into your PC) into the tranceiver connected to AUI1.  Then if you want to connect your PC directly to the router, you'll need a crossover cable (straight through won't work) from your PC into the tranceiver connected to AUI2.  Alternatively, you can use a hub/switch in between your PC and the routers AUI2 tranceiver, you could use straight through cables in this case.

You are receiving an IP address from your provider via DHCP so use the "ip address dhcp" command as shown in the config I posted.
0
 
LVL 1

Author Comment

by:Simon336697
ID: 11826916
Hi JFrederick29,

Mate thank you so much.

Just one more thing and the points are yours (they are anyway!).

Previously without the router, I could control cable modem access to the Internet through cable modem software on my PC.
Now that the modem is not connected directly to the PCs NIC, but to an Ethernet port on the router, to stop Internet activity, do I have to shut down the interface each time on the router then bring it back up again to get Internet connectivity?
Also, as the internal network will be something like 192.168.x.x, will this mean I have to statically assign an IP address to my PC's network card and also the ethernet port on the router?

Many thanks mate.

Simon
0
 
LVL 43

Expert Comment

by:JFrederick29
ID: 11829745
You can shut down the interface connected to the cable modem and that will block the Internet from your entire internal network.  If you only have one PC, you could disable your "Local Area Connection" in Windows and that would stop the Internet from hitting your PC but still traversing the router.

For the router's internal interface, yes, you need to statically assign it an IP address using the "ip address <address> <mask>" interface configuration command.  For the PC, two ways, you can statically assign an IP address on the PC which is easiest if you only have the one PC.  If you have a good number of PC's you could setup the DHCP server on the router to provide addresses to the internal PC's.  
0
 
LVL 1

Author Comment

by:Simon336697
ID: 11836020
JFrederick29,

Youre a champion!

Thanks so much for all your great help.

Appreciate your expertise!!

Simon
0
 
LVL 43

Expert Comment

by:JFrederick29
ID: 11840178
You're welcome!
0

Featured Post

Networking for the Cloud Era

Join Microsoft and Riverbed for a discussion and demonstration of enhancements to SteelConnect:
-One-click orchestration and cloud connectivity in Azure environments
-Tight integration of SD-WAN and WAN optimization capabilities
-Scalability and resiliency equal to a data center

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Balance MONTHLY bandwidth between 2 connections 4 38
Bridge on Technicolor tg589 4 211
Best tool to terminate fiber 8 87
Ping and real time 48 57
    Over the past few years, small business and home owners have become so dependent on internet that a need for redundancy has arisen.    What happens when your small business or home / home office loses its internet connection?  The results c…
This solves the problem of diagnosing why an internet connection is no longer working. It also helps identify the likely cause of the lost connection if the procedure fails to re-establish your internet connection. It helps to pinpoint the likely co…
A short tutorial showing how to set up an email signature in Outlook on the Web (previously known as OWA). For free email signatures designs, visit https://www.mail-signatures.com/articles/signature-templates/?sts=6651 If you want to manage em…
Finds all prime numbers in a range requested and places them in a public primes() array. I've demostrated a template size of 30 (2 * 3 * 5) but larger templates can be built such 210  (2 * 3 * 5 * 7) or 2310  (2 * 3 * 5 * 7 * 11). The larger templa…

821 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question