Solved

dual boot linux

Posted on 2004-08-17
12
647 Views
Last Modified: 2013-11-15
Hello
I installed linux on my second hard drive, the first has win2000
when I boot up, window NTLDR gives me the  options to go win or linux. the win option works good, the linux option gives me a black scren with the work  GRUB on the top left cornor and  nothing happens. how can this be fixed.

thanks
0
Comment
Question by:samj
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 4
  • 3
12 Comments
 
LVL 6

Expert Comment

by:knollbert
ID: 11819439
0
 

Expert Comment

by:BotHunter
ID: 11822922
I'm not sure about grub, but I know that with LILO, you had to copy the bootsector to a file on the NT partition before the NT loader could boot it.  It may be similar for grub.  

Try running dd if=/dev/hda2 of=/tmp/grub.img (replace hda2 with your boot partition where grub is installed)

Copy grub.img to the root directory on your NT drive and modify the boot.ini to boot that image.

Can you post a copy of your boot.ini file?
0
 

Expert Comment

by:BotHunter
ID: 11822940
Another option is to have grub boot NT instead of having NT boot Linux.  It works a lot better that way.  (Grub understands the NT boot loader... the NT boot loader doesn't understand non-MS operating systems)
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 6

Expert Comment

by:knollbert
ID: 11823592
>Another option is to have grub boot NT instead of having NT boot Linux.  It works a lot better that way.

Absolutely  correct!!

i just answered the question asked.
0
 

Author Comment

by:samj
ID: 11824883
ok, lets then to with grub to boot NT.
so  setting bios to use D instead of C as it is first option to boot.
I did that, that is
when I change the boot sequence to boot from hdb
I get
Verifying DMI Pool Data ..............
GRUB Loading state 1.5.

GRUB loading, pleae wait...
Error 22


so I used a grub floppy to boot up.
Grub> find /boot/grub/stage1
(hd1,1)
grub> root (hd1,1)
filesystem type is …..
grub> setup (hd1)

done
grub> setup (hd1,1)
..
done
grub> reboot

the same thing "Error 22"
0
 

Author Comment

by:samj
ID: 11824917
and, here is my /boot/grub/menu.lst

default            0

timeout            2

color cyan/blue white/blue


 title            Windows 95/98/NT/2000
 root            (hd0,0)
 makeactive
 chainloader      +1
#
 title            Linux
 root            (hd1,1)
 kernel      /vmlinuz root=/dev/hdb1 ro
#

title            Debian GNU/Linux, kernel 2.4.18.081704
root            (hd1,1)
kernel            /vmlinuz-2.4.18.081704 root=/dev/hdb1 ro
savedefault

title            Debian GNU/Linux, kernel 2.4.18-bf2.4
root            (hd1,1)
kernel            /vmlinuz-2.4.18-bf2.4 root=/dev/hdb1 ro
savedefault


### END DEBIAN AUTOMAGIC KERNELS LIST
0
 

Author Comment

by:samj
ID: 11826157
if I let the bios boot into hda, it gives me the options to boot into win or lnx, the win options works, the lix option gives
grub>

here is my boot.ini
[boot loader]
timeout=3
default=multi(0)disk(0)rdisk(0)partition(1)\WINNT
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINNT="Microsoft Windows 2000 Professional" /fastdetect
c:\bootsect.lnx="Linux debian"

0
 

Expert Comment

by:BotHunter
ID: 11826309
You might want to try lilo for a change.  I don't want to start a religious battle here, but I think it's worth a shot.  According to your grub file, I've created a LILO configuration that might work:

# /etc/lilo.conf - See: `lilo(8)' and `lilo.conf(5)',
# +---------------------------------------------------------------+
# |                        !! Reminder !!                         |
# |                                                               |
# | Don't forget to run `lilo' after you make changes to this     |
# | conffile, `/boot/bootmess.txt', or install a new kernel.  The |
# | computer will most likely fail to boot if a kernel-image      |
# | post-install script or you don't remember to run `lilo'.      |
# |                                                               |
# +---------------------------------------------------------------+

# Support LBA for large hard disks.
#
lba32

boot=/dev/hdb

# Specifies the device that should be mounted as root. (`/')
#
root=/dev/hdb1

# Installs the specified file as the new boot sector
# You have the choice between: bmp, compat, menu and text
# Look in /boot/ and in lilo.conf(5) manpage for details
#
install=/boot/boot-menu.b

# Specifies the location of the map file
#            
map=/boot/map

delay=20

vga=normal

append=""

# Boot up Windows by default.
#
default=Windows

image=/vmlinuz
        label=Linux
        read-only
#       restricted
#       alias=1

image=/vmlinuz-2.4.18.081704
        label=Kernel-08-18-04
        read-only
        optional
#       restricted
#       alias=2

image=/vmlinuz-2.4.18-bf2.4
        label=Kernel2418bf24
        read-only
        optional
#       restricted
#       alias=2


# If you have another OS on this machine to boot, you can uncomment the
# following lines, changing the device name on the `other' line to
# where your other OS' partition is.
#
other=/dev/hda1
#       label=Windows
#       restricted
#       alias=3
0
 

Expert Comment

by:BotHunter
ID: 11826315
Doh!! Correction to my previous post:

3rd to last line should not be commented:


# If you have another OS on this machine to boot, you can uncomment the
# following lines, changing the device name on the `other' line to
# where your other OS' partition is.
#
other=/dev/hda1
       label=Windows
#       restricted
#       alias=3
0
 

Accepted Solution

by:
samj earned 0 total points
ID: 11826669
ok
no suggestion here I used to fix the problem.
the problem is fixed with the help of
http://www.desktop-linux.net/grub.htm
basicly, I reinstalled grub, followed the steps in the link above.
all is good.

thanks

if no objection from anybody, I would like to ask for PAQ and refund.

thanks
0
 
LVL 6

Expert Comment

by:knollbert
ID: 11826820
Congrats on figuring it out your self


Knollbert
0

Featured Post

[Webinar] Code, Load, and Grow

Managing multiple websites, servers, applications, and security on a daily basis? Join us for a webinar on May 25th to learn how to simplify administration and management of virtual hosts for IT admins, create a secure environment, and deploy code more effectively and frequently.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

SSH (Secure Shell) - Tips and Tricks As you all know SSH(Secure Shell) is a network protocol, which we use to access/transfer files securely between two networked devices. SSH was actually designed as a replacement for insecure protocols that sen…
If you use Debian 6 Squeeze and you are tired of looking at the childish graphical GDM login screen that is used by default, here's an easy way to change it. If you've already tried to change it you've probably discovered that none of the old met…
Learn how to navigate the file tree with the shell. Use pwd to print the current working directory: Use ls to list a directory's contents: Use cd to change to a new directory: Use wildcards instead of typing out long directory names: Use ../ to move…
Connecting to an Amazon Linux EC2 Instance from Windows Using PuTTY.
Suggested Courses

738 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question