Solved

Internet Explorer not automatically adding the 'http://' bit at the beginning

Posted on 2004-08-17
8
507 Views
Last Modified: 2008-03-06
We are having problems with some systems that were infected with spyware, and now can't finish the URLs in Internet explorer. If you type in www.google.co.uk instead of http://www.google.co.uk t just doesn't open. We have tried all the obvious things like re-instaling Internet Explorer, resetting all the default settings and running various spyware removal packages. We have also re-registered all the associated DLL files. Just wondered if anyone had any ideas?

Thanks a lot,
Dan
0
Comment
Question by:DClayden
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
8 Comments
 
LVL 32

Expert Comment

by:LucF
ID: 11818420
Hi DClayden,

Lost http prefix in URLs
http://malektips.com/internet_explorer_6_0016.html

SUMMARY: Internet Explorer not adding http:// to your URLs? This may help.
 
After dealing with some viruses and spyware, you may have come across a situation in Internet Explorer 6 where the default prefix "http://" is missing. For example, if you type in www.experts-exchange.com into Internet Explorer, it will never add the "http://" in front, making the correct URL http://www.experts-exchange.com

If this has happened, copy the text between the --- signs below into a file called 'prefix.reg' (use Notepad or your favorite text editor). Note that the [HKEY] lines are split in two for viewing on this page. Double-click the file from Explorer, and it should solve your problem. Since this is a registry editing tip, all standard disclaimers apply.

---
[HKEY_LOCAL_MACHINE\Software\Microsoft\
Windows\CurrentVersion\URL\DefaultPrefix]
@="http://"

[HKEY_LOCAL_MACHINE\Software\Microsoft\
Windows\CurrentVersion\URL\Prefixes]
"ftp"="ftp://"
"gopher"="gopher://"
"home"="http://"
"mosaic"="http://"
"www"="http://"
---

Greetings,

LucF
0
 
LVL 1

Author Comment

by:DClayden
ID: 11818688
That's fixed it! It was the www key that didn't have the http:// in.

Thanks a lot!
0
 
LVL 32

Accepted Solution

by:
LucF earned 125 total points
ID: 11818696
You're very welcome, glad to help :)

LucF
0
Back Up Your Microsoft Windows Server®

Back up all your Microsoft Windows Server – on-premises, in remote locations, in private and hybrid clouds. Your entire Windows Server will be backed up in one easy step with patented, block-level disk imaging. We achieve RTOs (recovery time objectives) as low as 15 seconds.

 

Expert Comment

by:subrap
ID: 11991693

I have a similar situation where my PC got into virus problem. Though I recovered from it - I am facing the same problem. But surprisingly my registry is having the entries you had talked about. Still its not working. For e.g. _ earlier I used to type "mail.yahoo.com" and the address used to get completed and the page appears but now it doesn't appear and I am getting the a page like "C:\Documents and Settings\N4741\Desktop\#mail.yahoo.com" where N4741 is my userid (which has administrator right as well).
Hope somebody would be able to help us.
0
 
LVL 32

Expert Comment

by:LucF
ID: 11991760
No problem subrap, but within the rules of Experts Exchange.
Please create your own question by clicking this link:
http://www.experts-exchange.com/Applications/askQuestion.jsp

Then, if you want, you can email me the link, or post it here if you like and I'll see what I can do for you.

LucF
0
 

Expert Comment

by:subrap
ID: 11995487
yes i have posted under my name and the question no is : Q_21121322. Hope you would be able to help.
0
 

Expert Comment

by:kuzmishin
ID: 12150189
Hi -

I'm having the same problem described above and copied the registry fixes into Notepad.  When I go to Explorer and double click on the Notepad file, it merely opens it.  How do I get it to "run" the changes?
0
 
LVL 32

Expert Comment

by:LucF
ID: 12153933
kuzmishin,

Please check the full information at http:#11818420 and make sure you have named the file prefix.reg
Now you've probably named it prefix.reg.txt as that's the default for notepad (known file extensions are hidden)

LucF
0

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

A high-level exploration of how our ever-increasing access to information has changed the way we do our jobs.
I use more than 1 computer in my office for various reasons. Multiple keyboards and mice take up more than just extra space, they make working a little more complicated. Using one mouse and keyboard for all of my computers makes life easier. This co…
The viewer will learn how to set up a document for the web and print and the recommended PPI for printing.
The viewer will learn how to create multiple layers to apply various filters and how to delete areas from each layer’s filter.

738 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question