I want to jumpstart a Sparc Netra X1 from an x86 Intel PC using Solaris 9

Posted on 2004-08-17
Medium Priority
Last Modified: 2013-12-21

I'm trying to jumpstart a Sun Netra X1 sparc box using Solaris 9 on an x86 Intel PC. I've seen some guides which i'm following but i get stuck when i try and run ./setup_install_server on the Intel PC as it tells me that the Boot does not exist. This command will run with the x86 CD 1 in however. So how am i possibly supposed to be able to copy over the sparc CD 1 & 2, that will be required to jumpstart the sparc box, to an x86 PC?

I run the following :

mkdir -p /export/install/sparc_9
cd /cdrom0/Solaris_9/Tools
./setup_install_server /export/install/sparc_9

Using Sparc CD 1 it doesn't work and returns and error of :

Install boot image /cdrom/sol_9_904_sparc/Solaris_9/Tools/Boot does not exist, Check that boot image exists, or use [-t] to specify a valid boot image elsewhere.

Please help, i've got a nice Netra here collecting dust and the only way to make use of it is to install it by jumpstarting it.

Thanks in advance! :-)
Question by:matd_
  • 5
  • 2
  • 2
  • +2
LVL 40

Expert Comment

ID: 11826462
It's been quite a while since I need to set up a hertogenous install server, but I think I just looked at what the setup_install_server script did and duplicated what would result manually.

Author Comment

ID: 11826510
LVL 40

Expert Comment

ID: 11826641
Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.


Author Comment

ID: 11826652
That seems to be be more of a thought than being of any help, just wondered why you bothered pasting it really....
LVL 38

Expert Comment

ID: 11826838
You have used the wrong CD, you need to use the Solaris 9 Insatllation CD to setup
installation server, then use Solaris 9 Software CD 1 0f 2 and 2 of 2 !

Author Comment

ID: 11826923
how do you suggest that i run ./setup_install_server when this is all thats on the sparc install cd?

/cdrom/cdrom0> ls -la
total 196
dr-xr-xr-x   2 root     sys         2048 Jun 29 20:51 .
drwxr-xr-x   3 root     root         512 Aug 18 02:23 ..
-rw-r--r--   1 root     other         30 Jun 29 20:51 .volume.inf
lrwxrwxrwx   1 root     other          5 Jun 29 20:51 Boot -> ../s1
-r--r--r--   1 root     other       7052 Jun 29 20:51 Copyright
-rwxr-xr-x   1 root     other      63732 Jun 29 20:51 add_install_client
-rwxr-xr-x   1 root     other       5684 Jun 29 20:51 modify_install_server
-rwxr-xr-x   1 root     other      18523 Jun 29 20:51 rm_install_client
LVL 38

Expert Comment

ID: 11827098
Sorry above the miss leading infor in http:#11826838

You do need to use the Solaris Software CD 1 of 2 to setup the installation server.
I have not try use Solaris 9 as an installation server.

I have use Solaris 7/8 as installation server with multiple Solaris OS versions and
never have any problem.  Please read the "Advanced Installation Guide Comes
with the Solaris 9 media" or have a look at:

To see if anything has changed in Solaris 9.

Author Comment

ID: 11829799
Ok, i found this on sunsolve :


The only problem is i can't get that to work either as the example is referring to sol-9-u1-sparc-v1.iso and i'm using the latest sol-9-u7-sparc-v1.iso downloaded from sun.com

I can't be the only person in the world attempting to boot a sparc box from an intel box using this release surely?

Expert Comment

ID: 11924711
I have a Solaris 8 Jumpstart server, but hopefully Sun hasn't changed too much in the setup_install_server script.
The error says to specify the /Boot image, which is the portion that gets netbooted when you "boot net" from the ok> prompt.

What's odd is that it doesn't seem to know the proper directory to look,
as evidenced by the error portion:

when in actuality you are at:

Try specifying the location of the boot image as such:
./setup_install_server /export/install/sparc_9 -t /cdrom0/Solaris_9/Tools/Boot

In the event that it automatically appends the /Boot:
./setup_install_server /export/install/sparc_9 -t /cdrom0/Solaris_9/Tools

If it copies, then the rest of the Jumpstart Install Guide shouldn't cause any issue.
(Though I'm dubios about the add_install_client being x86 compatible either....)


Author Comment

ID: 12178460
please refund points, i answered / solved this myself by just using a jumpstart from Solaris 8, as this seems to be a common fault on Solaris 9.

Accepted Solution

CetusMOD earned 0 total points
ID: 12211285
PAQed, with points refunded (100)

Community Support Moderator

Featured Post

Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

My previous tech tip, Installing the Solaris OS From the Flash Archive On a Tape (http://www.experts-exchange.com/articles/OS/Unix/Solaris/Installing-the-Solaris-OS-From-the-Flash-Archive-on-a-Tape.html), discussed installing the Solaris Operating S…
Java performance on Solaris - Managing CPUs There are various resource controls in operating system which directly/indirectly influence the performance of application. one of the most important resource controls is "CPU".   In a multithreaded…
Learn how to find files with the shell using the find and locate commands. Use locate to find a needle in a haystack.: With locate, check if the file still exists.: Use find to get the actual location of the file.:
Learn how to navigate the file tree with the shell. Use pwd to print the current working directory: Use ls to list a directory's contents: Use cd to change to a new directory: Use wildcards instead of typing out long directory names: Use ../ to move…

607 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question