[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 392
  • Last Modified:

SP2 - Asking before opening files "Open File - Security Warning"

I have an alarm clock program that no longer works due to the fact that it will open a specified file at a specified time. I simply give it the file name, and it, I assume, sends the command to Windows to open the file, at which point WinAmp is supposed to open.

After I installed SP2, it now pops up a dialog box that says:
"Open File - Security Warning"
Do you want to open this file?
  Name: xxxxx
  Publisher: xxxxx
  Type: Winamp Media File
  From: file location

Then it asks me to Open or Cancel

No option to not ask again.

Any way to disable this? I've looked through the firewall settings and such to no avail.

Please advise,
Thanks,
Matt
0
mattboy_slim
Asked:
mattboy_slim
  • 4
  • 4
  • 2
  • +1
1 Solution
 
tosh9iiiCommented:
Well, I don't know how to disable, but I'll keep on looking into it.

However, you should be able to use Scheduled Tasks in Control Panel to open Winamp.  

One more thing, you said you looked in Firewall, so you went to Control Panel>Windows Firewall>Exceptions>Add Program and selected winamp and then your alarm clock.  Is that correct? If not, then try it.
0
 
GT-Commented:
I think it will be related to the Attachment Execution restrictions implemented with service pack 2.

It would be nice to know more about the clock program, and what the winamp media file actually is. IE; Is it an MP3, or a WMA or something similar. It might possible that the extension/content of the file triggered the attachment execution code added with sp2 and causing the prompt.

Not sure if this is helpful, and I am not sure if I will get time to find the specific documentation tomorrow, so I hope that if Im on the right track someone else manages to take the info and help you.

0
 
mattboy_slimAuthor Commented:
Well unfortunately, Scheduled Tasks doesn't offer the flexibility that I need in an alarm clock program.

And yes, both programs have been added to the exceptions list, to no avail.

The file is an MP3.

I've looked through at least 25 pages of 10 different Google queries regarding the exact error message, but it doesn't seem as though anyone else is having this problem yet.

Thanks for the continued help,
Matt
0
VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

 
tosh9iiiCommented:
I'm not sure if this will help but it might be worth it to try it:

Control Panel>Systems>Advanced>Performance>settings>Data Execution Prevention>Turn on DEP for all...>Add>locate your alarm clock then Winamp

As for any downsides, I really don't know.
0
 
GT-Commented:
I dont think that the problem is with DEP or the firewall, but with AES, or IE Local Zone security enhancement.

If it was the firewall, you would get a firewall dialog, also the application is unlikley to be using network calls to open a local file. I dont think its DEP, since DEP detects buffer overflows, and halts the code from running, and provides an error to indicate that is has halted the code.

I think its due to the application probably calling the MP3 and being affected by IE Zones.

Check the Group Policy on your local computer and see if you can modify some of the file opening security options within it.

Id give this a go myself, out of interest, however I do not know what application you are using.
0
 
mattboy_slimAuthor Commented:
The other program is "Daily Alarm Clock" Link here: http://www.litespring.com/alarm/

I set my "Local" security in IE to Low, which did not help either.
0
 
tosh9iiiCommented:
Well mattboy_slim, maybe it's not SP2 that's blocking it.  I have SP2 on my Windows XP Pro computer (as well as Norton Personal Firewall) and I downloaded and installed both Daily Alarm Clock and Winamp, I had the clock play an mp3 at a specific time.   And then, it played the mp3.  I didn't get a warning or error message or anything.  Do you have any other security software on your computer such as zonealarm?

This probably won't work, but try uninstalling and reinstalling both winamp and daily alarm clock.

All my IE security setting are set at default.
0
 
mattboy_slimAuthor Commented:
I can show you that it is SP2 that is causing the problem: Screenshot Here: http://www.mattstanzel.com/images/warning.jpg

I'll try to uninstall and reinstall both programs.
0
 
tosh9iiiCommented:
It says From:  I:\MP3s\Dax Riders.  Is I:\ your cdrom or is it some sort of network drive?
I also noticed that at the bottom it says "files from the Internet" are you trying to access it from the internet.

0
 
mattboy_slimAuthor Commented:
Yes, it is a network drive. I moved the file to the system drive and all works fine. I think there needs to be a way to distinguish, or to bypass the security dialog when opening files over a network drive.
0
 
lasseruudCommented:
Because the file is located on  a network drive, you need to add it to your local intranet zone in Internet Explorer.

Open Internet Explorer properties.
Chose the 'Security' tab
Select 'Local Intranet'
Click 'Sites'
Click 'Advanced'
Enter the server's IP-address or name and click 'Add'
Close program, open file without warning.
0

Featured Post

Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 4
  • 4
  • 2
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now