[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1145
  • Last Modified:

Exchange E-mail Alias

I'm trying to setup an E-mail alias for forwarding.  We have a new employee that needs an email address of our company forwareded to his own.  I want to do this without creating a user or mailbox.  I'm running Exchange 2000.  I tried doing this http://www.msexchange.org/tutorials/Forwarding_Mail_to_an_External_Recipient_Part_II.html
but will only work if I send the mail from within our domain (on our network).  I tried sending the mail from gmail and hotmail and it does not work.  hisname@ourdomain.com needs to forward to hisname@hisdomain.com.  The article does say Exhchange default relaying settings should work for this.  I'm not sure what the defualt settings are as I came into this Exchanger server that was already setup.
0
GentooOS
Asked:
GentooOS
  • 8
  • 7
  • 4
  • +2
2 Solutions
 
SembeeCommented:
Skip all of that.

Create a new contact in ADUC on the Exchange server. Enter the external email address during the wizard as normal.
Once the contact has been created go back in to properties of the contact and add an internal email address.
Thus the contact has two email addresses listed:

hisname@ourdomain.com
hisname@hisdomain.com

No mailbox, no user.

Wait a little while for the AD to catch up.

Simon.
0
 
GentooOSAuthor Commented:
That is what I did.  I does not work if I send mail from outside our network.  It must have to do with relaying, but I don't know what.
0
 
GentooOSAuthor Commented:
If the user wants to send out using @ourdomain.com does a mailbox and user need to be setup?
0
Configuration Guide and Best Practices

Read the guide to learn how to orchestrate Data ONTAP, create application-consistent backups and enable fast recovery from NetApp storage snapshots. Version 9.5 also contains performance and scalability enhancements to meet the needs of the largest enterprise environments.

 
SembeeCommented:
Yes and No

If the user wants to send out using @ourdomain.com using Outlook and keeping a copy of the message on your server then a mailbox will be required.

You can also do it by using Outlook Express and specifying the email address as hisname@ourdomain.com. The message will go via his regular ISP.

Don't know why the contact wouldn't work - I have the configuration in place on two seperate servers - although they are both Exchange 2003 systems.
Have you changed anything with regards to relaying that could have broken this functionality?

Simon.
0
 
kristinawCommented:
Simon and Gent,

Wouldn't he have to have 'Allow Automatic Forward' checked under Internet Message Formats for this to work? Seems like that has to be turned on for this to work.

Kris.
0
 
SembeeCommented:
I don't have that option enabled on the servers that I am using. They are Exchange 2003 though and I am not sure whether anything has changed with this feature from Exchange 2000.

Simon.
0
 
robinluoCommented:
GentooOs,

You sure you have created a Contact not a mailbox? I have this working on Contact object, but won't work on Mailbox object.
0
 
GentooOSAuthor Commented:
Yes, I did use a contact.  I think the problem is with relaying.  The server has grant only to a few IP addresses but, I wasn't the one who put them in.  I have not had the time to see what ones if any need to be there.  What relaying do you have setup if any?  What is the default relaying?
0
 
kristinawCommented:
Gent,

Do you check the option I suggested earlier? robin, do you have that option checked?

kris.
0
 
robinluoCommented:
Kris,

No, I don't have this option checked on my Exch2003.
0
 
robinluoCommented:
Gent,

My relay setting is even more strict, no IP is allow to relay, even "allow athenticated user to relay" is disabled.
0
 
SembeeCommented:
I don't think it is relaying as the Exchange server is doing it internally. I haven't got access to an Exchange 2000 machine in my current location. Can someone with an Exchange 2000 server do a quick test to see if it does work?

Simon.
0
 
kristinawCommented:
ok, just tried it in my domain and it worked fine. test message showed up in my yahoo account np. i would test it without the forwarding option checked, but don't want to break anything in my own domain, as i have users actively using this feature.

hth,

kris.
0
 
GentooOSAuthor Commented:
Kristinaw,

Try to to send it from your yahoo account to the alias so that it comes back to your yahoo account.  Where did you send from in your last example, inside your domain?
0
 
kristinawCommented:
i sent it from an outside (user@mail.com) account to the contact alias i created, testuser@norfolk.gov, email showed up in myyahoo@yahoo.com.

This is what you are trying to do, correct?

Kris.
0
 
kristinawCommented:
since i am trying to help, it would be nice if you could at least answer the question i asked. if not i'll sign off and let the others assist you.

best of luck,

kris.
0
 
GentooOSAuthor Commented:
were do I find the forwarding options check box?
0
 
kristinawCommented:
In the ESM go to Global Settings, Internet Message Formats, Highlight Default in the right pane and select properties, select the Advanced tab, then check 'Allow Automatic Forward'.

Kris.
0
 
GentooOSAuthor Commented:
Still not working for me.  Something must be messed up on my Exchange Box.
0
 
kristinawCommented:
when was the last time you rebooted? do you have the latest sp installed?

Kris.
0
 
robinluoCommented:
GentooOS,

Just a quick thought: are you able to send a message from your exchange account to the email address that you are trying to forward?

If the message are not able to be sent even from your exchange account, then it's a mail routing issue.

If the message can be delivered, then it's something wrong so can not trigger the forwarding.

Try this and post back.
0
 
GentooOSAuthor Commented:
I could use a reboot and is only at sp1 but not sure I want to take the chance as we are planning for Exchange 2003 on a new box soon.
0
 
kristinawCommented:
Gent,

Had time to do the reboot yet? If you don't want to go to the current sp level then I'm not sure I have any more suggestions.

Kris.
0
 
jmhquestCommented:
If you have ADSIEdit installed, check the following attributes on the Contact you created.

Mail - This attribute should contain your company e-mail address for the employee.

targetAddress - This attribute should contain the address where you want the e-mail forwarded.


This configuration should allow e-mail sent to your employee's company SMTP address to be forwarded to his external e-mail account.

Cheers.
0
 
jmhquestCommented:
I did not receive any feedback ragarding the contents of the mail and targetAddress attributes.  
Has the original issue been resolved?  If not there are more options for troubleshooting the cause.  

Cheers,

JMH
0

Featured Post

NFR key for Veeam Backup for Microsoft Office 365

Veeam is happy to provide a free NFR license (for 1 year, up to 10 users). This license allows for the non‑production use of Veeam Backup for Microsoft Office 365 in your home lab without any feature limitations.

  • 8
  • 7
  • 4
  • +2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now