Solved

How to get rid of  "Your current security settings prohibit running ActiveX controls on this page..." message

Posted on 2004-08-18
5
18,757 Views
Last Modified: 2011-08-18
I'm using MS Outlook 2003, and MS Office 2003 on a XP machine.  When I open an email message that contains a web page, I get "Your current security settings prohibit running ActiveX controls on this page..." message.  What would I do to prevent this from happening.  I searched the experts-exchange.com website and found some suggestions to solve to this issue, for example, lowing the sercurity level, enabling all the ActiveX related  components, as well running script.  But they didn't seem to work for me.  Any other suggestions?

Thanks,

Henry
0
Comment
Question by:henkkasu
5 Comments
 
LVL 32

Expert Comment

by:Luc Franken
ID: 11835694
Hi henkkasu,

Just wondering... WHY would you want to disable a ActiveX security from e-mails? A lot of viruswriters just love it if you let these come through.
Emails are always treated as "restricted sites" by default, I surely suggest you to keep it that way.

Greetings,

LucF
0
 
LVL 4

Expert Comment

by:nagraves
ID: 11835701
Inside Outlook:

1. On the Tools menu, click Options, and then click the Security tab.
2. Click Zone Settings, and then click OK.
3. Click the Internet icon, and then click Custom Level.
4. Click the settings that you want, and then click OK three times
0
 

Author Comment

by:henkkasu
ID: 11835854
Hi LucF,

Thanks for the response.  I thought the message was from Internet Explorer.  The main reason is that the message seems to suggest that the page may not be displayed correct.  It was also a bit inconvenient to respond to it every time.  But if there is potential security compromise by disabling it, then it probably better to leave it as is.

Henry
0
 
LVL 32

Accepted Solution

by:
Luc Franken earned 250 total points
ID: 11835902
Yes, you should see ActiveX as executables, although most are used in a safe manner, some might cause big problems, so I really suggest you to keep the settings as-is. And just live with it.

If you know it's from a trustable source, you can always view the site in IE itself, so it'll be handled through the normal security options instead of the "restricted sites" options.

LucF
0
 
LVL 2

Expert Comment

by:dehcbad25
ID: 20173198
I want to note that you can get this message when you create a signature with a picture as well. When you send an HTML message you get this error and the picture does not show. Reaso for this? Well, I think MS Word is putting the ActiveX code to pull out the picture from the folder and send it.
0

Featured Post

What Should I Do With This Threat Intelligence?

Are you wondering if you actually need threat intelligence? The answer is yes. We explain the basics for creating useful threat intelligence.

Join & Write a Comment

Not sure what the best email signature size is? Are you worried about email signature image size? Follow this best practice guide.
Follow this checklist to learn more about the 15 things you should never include in an email signature from personal quotes, animated gifs and out-of-date marketing content.
This Experts Exchange video Micro Tutorial shows how to tell Microsoft Office that a word is NOT spelled correctly. Microsoft Office has a built-in, main dictionary that is shared by Office apps, including Excel, Outlook, PowerPoint, and Word. When …
To add imagery to an HTML email signature, you have two options available to you. You can either add a logo/image by embedding it directly into the signature or hosting it externally and linking to it. The vast majority of email clients display l…

706 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

19 Experts available now in Live!

Get 1:1 Help Now