Solved

I am replacing a failed Cisco 1720 router with a Cisco 2600 for a full Internet T-1 and need help.

Posted on 2004-08-18
15
244 Views
Last Modified: 2010-04-17
Can anyone look this over and tell me how far off i am from a good config. I basically used the config in my 1720. My concern is that the config from the 1720 does not utilize a serial 0/0.1 interface. What is this for and do I need it?

LPSRTR-1960-01#sho config
Using 1050 out of 29688 bytes
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname LPSRTR-1960-01
!
enable secret 5 $1$knCQ$VmLq7mMmiMkxZGCAxhVk4/
enable password 7 045F5D020D791A1D0B1A00
!
!
!
!
!
ip subnet-zero
ip domain-name ALTER.NET
ip name-server 198.6.1.2
!
!
!
!
interface FastEthernet0/0
 description To Office FastEthernet
 ip address 66.162.209.XXX 255.255.255.XXX
 duplex auto
 speed auto
!
interface Serial0/0
 bandwidth 1536
 ip address 216.54.233.XXX 255.255.255.XXX
 encapsulation ppp
 no fair-queue
 service-module t1 timeslots 1-24
!
ip classless
ip route 0.0.0.0 0.0.0.0 216.54.233.XXX
no ip http server
!
snmp-server engineID local 000000090200000427B50860
snmp-server community public RO
!
line con 0
password 7 151D18181623282C
 login
 transport preferred none
 transport input none
line aux 0
password 7 070032585C001A0D
 login
 modem InOut
 transport preferred none
 transport input all
 transport output pad v120 telnet rlogin udptn
 stopbits 1
 flowcontrol hardware
line vty 0 4
 password 7 151D18181623282C
 login
 transport preferred none
!
end

LPSRTR-1960-01#

Thanks,
0
Comment
Question by:TeamPyro
  • 6
  • 5
  • 3
  • +1
15 Comments
 
LVL 15

Expert Comment

by:scampgb
ID: 11835874
Hi TeamPyro,

At first glance, I can't see anything wrong with this config.
If you're not using partial T1, then the "service-module t1 timeslots 1-24" would be the default.

You asked what Serial 0/0.1 meant:
Serial      - Serial interface
0               - Slot 0 of the router
0               - Interface 0 of Slot 0
1               - Subinterface 1 of interface 0 of slot 0

Does that make sense?

I can't see anything in this config that refers to Serial0/0.1 though.

Is your question meant to be "this is what I'm planning to do, is it OK?" or "this is what I have done and it doesn't work?"

If it's the former, then I'd say it looks fine to me!
If it's the latter, let me know and we'll do some more diagnostics :-)

Hope that this helps
0
 

Author Comment

by:TeamPyro
ID: 11836004
First i want to thank you. Second, what I ment is; "this is what I'm planning to do, is it OK?"

Would you be able to elaborate on when you should use serial 0/0.1?
0
 
LVL 15

Expert Comment

by:scampgb
ID: 11836087
Gladly :-)

You tend to use subinterfaces in Serial lines when you've got "channelised" circuits.
T1 is a good example of this, as it is essentially formed from 24 x 64Kb channels.

Rather than using all 24 channels in the same point-to-point link, your telco can actually split these up.  A useful example of this is where you have a central site and lots of remote sites.  The central site would have one T1 circuit, and the channels from the remote sites would be delivered over it.  (I've not explained that very well, but hopfully you've got the gist)

For this to work, you create "subinterfaces" - these are essentially a channel (or number of channels) on the physical serial interface.

Does that help?

0
PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

 

Author Comment

by:TeamPyro
ID: 11836298
Very much so!

Thank you!!! I am off to go and replace the 1720. I will let everyone know how it went later.
0
 
LVL 15

Accepted Solution

by:
scampgb earned 500 total points
ID: 11839205
Best of luck - enjoy your new toy! :-)
0
 

Expert Comment

by:parshal
ID: 11846590
You can also use subinterfaces when configuring for frame relay or atm.  You don't mention what type of serial connection you currently have.
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 11846895
You can't use subinterfaces with encapsulation ppp

0
 

Author Comment

by:TeamPyro
ID: 11848895
T-1 1-24 & encapsulation ppp
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 11852376
Then this is the correct configuration:

interface Serial0/0
 ip address 216.54.233.XXX 255.255.255.XXX
 encapsulation ppp
 no fair-queue
 service-module t1 timeslots 1-24
!

0
 
LVL 79

Expert Comment

by:lrmoore
ID: 11852401
Actually, assuming you have the T1 WIC, this is all you need to configure on the interface:

interface Serial0/0
 ip address 216.54.233.XXX 255.255.255.XXX
 encapsulation ppp
 no shutdown

Any new router, or any router with default config will have all ports shutdown until you enable them with "no shutdown"

The timeslots command is default so no need to add it to the config.
0
 

Author Comment

by:TeamPyro
ID: 11852557
Thanks again.
0
 
LVL 15

Expert Comment

by:scampgb
ID: 11852734
TeamPyro - the config you posted doesn't use subinterfaces, so the PPP should work.
I assume that your comment about subinterfaces was justfor information?

lrmoore is right, interfaces are shut down by default.  I didn't mention it as you posted a config that didn't show the interface as being down; the config also showed the "service-module t1 timeslots 1-24" - which is a default setting if you're using the entire T1.

Have you had chance to try it yet?

0
 

Author Comment

by:TeamPyro
ID: 11852847
For my info only, that is correct.

I must also appologize to all. I installed this router after your last reply on 08/19/04. It came right up!!!!! Thanks for your and everyone's help that replied.

Also, thank you very much for the added bonus info for my benefit.
0
 
LVL 15

Expert Comment

by:scampgb
ID: 11853169
Hi.  Thanks for the "A". I'm glad that I could help and it worked for you :-)
0
 

Author Comment

by:TeamPyro
ID: 11853182
;-)
0

Featured Post

Live: Real-Time Solutions, Start Here

Receive instant 1:1 support from technology experts, using our real-time conversation and whiteboard interface. Your first 5 minutes are always free.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Hello , This is a short article on how would you go about enabling traceoptions on a Juniper router . Traceoptions are similar to Cisco debug commands but these traceoptions are implemented in Juniper networks router . The following demonstr…
Tired of waiting for your show or movie to load?  Are buffering issues a constant problem with your internet connection?  Check this article out to see if these simple adjustments are the solution for you.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

813 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

15 Experts available now in Live!

Get 1:1 Help Now