Dual Homed Mail Server recieves mail on WAN sends back out through LAN

I have an exchange 2003 server... dual homed (two NICS) ...one IP for LAN and one for WAN through pix fw....

I can send and recieve mail fine, the weird thing is that when the smtp server sends out mail to external addresses...it doesnt use the WAN IP I have designated for the exchange server...it routes outgoing messages through the LAN (Internal IP) and out through the gateway...

The LAN NIC is built into MOBO and the WAN NIC is a pci card...dont think this is issue, but becuase LAN NIC is on MOBO, does it default to that NIC first for outgoing TCP packets?

any help would be awesome...
eseyfriedAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

rhandelsCommented:
Hi,

You can set the properties on what NIC has priority, here's how to..

1. Go to the server and open the Network properties.
2. In network properties, go to advanced
3. In the advanced menu choose Advanced Options
4. Make sure that the Internet connection is last in line at the connections box (you can change properties by using the green arrows next to the box).

You could also go to the WAN NIC and make sure that the default gateway is only set on this NIC and make sure it is the ip address of the WAN NIC.

Still i wouldn't use a multihomed Exchange server. You'd better make sure that the Exchange server has one NIC, and that you're router NAT's the external ip addresses port 25 to the internal address of the Exchange server. This is also safer for your Exchange server.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
eseyfriedAuthor Commented:
right on...thanks...my machine is dual homed   192.168.0  addy and a 192.168.1 addy which is static mapped to WAN IP through the PIX Firewall.

All I did was move the WAN connection up to the top, and took off default gateway on the LAN NIC...

thanks alot
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Networking

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.