Solved

Outlook 2003 displays error 0x80042109: '... unable to connect to your outgoing (SMTP) e-mail server.'

Posted on 2004-08-18
27
95,882 Views
Last Modified: 2011-08-18
I'm runnning Outlook 2003 (11.5608.5606) on five Windows 2000 Professional (5.0.2195 SP4) computers, each set up to use an off-site authenticated SMTP server and IMAP.  Two of the computers are now showing signs of the following error for all users, and are completely unable to send e-mail:

Task '<mailserver> - Sending' reported error (0x80042109) : 'Outlook is unable to connect to your outgoing (SMTP) e-mail server.  If you continue to receive this message, contact your server administrator or Internet service provider (ISP).'

We have Norton Anti-Virus 2004 installed, running, and fully updated on all machines.  There is an in-house network over 100MBit ethernet with these five workstations, one file/print server and domain controller running Windows 2003 SBS, one firewall/router, one standard router, and a DSL modem.  As only two of the workstations encounter this problem, the firewall/router is not blocking all port 25 requests (tested from other workstations and the server) - the afflicted workstations are unable to connect to any server on port 25 (SMTP), however.

I have disabled NAV to no great effect, and the mail server settings are identical to the other workstations.  The key to this is the fact that outgoing connections on port 25 (SMTP) are blocked on these workstations.  How, I do not know, but if I can re-enable outgoing port 25 connections, I believe the problem will be fixed.

This must be resolved ASAP, thus the difficulty rating.  Thank you, in advance, for any help.
    - Matthew Bevan
0
Comment
Question by:topfloorcomputer
27 Comments
 
LVL 15

Expert Comment

by:Yan_west
Comment Utility
There is this, but i doubt this is the solution..
Error Message: Outlook Is Unable to Connect to Your Outgoing (SMTP) E-mail Server
http://support.microsoft.com/default.aspx?scid=kb;en-us;302357


Check this out also:

"I may have seen this several times.

My solution was to check the settings and have it checked off that the server requires authentication.

outlook - Tools>services>internet mail
Properties button
Servers tab and check My server requires authentication."
0
 
LVL 15

Assisted Solution

by:Yan_west
Yan_west earned 100 total points
Comment Utility
If your port 25 is blocked, then that is why you are receiving this message.

Hmm there is several people on experts exchange who had that problem..
http://www.experts-exchange.com/Networking/Q_20891651.html?query=0x80042109&clearTAFilter=true
http://www.experts-exchange.com/Networking/Email_Groupware/Q_20706743.html?query=0x80042109&clearTAFilter=true
0
 

Author Comment

by:topfloorcomputer
Comment Utility
I have previousally scoured EE, MSDN/MSKB, and the web via Google, for a solution to this problem and have not found one.  The articles mentioned above (Microsoft, EE, and EE) I have already read and none of which have helped.  The configuration is identical between the machines and the two computers which are acting up worked previousally - the problem was spontaneous, it seems.

The overriding problem here is that all outgoing communications over port 25 are denied on these two workstations.  I already knew this was the reason for the error - I need to know how to fix it.

Also, the SMTP server we use here /requires/ authentication to work.  It does not use POP-before-SMTP authentication, it uses a username/password combo.  Also, it's a slightly grander problem then just Outlook - I am unable to even telnet to any server on port 25, my testbed, the Windows 2003 SBS, and both the "real" name of the SMTP server and the "virutal" name of the SMTP server (one being mail.ourdomain.com and the other being host.hostingcompany.com).

Any other ideas?
0
 
LVL 26

Expert Comment

by:Vahik
Comment Utility
if this happend for no reason then maybe u should look for addware or spyware programs running on those two computers?
also try changing one of the nic cards(i doubt two nics will fail the same time)it wont hurt.
0
 

Author Comment

by:topfloorcomputer
Comment Utility
Ran a complete virus scan over the affected computers and discovered nothing - the user who was logged in when this started lacks permission to install /anything/ on the computer, and as the physical location of these computers is a 40 minute drive to another city... replacing NICs would be difficult.  I'll try re-installing the NIC drivers, but I fear an OS re-install may be nessicary... arg.
0
 
LVL 15

Expert Comment

by:Yan_west
Comment Utility
Hmmm, Is the XP firewall enabled? Probably not that, but if it is, try disabling it. Usually, the xp firewall doesnt block outbound connection tho..
0
 

Author Comment

by:topfloorcomputer
Comment Utility
I'd be impressed if the Windows 2000 machines had Windows XP firewalls. ;-)

But just in case, I made sure the thing most resembling a firewall (IP deny rules inside the connection settings) was disabled.
0
 
LVL 26

Expert Comment

by:Vahik
Comment Utility
topfloor i know u have AV but since two machines went bad the same time it may be
something they downloaded so if u can download a free anti spyware and run it.also make sure users have not downloaded popup blockers(they cause what u describe).
0
 

Author Comment

by:topfloorcomputer
Comment Utility
No spyware, no popup blockers.  Checked both, and no user can install such software - only Administrators can install anything.  Thank you for the suggestions, but I still need a solution to this ASAP - users getting frustrated.

I'll try killing off random processes - we'll see how well that works. ;-)
0
 
LVL 1

Assisted Solution

by:Dissenter
Dissenter earned 200 total points
Comment Utility
Are all of these machines on the same site? I have found that there are a number of ISPs that will not allow port 25 to go anywhere outside of their internal network. This is especially prevelent with dial up ISPs. If the machines are offsite, call the ISP and ask about this.
0
 

Accepted Solution

by:
GJSilva earned 200 total points
Comment Utility
Your ooption is to delete the profile in OL2003 close Outlook reopen it and recreate your profile that's how I fixed mine. Hope it will help.
0
 

Author Comment

by:topfloorcomputer
Comment Utility
All workstations are at one site, all sharing the same ISP.  I have already attempted the easy solutions (delete and recreate profile in Outlook, re-install Outlook, etc.) to no avail.  Re-installing the system worked much better, however, the problem still remains a mystery.
0
 

Expert Comment

by:GJSilva
Comment Utility
    Like Dissenter mention on his comment, PORT 25 is blocked by most ISP today to control SPAM, but if you have and ISP BUSINESS account (Business DSL for exemple) Port 25 should not be blocked most ISPs only block port 25 for Residential accounts. the main thing is the ISPs wont support this, I have worked for many of them that's how I know.

     If you have a business account you need to have an MX Record created with your ISP to better accept your profile. Also if your ISP require authentication look up with them if you need to have the full email address under the Logon Information box i.e. johndoe@myisp.net insteady of just johndoe. I tried to insert a picture for you to see what I mean, but I could not insert it here.  By the way if anyone know how I can attached a snpshot to this box as an exemple let me know please.

     Hope you get it fixed, I know how bad is when you want and need something done and start getting error messages.

 
 
   
0
Control application downtime with dependency maps

Visualize the interdependencies between application components better with Applications Manager's automated application discovery and dependency mapping feature. Resolve performance issues faster by quickly isolating problematic components.

 

Expert Comment

by:GJSilva
Comment Utility
disregard my lest comment...you have other machines that was working fine.  some how you some profile issue on those 2 machines it's clear if you have 5 PCs 3 works fine and 2 dont the problem is configuration that got damage on the affected PCs.
0
 

Expert Comment

by:Lomius
Comment Utility
I have called 3 Cable companies. It took them a while to Divulge the info. But they all said the exact same thing. That port 25 has been blocked, and you MUST use their outgoing SMTP server... I.E.

I use COX.NET with my YAHOO.COM Email so my settings look like this...
POP3= pop.mail.yahoo.com
SMTP= SMTP.COX.NET

This fixed the problem. They assured me that E-mail is still private, but the companies simply don't want others accessing that port. An annoyance really only if your ISP does not provide POP3 Mail... I hope this helps some of you.

Lomius Maximus
0
 

Author Comment

by:topfloorcomputer
Comment Utility
Despite the fact that in most cases, your comments would solve the problem, reading my previous comments reveals that port 25 is only firewalled on the machine itself, not outside the building.  Two machines cease to create connections on port 25, thus causing the problem.  There are three other machines which continue to work fine, and, once the system was re-installed, both of the computers began functioning properly again.

Thanks to everyone who posted constructive comments.
0
 

Expert Comment

by:dkmedicine
Comment Utility
After much arduous researching this exact problem with my computer using Outlook 2003 on an Earthlink account accessed through a cox cable network, I found that by changing my outgoing port to 443 from 25 totally solved the problem...

Good luck to all
0
 

Expert Comment

by:gamblerc
Comment Utility
I recently came across the same problem and tracked the issue to Norton Anti Virus 2003. Outlook 2003 was functioning properly until the user downloaded a new virus definition file. Disabling Norton completely did not solve the problem, but disabling the email scanning properties for both incoming and outgoing emails solved the problem.

I hope this suggestion will benefit someone else who may encounter this problem.

gamblerc
0
 

Expert Comment

by:PatrickEpps
Comment Utility
We had the same problem.  It turns out to be an issue with Windows Firewall Settings (we think).  Logged in as local Admin and switched off the firewall and shutdown all services to Symantec AV, then tried to telnet to port 25 on the mail server, and it worked (previously had failed).  Switched Firewall back on and restarted Anti Virus and tried again, and all Okay.  Rebooted machine and logged in as restricted access user and tried to telnet to port 25 again, which worked with no problems.
0
 

Expert Comment

by:yankinlk
Comment Utility
I had a very similar issue with a windows xp sp2 machine running Mcafee Virusscan 8. Hidden in the Virusscan Console was a service called Access Protection which had 6 port blocking rules applied.  One of these was to prevent mass mailing of worms on port 25.

From your description above you never mentioned disabling antivirus, did you try that?  Once I unticked the rule, my telnet on port 25 returned.
I have searhced I high and low for a solution to this problem and it was driving me mad!!!!!
0
 

Expert Comment

by:Estermer
Comment Utility
I had the same problem.  Most large ISPs no longer let you telnet to port 25, so it looks like the port is filtered/blocked.  It wasn't filtered at the gateway because other systems were using the same connection.  I killed AV, I killed the local firewall.  Still couldn't connect.  I tried deleting and recreating the profile, no luch.  The symtoms i experienced appear as though there is an issue making a connection.

However, try this.  Create a new pst, tell outlook to deliver to that new pst.   And then try to do a Send receive.  If this works,  Do a file export of the pst with data to a new pst and set that new one as the pst to deliver mail to.  Check to makes sure you can send/receive and life should be good.  Using scanpst.exe (Inbox Repair Tool) does not fix the problem.  I spent the last 6 hours chasing a ghost because it looks like a connection problem, so if you are still having problems give this a try, it may work for you.
0
 

Expert Comment

by:Adrynet
Comment Utility
Hi everybody. I've got not solution but I think I understood the cause. This happens when you change the account name in your outlook 2003 account list. For example, if you have:

john@example.com

and then rename this account into:

Account of john@example.com

You got the problem. I don't know where but I think that's a reference bug because Outlook it's trying to refer to account "john@example.com" but now there is just "Account of john@example.com".

Comments are accepted and precious

Have a nice day
Adriano
0
 

Expert Comment

by:Adrynet
Comment Utility
0
 

Expert Comment

by:Adrynet
Comment Utility
Now It works again, maybe is really all related to Transparent Proxying (I'm hating it..). I think my SMTP server has just a delay and in this interval locks you when you try to connect. Now it's all OK.

Perhaps you should call your ISP asking about their Transparent Proxying polices.

Have a nice day
Adriano




the article body
___________________________________________________________
0x80042109 SMTP server problem

I post fixes to computer problems I have that takes me ages to fix, in the hope that someone else might be able to find the solution and so save themselves the pain. In this case, I couldn't send outgoing email via my SMTP server on port 25 despite the fact that I could receive email fine. It all came down to transparent proxying, but it took a while to find out. If this helps you, please drop a note to let me know, otherwise I feel like I'm writing for the web-bots.

Basically, when I tried to do a send/receive with Outlook, everything went well until it tried to send my outgoing messages, at which point it would hang for a while, and after the pause, I'd get error number 0x80042109, with some problem connecting to my SMTP server. But this would happen only through some connections and not through others.

Microsoft's online help service, which is frankly usually quite good, was completely useless in this case. It has some blurb about MSN messages that doesn't really help at all.

What it turned out to be is that my ISP is using something called "Transparent Proxying", which they didn't bother to tell us they were doing. It's part of a spam-prevention toolkit that prevents anyone who subscribes to this ISP from connecting to any machine's port 25 other than the ISP's own SMTP server. Annoying? Oh yes. Especially since it took me 2 days to work out what the damn problem was.

In my case, my email provider has a workaround. They've set up another port on which the SMTP server will respond, and their authentication system requires that I log into the POP3 server before the SMTP server will acknowledge my existence. This conveniently bypasses the port 25 block my ISP has set up. That's all this problem really was - my ISP was blocking connections to port 25 on any machine other than their own SMTP server.

If you're struggling with something similar, try TELNET to any SMTP server you can find outside of your own ISP's address range (port 25) - if it doesn't work there, but it works on your ISP's SMTP server, then this is your problem - scream at your ISP, and much good may it do you.
0
 

Expert Comment

by:gmctech
Comment Utility
I had the same experience w/ Outlook 2003.  I noticed that I was able to successfully connect and send/recieve email after I created my first account.  Then I tried to create a second account (and I changed the .pst file location at the same time.  Immediately afterwards, I started receiveing the username/password error.  
 
After a bit of time, I was able to get Outlook working by using the login info for the second account created, but only that account.  I cannot add another account r everything stops working).  Deleting accounts and recreating them does not work either.    I can however, always seem to get things working in the second account.
 
Unfortunately, the account that works is not the preferred account.  Right now, Outlook2003 is unusable to me, so if anyone has any suggestions, I would certianly appreciate hearing some.  
 
Many thanks.
0
 

Expert Comment

by:gmctech
Comment Utility
Okay, I have found a solution that fixes this problem.  
 
Delete any Outlook profiles you have created (not email accounts, but Outlook profiles), and re-create them.  Once you do this, you can re-create your email accounts, and everything (so far) seems to work as intended
(even no problem adding multiple email accounts to the same profile works).  

Good day and good luck.
gmctech
0
 

Expert Comment

by:sdmarler
Comment Utility

"I have called 3 Cable companies. It took them a while to Divulge the info. But they all said the exact same thing. That port 25 has been blocked, and you MUST use their outgoing SMTP server... I.E.

I use COX.NET with my YAHOO.COM Email so my settings look like this...
POP3= pop.mail.yahoo.com
SMTP= SMTP.COX.NET

This fixed the problem. They assured me that E-mail is still private, but the companies simply don't want others accessing that port. An annoyance really only if your ISP does not provide POP3 Mail... I hope this helps some of you.

Lomius Maximus"

This fixed my issue for me. Since I was using a different ISP, but trying to connect to an smtp server of a different ISP, I used my current smtp server and I'm able to send e-mail.  Thanks Lomius!
0

Featured Post

Free Trending Threat Insights Every Day

Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

Join & Write a Comment

Use email signature images to promote corporate certifications and industry awards.
Follow this checklist to learn more about the 15 things you should never include in an email signature from personal quotes, animated gifs and out-of-date marketing content.
Get people started with the process of using Access VBA to control Outlook using automation, Microsoft Access can control other applications. An example is the ability to programmatically talk to Microsoft Outlook. Using automation, an Access applic…
This video shows how to remove a single email address from the Outlook 2010 Auto Suggestion memory. NOTE: For Outlook 2016 and 2013 perform the exact same steps. Open a new email: Click the New email button in Outlook. Start typing the address: …

763 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

7 Experts available now in Live!

Get 1:1 Help Now