Solved

rdist - A remote host refused an attempted connect operation.

Posted on 2004-08-19
10
4,308 Views
Last Modified: 2013-12-23
I need to rdist a file from serverA to serverB. When I do a rdist from serverA, it's giving me a "A remote host refused an attempted connect operation.". I have added the serverA's ssh key in serverB and I can ssh without password. But i don't think this is the problem.
1) Do I need to add serverA's ip/hostname into serverB's hosts.allow?
2) What else do I need to check?
3) What causes this refusal from the remote host?
0
Comment
Question by:lothlorien
  • 4
  • 3
  • 2
  • +1
10 Comments
 
LVL 40

Expert Comment

by:jlevie
ID: 11844246
What OS are you trying to do this on? What was the rdist command line and what is the contents of the rdist control file on the local system?
0
 
LVL 38

Expert Comment

by:yuzh
ID: 11848967
rdist is for Solaris only, to make rdist to work your need to create a .rhosts file
under usr's home dir in the remote box, or /etc/host.equiv file.

man rdist
0
 

Author Comment

by:lothlorien
ID: 11849063
I'm doing this in 2 Solaris AIX server.

========================================
serverA (11.111.11.11)

user1 rdist command line: $ rdist

distfile:
_______________________________
HOSTS = ( user2@22.222.22.22 )

FILES = ( /tmp/a )

${FILES} -> ${HOSTS}
_______________________________
=========================================
serverB (22.222.22.22)

.rhosts is already created in user2's home directory, chmod 600:
_________________
serverA user1
11.111.11.11 user1
_________________
Didn't add anything in /etc/host.equiv
=========================================

I am suspecting it's the hosts name not resolving. Do I need to add the below in serverA's hosts?
22.222.22.22 serverB
0
Manage your data center from practically anywhere

The KN8164V features HD resolution of 1920 x 1200, FIPS 140-2 with level 1 security standards and virtual media transmissions at twice the speed. Built for reliability, the KN series provides local console and remote over IP access, ensuring 24/7 availability to all servers.

 
LVL 40

Expert Comment

by:jlevie
ID: 11849114
Could there already be a /tmp/a file on the remote not owned by user2? I'm confused by your statement that this is happening on "2 Solaris AIX server". Do you mean that both are Solaris or AIX or that one is Solaris and the other AIX? If the systems have dissimilar operating systems there's a good chance that you won't be able to use rdist between them. I know for sure that you can't rdist between a Solaris and Irix system because the rdist implementations differ.

yuzh,

" rdist is for Solaris only" I'm sorry but that's not true. It exists on my RedHat systems  and has been on every *BSD box I've used including Irix.
0
 
LVL 38

Expert Comment

by:yuzh
ID: 11849142
At box A, type in:
rsh 22.222.22.22 echo test

If you can see "test" echoed back to your screen, you permission is OK, otherwise
check your setup again.

also check /etc/inetd.conf to make sure that the r* is not disable. (Warming rsh is
NOT secure, consider use secure shell -- ssh instead!!!)

Good luck!

0
 
LVL 38

Expert Comment

by:yuzh
ID: 11849170
jlevie,
     Thanks for the correction, rdist also available for HP-UX, and AIX, but not for SCO.
0
 

Author Comment

by:lothlorien
ID: 11849228
jlevie,
Oops, I mean serverA AIX and serverB Solaris. Are they able to rdist to each other? Any idea if there is some patch that we're suppose to apply to have these functions?

yuzh,
At serverA, below return same error "A remote host refused an attempted connect operation."
rsh 22.222.22.22 echo test

I've checked /etc/inetd.conf and the below is disabled:
#shell   stream  tcp    nowait  root    /usr/sbin/tcpd  rshd
#login   stream  tcp    nowait  root    /usr/sbin/tcpd  rlogind
#exec    stream  tcp    nowait  root    /usr/sbin/tcpd  rexecd

Sorry for asking the above as I need to make sure that these are what I'm suppose to change as I need to raise a request to another person who owns this server.

Previously I was using RedHat and rdist works fine with ssh ie "rdist -P /usr/bin/ssh -f file". But seems like neither AIX or Solaris are having these options.
0
 
LVL 38

Accepted Solution

by:
yuzh earned 50 total points
ID: 11849587
rshd was disable that's why rsh doesn't work!

have a look at the following page to learn more about /etc/inetd.conf:
http://ist.uwaterloo.ca/security/howto/2000-09-19/inetd.html
0
 
LVL 40

Expert Comment

by:jlevie
ID: 11851580
> I mean serverA AIX and serverB Solaris. Are they able to rdist to each other?

Not having tried that combination I can't say. But since it worked before with RedHat there's a decent chance that it will.

As yuzh pointed out the immediate problem is that rshd isn't enabled. Fix that (and set up a correct ~/.rhosts) and let's see what happens.
0
 
LVL 62

Expert Comment

by:gheist
ID: 11865058
> Are they able to rdist to each other?

each has rdist in a bit different path, for example aix will try to run /usr/local/bin/rdist via rsh ..... ( mkdir -p /usr/local/bin ; ln -s `which rdist` /usr/local/bin/rdist # to work around on solaris )
0

Featured Post

What is SQL Server and how does it work?

The purpose of this paper is to provide you background on SQL Server. It’s your self-study guide for learning fundamentals. It includes both the history of SQL and its technical basics. Concepts and definitions will form the solid foundation of your future DBA expertise.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

If you're not part of the solution, you're part of the problem.   Tips on how to secure IoT devices, even the dumbest ones, so they can't be used as part of a DDoS botnet.  Use PRTG Network Monitor as one of the building blocks, to detect unusual…
In this article, I am going to show you how to simulate a multi-site Lab environment on a single Hyper-V host. I use this method successfully in my own lab to simulate three fully routed global AD Sites on a Windows 10 Hyper-V host.
Viewers will learn how to connect to a wireless network using the network security key. They will also learn how to access the IP address and DNS server for connections that must be done manually. After setting up a router, find the network security…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

830 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question