Solved

ExMerge Fails with multiple errors.

Posted on 2004-08-19
5
3,635 Views
Last Modified: 2008-01-09
We are in the process of upgrading out Exchange 5.5 Servers to Exchange 2003.  We have been trying to use the ExMerge tool however, we continue to get MAPI failures.  Also, ExMerge is reporting my Exchange 5.5 server as an Exchange 4.x server.  I have included a copy of the ExMegre log file.  My question is, how do we correct these errors and get the process functioning properly?

Any help will be appreciated.


Start Logging:August 19, 2004   09:18:18
****************************************************************
[09:18:18] Logging Level: None
[09:18:18] Reading settings from file 'C:\Documents and Settings\User\Desktop\exmerge\Exmerge\EXMERGE.INI'.
[09:18:19] Error 8007203a opening an LDAP connection. ('LDAP://ServerName:3389/rootDSE')  (CADRoutines::GetNamingContextData)
[09:18:20] Error 8007054b opening an LDAP connection. ('LDAP://rootDSE')  (CADRoutines::GetNamingContextData)
[09:18:20] 'ServerName' is running Exchange Server 4.x
[09:18:20] Source server read from settings file is 'ServerName'.
[09:18:20] Invalid LDAP Port number entered in INI file (''). Ignoring this setting.
[09:18:20] Reading list of subjects for messages to be selected from file ''
[09:18:20] Reading list of attachment names for messages to be selected from file ''
[09:18:20] List of folders to be ignored has been read. 0 folders in the list.
[09:18:20] The file containing the list of mailboxes to be processed, 'C:\Documents and Settings\administrator\Desktop\exmerge\Exmerge\MAILBOXES.TXT' is missing or inaccessable. The filename was obtained from the FileContainingListOfMailboxes .INI file setting.
[09:18:20] Current machine locale ID is 0x409
[09:18:20] Operating System Version 5.1 (Build 2600)
[09:18:20] Incorrect registry value data type for 'Software\Microsoft\Exchange\Setup\ExchangeServerAdmin'.
[09:19:07] Error 8007203a opening an LDAP connection. ('LDAP://ServerName:3389/rootDSE')  (CADRoutines::GetNamingContextData)
[09:19:08] Error 8007203a opening an LDAP connection. ('LDAP://DomainController:3389/rootDSE')  (CADRoutines::GetNamingContextData)
[09:19:08] 'ServerName' is running Exchange Server 4.x
[09:19:53] Using attribute 'PR_MESSAGE_DELIVERY_TIME' for date operations.
[09:19:53] Merging data into target store. The program will copy only those messages that do not exist in the target store.
[09:19:53] Associated folder data will NOT be copied to the target store.
[09:19:53] Using 'English (US)' (0x409) as the default locale (Code page 1252)
[09:19:53] All mailboxes will be processed, regardless of locale
[09:19:53] Using default locale for all mailboxes
[09:19:53] Initializing worker thread (Thread0)
[09:19:53] Copying data from mailbox 'Username' ('UserName') on Server 'ServerName' to file 'C:\WINDOWS\TEMP\username.PST'.
[09:19:53] Error initializing MAPI.
[09:19:53] Errors encountered. Copy process aborted for mailbox 'UserName' ('Username').
[09:19:53] MAPI has not been initialized (CMapiSession::DeleteOurProfile)
[09:19:53] Number of items copied from the source store for all mailboxes processed: 0
[09:19:53] Total number of folders processed in the source store: 0
[09:19:53] 0 mailboxes successfully processed. 1 mailboxes were not successfully processed. 0 non-fatal errors encountered.
[09:19:53] Process completion time: 00:00:00
0
Comment
Question by:TinsleyC
  • 3
  • 2
5 Comments
 
LVL 5

Expert Comment

by:MFay
Comment Utility
Are you trying to do an export?  You MUST use exmerge version 3.71 as a minimum with Exchange 5.5.  What version are you using?

0
 

Author Comment

by:TinsleyC
Comment Utility
I am using ExMerge 2000.  And yes I am trying to do an export.
0
 
LVL 5

Accepted Solution

by:
MFay earned 500 total points
Comment Utility
Are you logged in with an account that has Service Account Permission to all mailboxes on the Source Exchange Server?  Did you read through the documentation?

0
 

Author Comment

by:TinsleyC
Comment Utility
We made the necessary changes to Exchange to allow the administrator to be the service acccount.  We had brought in a consultant to work on this.
0
 

Author Comment

by:TinsleyC
Comment Utility
We have this working now.  It turned out to be an authentication issue.  When I mapped a drive letter on the Exchange server it asked me for a name/password.  Once that was supplied, I was able to connect properly and exmerge worked correctly.
0

Featured Post

Promote certifications in your email signature

Has your company recently won an award or achieved a certification? They'll no doubt want to show it off. Email signature images used to promote certifications & awards can instantly establish credibility with a recipient and provide you with numerous benefits.

Join & Write a Comment

Disabling the Directory Sync Service Account in Office 365 will stop directory synchronization from working.
Scam emails are a huge burden for many businesses. Spotting one is not always easy. Follow our tips to identify if an email you receive is a scam.
In this video we show how to create a User Mailbox in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Recipients >> Mailb…
In this video we show how to create a mailbox database in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Servers >> Data…

743 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

15 Experts available now in Live!

Get 1:1 Help Now