Go Premium for a chance to win a PS4. Enter to Win

x
?
Solved

IE6 Proxy Server Settings Will Not Save

Posted on 2004-08-19
5
Medium Priority
?
740 Views
Last Modified: 2008-01-16
I am currently deploying PCs running Windows XP Professional, Service Pack 1, running Microsoft Internet Explorer 6, Service Pack 2 (6.0.2800.1106.xpsp2.030422-1633, to be exact).  Users are being set up with local profiles.  I am manually configuring Proxy settings to our Proxy, 10.18.x.x:8080, selecting Use a Proxy Server..... and Bypass Proxy...... check boxes.  When users logoff/log back on, the settings disappear.  I manually configured the settings in the registry (HKEY_CURRENT_USER\Software\Microsoft\Windows\Internet Settings) with the following values:  ProxyServer: 10.18.x.x:8080, ProxyOverride <local>, ProxyEnable 1. When applied, these settings hold, until users logoff, log back in.  Use HTTP 1.1 set in advanced settings, both check boxes.  Any help would be appreciated.
0
Comment
Question by:thumper666
  • 3
  • 2
5 Comments
 
LVL 57

Expert Comment

by:Pete Long
ID: 11846489
Have you tried setting it in Group policy?

On a domain controller open "Active directory Users and computers"

NOTE: As said above you can apply a GP to an OU in this instance we will deal with a domain GP, if you are concerned with a GP for an OU insert the "OU name" instead of the "Domain Name"

1. Locate the domain (top of the Tree) and right click it, then select "Properties"
2. Select the group policy Tab.
3. You will see the Default domain policy (and any other policies applied at this level)
4. You can create another domain policy by clicking "New" giving it a name and configuring it"
5. Ensure the default domain policy is highlighted and select "Edit" (unless you are working on another policy)
6. The Group policy object editor will open.
7. You can now edit the policy and close the editor when you are finished.
8. Back in the domain properties click "apply" and "OK"

Troubleshooting Group Policy in Windows Server 2003
http://www.microsoft.com/downloads/details.aspx?FamilyId=B24BF2D5-0D7A-4FC5-A14D-E91D211C21B2&displaylang=en

Group Policy Infrastructure White Paper
http://www.microsoft.com/downloads/details.aspx?FamilyId=D26E88BC-D445-4E8F-AA4E-B9C27061F7CA&displaylang=en

======================================================================

Set Proxy Server: user configuration >windows settings >internet explorer maintenance >connection >proxy settings
    NOTE Proxy IP can be set in DHCP options also (See option 252 on the scope)

======================================================================

this can also be set in LOCAL polict Start >Run >gpedit.msc {enter}

policy is in the same place as above :)
0
 

Author Comment

by:thumper666
ID: 11855917
I'm not running Active Directory on any of our servers/workstations.  Profiles are local.  They do not roam.  Applied the policy setting, per your instructions.  I was able to apply, but the settings went away once I logged off/logged back in.  

I noticed the proxy settings stayed at first, but once a .exe file called NET.exe ran, the settings were removed.  I'm assuming there's a setting in the NET.exe which is clearing these settings.  How can I modify this .exe, or, would it be safe to remove from starting on reboot?
0
 
LVL 57

Accepted Solution

by:
Pete Long earned 750 total points
ID: 11858483
Open Windows Explorer window. Click Tools -> Folder Options -> View tab -> uncheck Automatically search for network folders and printers.
Then
Start -> Settings -> Control Panel -> Network Connections -> right-click Local Area Connection -> drop everything except Internet Protocol (TCP/IP) and Client for Microsoft Networks. Note: Add File and Printer Sharing later if you need it.

Unsure why net.exe it causing you problems, its a standard DOS command
The NET command
http://www.robvanderwoude.com/index.html

0
 

Author Comment

by:thumper666
ID: 11871775
Pete-

My bad.  I neglected to query our account administrator at our office.  When I did, I found out that certain accounts were running a login script.  One of the purposes of this script was to wipe out any internet proxy settings.  None of the commands are needed.  I removed the login script, logged in a couple of users, made the changes, logged off, back in.  The settings held.

Thanks for your help.  I was just concentrating too much on the PCs as culprits!
0
 
LVL 57

Expert Comment

by:Pete Long
ID: 11873294
:) ThanQ  -glad you got it sorted
0

Featured Post

Vote for the Most Valuable Expert

It’s time to recognize experts that go above and beyond with helpful solutions and engagement on site. Choose from the top experts in the Hall of Fame or on the right rail of your favorite topic page. Look for the blue “Nominate” button on their profile to vote.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I had to do a bit of research to find the answer to this question so I thought I'd share my results.  Due to our outdated mainframe systems, we need to downgrade IE9 to IE8 in order to stay compatible.  We also needed to downgrade Java.  In order to…
If you are a web developer, you would be aware of the <iframe> tag in HTML. The <iframe> stands for inline frame and is used to embed another document within the current HTML document. The embedded document could be even another website.
Shows how to create a shortcut to site-search Experts Exchange using Google in the Chrome browser. This eliminates the need to type out site:experts-exchange.com whenever you want to search the site. Launch the Search Engine Menu: In chrome, via you…
Want to learn how to record your desktop screen without having to use an outside camera. Click on this video and learn how to use the cool google extension called "Screencastify"! Step 1: Open a new google tab Step 2: Go to the left hand upper corn…
Suggested Courses

972 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question