• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 267
  • Last Modified:

dummy.net sufix blocks access to LAN machines by names

Hello, experts, I have a problem :P

I have 3 machines in my LAN, well configured, same workgroup and they are all naned (PC1, PC2, PC3) and visible with manual configured IP's (192.168.0.1, 192.168.0.2, 192.168.0.3). First of them has a second network card connected to a router (internet). This is "ipconfig" log for it (I delete public IP, sorry :)

Adaptador Ethernet Conexión LAN          :
        Sufijo de conexión específica DNS :
        Dirección IP. . . . . . . . . . . : 192.168.0.1
        Máscara de subred . . . . . . . . : 255.255.255.0
        Puerta de enlace predeterminada   :

Adaptador Ethernet Conexión Router          :
        Sufijo de conexión específica DNS : dummy.net
        Dirección IP. . . . . . . . . . . : ___.___.___.___
        Máscara de subred . . . . . . . . : 255.255.255.0
        Puerta de enlace predeterminada   : ___.___.___.___

Here is the problem. I want to use Automatic IP assignation in my LAN. Time ago, I have not had any problems for this, and doing "ping PC2" from PC1 console returns me right response from PC2. But now, I have problems because "PC2" changes to "PC2.dumy.net" name and same ping command returns bad results (one internet IP, not LAN). What is wrong? Why I have "dummy.net" suffix now for all names I write?

By the way, Windows XP SP1 is installed in all of them, and accesing via explorer to \\PCx is OK. But i cannot use any network program if I write names. I have to put static IP's.

I have tested network wizard by Windows, and I do not want to solve the problem modifying "hosts" file, because I will have to put static IPs. I want "cleaner" solution (time ago it worked).

Ah! And Router connection is also configured with automatic IP's. Router has all data. Perhaps a Router misconfiguration? (I have a 3com 812).

Thanks!
0
rabanero
Asked:
rabanero
  • 2
1 Solution
 
PennGwynCommented:
Your machines are trying to use DNS to resolve names, without trying WINS resolution first. This could work if you had a DDNS server in the network, but you don't.  (It's the preferred config for larger networks using Active Directory, but that's not you either.)

I suspect it's as simple as a checkbox somewhere in the Networking config on each box, labelled something like "Use WINS for name resolution".  Make sure it's turned on.

0
 
PennGwynCommented:
Hang on -- \\PCx couldn't work unless WINS resolution was enabled.

In the Networking config, there's a place where you give the local DNS domain as "dummy.net".  Somewhere very close to that is a checkbox which determines whether it first tries to resolve the name without that suffix, and then again with it, or if it only tries with it.  You need the first case....

0

Featured Post

SMB Security Just Got a Layer Stronger

WatchGuard acquires Percipient Networks to extend protection to the DNS layer, further increasing the value of Total Security Suite.  Learn more about what this means for you and how you can improve your security with WatchGuard today!

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now