Solved

Domain Controller - RPC server is unavailable

Posted on 2004-08-20
10
2,467 Views
Last Modified: 2009-07-29
So its Friday night around 5 pm and I m getting ready to head home and our DC locks up and I restart it 3 times. We have lost outside internet access and the DC is no longer available to the network! Everything else is working fine, I have setup an additional DC as a backup, but its not working like its supposed to, cuz we still dont have outside access, but I think its running the rest of the network because everything else is communicating with each other.

One of the things I noticed was that the c:\ drive is a 4 gig partition and its only got 7% free space. the other side of that partition has 63gigs available.

I can not ping any address on the network from the DC but on other computers i can ping our router/firewall/other machines. When I try to manualy replicate I get the following error :

 The RPC server is unavailable. This condition may be caused by a DNS lookup problem.

I double checked that the RPC service was running, and it is, I also typed in : NET START RPCSS to verify it was running, it was.

This is a windows 2000 server running DNS.
0
Comment
Question by:digitalslavery
  • 5
  • 3
  • 2
10 Comments
 
LVL 2

Expert Comment

by:TASINetwork
ID: 11857582
Sounds EXACTLY like a DNS problem.  Make sure that every single PC and server are pointed to the DCs for DNS and ONLY the DCs.  Your internet connection going down and causing the problem tells me that this is the problem almost gauranteed!
0
 

Author Comment

by:digitalslavery
ID: 11857717
well it is a dns problem, as i am finding out, I have another box setup in the lab for being a DC running DNS and now i can access the web no problem! but I m still stuck with what is going on with my main DC? and why all of the sudden does it just freak out and have to be restarted? I am guessing that it has something to do with the hard drive only have 7% free space. The only thing I can think of doing is wiping the partiontion from the drive and reinstalling the OS.

Is there a better way?
0
 
LVL 9

Expert Comment

by:jamesreddy
ID: 11858653
Yes.  Possibly.  There are two things that you can "move" to free up space on the C drive.  The virtual memory file and the printer spooler.

To move the virtual memory file:

1. Right-click My computer, then click Properties
2. Clicked the Advanced tab
3. Click the Settings button under Performance.
4.  Find your virtual memory setting and if there is one on the C drive, set it to zero and move it to the D drive with the same setting (same Min and MAX sizes)
5.  Apply and ok

Don't reboot yet.

To move the printer spooler:

1.  Click Start > Printers and Faxes
2.  Click the File Menu, then Server Properties
3.  Click Advanced
4.  If the Spooler file listed is on the C drive, move it to another drive (even if this is not used as a print server).


That'll help you with freeing up space...but I am not sure it's going to address your DNS problem.  You can ive it a try and let us know how it goes.

James
0
VMware Disaster Recovery and Data Protection

In this expert guide, you’ll learn about the components of a Modern Data Center. You will use cases for the value-added capabilities of Veeam®, including combining backup and replication for VMware disaster recovery and using replication for data center migration.

 
LVL 2

Expert Comment

by:TASINetwork
ID: 11858783
You could also try ServerMagic by PowerQuest to resize your partitions, but I really don't think that's the problem.  It sounds like you still have enough space to not have disk space causing a problem.  If you don't have enough disk space, servers usually just start running slow and don't usually STOP working until the disk is around a couple megs free.

Make sure that the DC is pointed only to either itself or other DCs if you have more and absolutely NO outside DNS
0
 

Author Comment

by:digitalslavery
ID: 11859274
Well I tried resizing the partition using Partition Expert and made the the other 63 gigs availabe as a drive that I could use, before it was not even seeing it, my intent was to increase the size of the c drive so that I would have more room, but it kept giving me an error saying that the disk was full and no further actions could be completed. Then I backed up everything on the c drive to the newly created drive and restarted. When the server restarted it stopped at a dos promt and gave me an error saying some file was corrupt and counld not boot.

I went and checked a couple of the desktops around the office to see if they were able to gain access to the internet, since I had setup the the other lab machine, which is an extra workstation we had, and heres whats happening, the computers are not picking up the replication of the new DC, I have to click on the LAN icon down by the clock and click the support tab and use the repair option in order for the computers to see that a new DNS server is available, it does make the change and then they can access the web. Also my Exchange server is not sending and recieving mail, I can open up outlook and my inbox appears with all my messages, but no new messages and I am getting the Working Offline mode. So no mail service is available, I did manually configure the exchange server to the new DNS address, but its still not working.

Right now I am getting ready to use the backup I made last night just before I shut down and the server failed to boot to restore the OS, I did an fdisk to delete the partition so now I have a 34 gig partition to install the OS. but If for some reason this does not work I need to figure out why my exchange server is working in offline mode.

Thanks for everyones help so far . . .
0
 

Author Comment

by:digitalslavery
ID: 11859863
So far everything seems to be working ok, except that our exchange server is still working in Offline Mode. It seems as thou I still need to adjust a DNS setting for the exchange server to work correctly with our new DC, but I m not sure what to do exactly.

I just got server 2k3 installed on the server that crashed, on one of the other partitions that I created and now have to go and setup all the DC attributes to run the network. lets see what happens . . . .
0
 

Author Comment

by:digitalslavery
ID: 11860548
still having problems getting exchange server to send and recieve mail. shows that its working in offline mode. Any ideas on what I should start looking at?
0
 
LVL 2

Accepted Solution

by:
TASINetwork earned 250 total points
ID: 11862015
have you tried turning off offline mode?  If the DNS is not correct, that could also cause the problem.  Here is how to setup your DNS (replace the server names and IPs with your own):

DC IPs
server1: 192.168.1.10
server2: 192.168.1.11

DNS config:
Server1:  Point DNS to 192.168.1.11 only (second entry blank)
Server2:  Point DNS to 192.168.1.10 only (second entry blank)
All other servers/workstations:  192.168.1.10 primary, 192.168.1.11 secondary
0
 

Author Comment

by:digitalslavery
ID: 11865531
Well it turns out that after reinstalling the OS and setting everything up, I needed to enable the Global Catalog option on ther server and then reboot, after that everything is working great! One important lesson I learned was that anytime a change is made to the dns you need to restart the service or reboot the machine. duh!

Thanks for your help I am awarding the points to TASINetwork for your support! w00t :)~
0
 
LVL 9

Expert Comment

by:jamesreddy
ID: 11865686
Glad you got it working.
0

Featured Post

Efficient way to get backups off site to Azure

This user guide provides instructions on how to deploy and configure both a StoneFly Scale Out NAS Enterprise Cloud Drive virtual machine and Veeam Cloud Connect in the Microsoft Azure Cloud.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
VPN 101 - how and which protocol? 9 109
Routing between two networks? 10 56
How to best manage folder and file security 4 101
Freeproxy running on Server 2012 R2 2 56
Enterprise networks where VoIP phones have been deployed frequently use port configurations that allow both a computer and an IP phone to be plugged into the same switch port but use different VLANs. On Cisco equipment I'm referring to the "native V…
Preface There are many applications where some computing systems need have their system clocks running synchronized within a small margin and eventually need to be in sync with the global time. There are different solutions for this, i.e. the W3…
Although Jacob Bernoulli (1654-1705) has been credited as the creator of "Binomial Distribution Table", Gottfried Leibniz (1646-1716) did his dissertation on the subject in 1666; Leibniz you may recall is the co-inventor of "Calculus" and beat Isaac…
The Email Laundry PDF encryption service allows companies to send confidential encrypted  emails to anybody. The PDF document can also contain attachments that are embedded in the encrypted PDF. The password is randomly generated by The Email Laundr…

773 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question