?
Solved

How can I have 3 IP address for 1 Ethernet Interface?

Posted on 2004-08-20
10
Medium Priority
?
243 Views
Last Modified: 2010-04-11
I have Router 3745, it has 1 Ethernet Interface.
On my Lan, I have 3 subnet.
I want to have 3 default gateway for these 3 subnet to this 3745.
So How can I have 3 IP address on Router 3745?
And If I use 2500. Can I do that?
Is it depend on IOS? Which IOS on 3745 or 2500, I need to use?
0
Comment
Question by:itman04
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
10 Comments
 
LVL 15

Accepted Solution

by:
scampgb earned 500 total points
ID: 11858459
Hi itman04,

I think that the "secondary" IP address can be used for what you want, I'm not sure if you can have a third one though.

Example would be:

interface ethernet 0
ip address 192.168.1.1 255.255.255.0
ip address 192.168.4.1 255.255.255.0 secondary

I hope that this helps - let me know if I can be of any further help.
0
 
LVL 1

Expert Comment

by:kmckinstry
ID: 11859467
Not sure if this will work for you, but you might want to try:

!    ISP interface
interface Ethernet1
 ip address 66.119.82.8 255.255.255.240
 ip nat outside
!
!
!    Allow traffic from internal LAN out
access-list 1 permit 10.10.0.0 0.0.255.255
!
ip nat inside source list 1 interface Ethernet1 overload
ip nat inside source static tcp 10.10.1.1 66.119.82.8 extendable
ip nat inside source static tcp 10.10.2.1 66.119.82.8 extendable
ip nat inside source static tcp 10.10.3.1 66.119.82.8 extendable
!
0
 
LVL 16

Assisted Solution

by:Nyaema
Nyaema earned 500 total points
ID: 11863599
Just helping scampgb

conf t
interface ethernet 0
ip address 192.168.1.1 255.255.255.0
ip address 192.168.4.1 255.255.255.0 secondary
ip address 192.168.10.1 255.255.255.0 secondary

Three IP Addresses...
0
Supports up to 4K resolution!

The VS192 2-Port 4K DisplayPort Splitter is perfect for anyone who needs to send one source of DisplayPort high definition video to two or four DisplayPort displays. The VS192 can split and also expand DisplayPort audio/video signal on two or four DisplayPort monitors.

 
LVL 15

Expert Comment

by:scampgb
ID: 11863617
Hi Nyaema - thanks :-)
I thought that you could probably do it, but I've never done it myself!
0
 
LVL 8

Expert Comment

by:MarkDozier
ID: 11867461
You can configure sub-interfaces on the interface.
0
 
LVL 16

Expert Comment

by:Nyaema
ID: 12578004
The LearnedOne...
I think I exhaustively answered this questiion and therefore deserve the points.

Isn't that right Itman04? =)
0
 
LVL 15

Expert Comment

by:scampgb
ID: 12578867
TheLearnedOne: I suggest Nyaema's first comment is accepted
0

Featured Post

Optimum High-Definition Video Viewing and Control

The ATEN VM0404HA 4x4 4K HDMI Matrix Switch supports 4K resolutions of UHD (3840 x 2160) and DCI (4096 x 2160) with refresh rates of 30 Hz (4:4:4) and 60 Hz (4:2:0). It is ideal for applications where the routing of 4K digital signals is required.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

WARNING:   If you follow the instructions here, you will wipe out your VTP and VLAN configurations.  Make sure you have backed up your switch!!! I recently had some issues with a few low-end Cisco routers (RV325) and I opened a case with Cisco TA…
This article is in regards to the Cisco QSFP-4SFP10G-CU1M cables, which are designed to uplink/downlink 40GB ports to 10GB SFP ports. I recently experienced this and found very little configuration documentation on how these are supposed to be confi…
Internet Business Fax to Email Made Easy - With  eFax Corporate (http://www.enterprise.efax.com), you'll receive a dedicated online fax number, which is used the same way as a typical analog fax number. You'll receive secure faxes in your email, f…
NetCrunch network monitor is a highly extensive platform for network monitoring and alert generation. In this video you'll see a live demo of NetCrunch with most notable features explained in a walk-through manner. You'll also get to know the philos…
Suggested Courses

771 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question