Go Premium for a chance to win a PS4. Enter to Win


Crystal Reports "Load report failed" error message after deploying windows application (visual studio .net 2003)

Posted on 2004-08-22
Medium Priority
Last Modified: 2012-06-27
I keep getting the "Load Report Failed" error message when I try to view Crystal Reports on any machine other than the development machine. Anyone know how to fix this?

Some info:
Development was done using VB.NET, VS.NET 2003
I'm using the bundled version of Crystal Reports (About says "Crystal Reports for Visual Studio .NET")
MS Access database

At first, I tried to simply copy the .exe and Access database to the target machine and run it like that. Everything else works fine, but when I tried to view any reports, I got the "Load report failed" message. I then tried creating a Setup Project and included the following merge modules:
Crystal_regwiz2003.msm (also entered the license key)

Tried that but still got the error when I tried to view any reports. I searched the business objects site and ran regsvr32 "C:\program files\common files\Crystal Decisions\1.0\bin\CRQE.dll" like they suggested, but still got the error. I also tried manually copying dbghelp.dll and atl.dll but still no luck.

I finally ended up installing VS.NET on the other machine and copied my entire project over, then re-built on the other computer and still got the error. The only time I was able to successfully view a report was when I created a new report on the other machine (can't view any reports created on the first machine). Does this have anything to do with the path to the Access database? It won't let me set a relative path to the database, so I used the same path on both machines (eg c:\data\db.mdb). Still didn't work though. Why does it only work when I add a new report on the target machine? By the way, I created the reports using the VS.NET Report Expert and selected the database under "Database Files" if that matters.

Any help would be greatly appreciated! Thanks!
Question by:fidke
  • 3
  • 3
  • 2
  • +1
LVL 18

Expert Comment

ID: 11864788
LVL 18

Expert Comment

ID: 11864798
Go ahead and deploy the whole application..

Author Comment

ID: 11865018
I already tried following the instructions listed in crnet_deployment.pdf but it didn't work.  For some reason I can't even view reports when I re-build the project on the target machine (I installed vs.net and copied the entire project folder over to the target machine). The only time I could successfully view a report was when I added a new crystal report to the project on the target machine.
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

LVL 27

Expert Comment

ID: 11873647

Author Comment

ID: 11898851
Thanks for the replies everyone, for some reason changing the reports to not embedded resourse fixed it.
LVL 18

Expert Comment

ID: 11899009
Please explain a bit more.. exactly what you did.  That would help a lot of people... :)

Author Comment

ID: 11919478
I'm not too sure what happened either ......... all I did was change the report build action from "Embedded Resource" to "None", then included all the reports in the setup project and it worked. Thinking real hard now, the problem might have been caused by the reports not having the correct path to the database though. I'm using a local Access database and have no idea how to set a relative path to it in Crystal Reports, so I just used an absolute path. To be totally honest, I'm not sure if changing the build action really fixed it or not. The real fix might be that I just happened to change the path to the correct one in the reports when I changed the build action. Either that, or is it possible that when I had the reports as an Embedded Resource, they didn't get updated during compilation since the only thing I changed was the path to the database? That might be why it worked after I changed the build action to "None"? Sorry if this caused any confusion, I was tired and pissed at the time so I don't remember much else :)

Accepted Solution

ee_ai_construct earned 0 total points
ID: 12006449
Closed, 300 points refunded.
ee_ai_construct (replacement part #xm34)
Community Support Moderator

Featured Post

Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Article by: jpaulino
XML Literals are a great way to handle XML files and the community doesn’t use it as much as it should.  An XML Literal is like a String (http://msdn.microsoft.com/en-us/library/system.string.aspx) Literal, only instead of starting and ending with w…
Article by: Kraeven
Introduction Remote Share is a simple remote sharing tool, enabling you to see, add and remove remote or local shares. The application is written in VB.NET targeting the .NET framework 2.0. The source code and the compiled programs have been in…
Are you ready to place your question in front of subject-matter experts for more timely responses? With the release of Priority Question, Premium Members, Team Accounts and Qualified Experts can now identify the emergent level of their issue, signal…
Please read the paragraph below before following the instructions in the video — there are important caveats in the paragraph that I did not mention in the video. If your PaperPort 12 or PaperPort 14 is failing to start, or crashing, or hanging, …

916 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question