Solved

I can receive but not send email

Posted on 2004-08-22
97
8,274 Views
Last Modified: 2013-12-24
I have:

1.) domain name
2.) static ip
3.) 2 computers
4.) linksys wireless router
5.) dynamic dns service from dyn-dns.org
6.) mercury/pegasus email software

I am trying to figure out how to enable my mail server to send email.  I have tried several clients and have had no luck at sending email.  I can receive fine from other net email addresses.  I'm not sure what all info I need to post here, but I'll put whatever I need to here.  Please help!!!
0
Comment
Question by:willebug
  • 36
  • 33
  • 25
  • +1
97 Comments
 
LVL 33

Expert Comment

by:humeniuk
ID: 11866857
Hi Willebug,

Since it's outgoing mail, your router/firewall shouldn't be involved, nor should the dns service.

First of all, a few questions:

What email client are you using?  I presume Pegasus is one and I'm anticipating Outlook or Outlook Express as others, but if you let us know, we may be better able to help.  If we focus on one and get the configuration right, it will probably answer the questions about configuring one of the other ones.

Also, are you trying to set up Mercury as a stand-alone server or as as a relaying client (via your ISP)?

The following link may be helpful.  It's a Mercury email server setup overview by someone running the same server (see http://www.btofaq.net/articles/servers/mercury.html)  There is a small section on each of 'Outgoing Mail' and 'Email Client Configuration'.
0
 

Author Comment

by:willebug
ID: 11867032
I would like to use outlook and if pegasus/mercury has a webmail interface I would like to use that for away from home use.  I would like to use mercury as a stand-alone server that can authenticate smtp and send email to non-local addresses.  Hopefully I've given enough info to start the wheels turning.  If not let me know.
0
 
LVL 13

Expert Comment

by:kenfcamp
ID: 11867183
Assuming your trying to send mail through your own mail server..

Have you verified that your ISP isn't blocking your smtp port (25) ??

Some providers do. If they are the only way around it is to either ask them "nicely" to enable it (they may or may not and it may add a fee to your account) or see about using a hosted mail account.

IF you're trying to send mail through your-domain.com's host, you may need to set your smtp setting on your client
to reflect your ISP's mail path (usually mail.your-provider.com)
0
 

Author Comment

by:willebug
ID: 11867242
Is there any way to know besides calling them?  I have asked them several times about blocking ports and they always tell me that they don't.  Is there something fundamental that I may be missing?  Is there an entry I need to put into my hosts file or something basic that I should know about all this?  I feel like I'm missing something simple.  I tried this with several email clients now and always come up with the same result... Can receive but can't send.  I am trying to use my computer to do smtp.  
0
 
LVL 33

Expert Comment

by:humeniuk
ID: 11867267
Very good point from ken.  Given that you had the same problem with MailEnable, you should confirm with your ISP that you can send mail via smtp.  If this is the case, you can either receive mail on your server (as you're doing now) and send it via your ISP SMTP (with you@yourdomain.com in the 'from email' and 'reply to' fields) or use an SMTP relay service for outgoing mail (ie. www.authsmtp.com or www.smtp.com).

If it's not the case, there must be some other configuration problem.  Can you give us some info about how you configured Outlook?  Ie. what type of server did you select?  If pop/smtp, what did you list as your incoming and outgoing servers, etc.?

Ken, this is sort of a continuation of another post: http://www.experts-exchange.com/Web/Hosting/Q_21099096.html.  If you read that, it might give you a little more background.  As I've said to willebug, mail servers aren't really my area (I have a little experience with Exchange, that's it), so maybe you can help him more than I can.
0
 
LVL 13

Expert Comment

by:kenfcamp
ID: 11867275
what OS are you running on your server

what email server are you using

Verify that port 25 is up and running
0
 

Author Comment

by:willebug
ID: 11867279
In Outlook I have set in my pop server 192.168.1.101 as my pop server and willebug.com as my smtp server.  Default ports for both of those.  Usernames and passwords all around are correct.  When I send an email I go to mercury and even with mailenable it said it got the message but could'nt send it because it couldnt establish a connection with the other "yahoo" name server.  I have port 25 open.  I went and did a shields up scan and port 25 and 110 are both showing open.  So I think that is ok.  I'm running xp pro.  I have both mercury and mailenable at my disposal but can't get either to cooperate and send an email out.
0
 
LVL 33

Expert Comment

by:humeniuk
ID: 11867290
Since the SMTP server is on your LAN, try using either the IP address (192.168.1.101 or the server name, ie. 'server' if you have DNS running on your LAN).

Sounds like that's not the problem, but it's worth a try.
0
 

Author Comment

by:willebug
ID: 11867293
Would my dns entries at dyn-dns have anything to do with the problems I'm having?  I got the website name through yahoo and got dns service through dyn-dns because I didn't have a static ip when I first got it.  I had cable so I had to find an alternative.  I since switched to dsl and am not sure if I have all the settings in my dns records correct.  Any idea what they should be?  my domain is willebug.com.  I have mx record willebug.com pointing to willebug.com and also mail.willebug.com pointing to willebug.com.  2 CNAMES:  www and ftp .willebug.com pointing to willebug.com and the A NAME of willebug.com pointing to my static ip address.  I am pretty sure that is all correct but I wanted to make all that known to be sure its right.
0
 

Author Comment

by:willebug
ID: 11867295
Unfortunately I tried that as well with same results.  Seems the two are interchangeable from home.  However when I put willebug.com as my pop server it never logs on...  Does that give any insight?
0
 
LVL 33

Expert Comment

by:humeniuk
ID: 11867312
The DNS for your domain only deals with incoming traffic, ie. resolves willebug.com to your IP address.  If your website is available from the internet (it is) and you can get incoming mail to you@willebug.com, then your DNS is set up correctly.
0
 
LVL 13

Expert Comment

by:kenfcamp
ID: 11867322
humeniuk: very informative .. though I'm more geared for Linux and Sendmail heh

willebug: I've noticed the following from your other post.

>  I have the mail server set up for port 81.

This could be part of your problem for 2 reasons

1) services are designed to work on pre-determined ports, to change this requires that you ensure that the port you desire to use isn't assigned to any other service, then configuration changes to ensure things work as they sure (it's usually easier and desired to leave the ports alone unless you have a specific need to service.

2) the port you defined (81) is the port that's used for DNS .. ie you're going to have problems.

.. what steps did you take in changing the port for smtp?



0
 
LVL 33

Expert Comment

by:humeniuk
ID: 11867325
If your computer can't find the POP server at willebug.com but can find it at 192.168.1.101, then it won't be able to find your SMTP server at willebug.com but will be able to find it at 192.168.1.101.  I would set both your POP server and SMTP server to use the IP address.  If you still can't send mail, there is an additional problem, but if we solve that problem we won't know it because your computer still won't be able to find the SMTP server on your LAN.
0
 

Author Comment

by:willebug
ID: 11867326
Just did a test to make sure I can receive again and it is still working.  
0
 
LVL 33

Expert Comment

by:humeniuk
ID: 11867329
As a test, switch your SMTP in Outlook to the IP address and see if you can send me an email (address in my profile).
0
 

Author Comment

by:willebug
ID: 11867335
I set them both to 192.168.1.101 and the test settings completes all tests and I receive the test email from myself.  Also I have made some changes since the post you are referring to ken.  I have smtp on port 25 with 26 as an alt.  I have tried to keep everything as default due to the reason of conflicting services/ports.
0
 

Author Comment

by:willebug
ID: 11867345
Ok I sent an email to you.  Well I tried anyways.
0
 
LVL 33

Expert Comment

by:humeniuk
ID: 11867346
Did you get an error message?
0
 

Author Comment

by:willebug
ID: 11867355
Not from outlook.  It is communicating with mercury fine.  Mercury however gave me an error.  It says Temp Error 249 (temporary mx resolution error) resolving qmail.com.  It says that for every email I've tried to send.
0
 

Author Comment

by:willebug
ID: 11867356
Mailenable would give me simliar messages when sending email.  My client would communicate fine it just wouldnt send the mail due to some communication error with a name server.
0
 
LVL 13

Expert Comment

by:kenfcamp
ID: 11867358

> williebug:  Would my dns entries at dyn-dns have anything to do with the problems I'm having?
> humeniuk:  The DNS for your domain only deals with incoming traffic, ie. resolves willebug.com

Actually I may have to disagree with humeniuk on this one.

I'm assuming the DNS for your computers (router etc) is set to the DNS of your provider.

If this is the case then it's going to resolve to what ever is in the name server assigned for the domain willebug.com

"IF" your dns's MX record isn't setup properly then this could be part of your issue.

as humeniuk suggested  try assigning 192.168.1.101 as both pop3 and smtp and see if that clears things up.
Note that this may cause issues with some domains since reverse IP lookups will not resolve to the domain the mail would be sent from and as such may be dropped (earthlink, frontier, aol, and msn have for some god for saken reason started doing this)

0
 
LVL 33

Expert Comment

by:humeniuk
ID: 11867398
I stand corrected.
0
 

Author Comment

by:willebug
ID: 11867406
So should I put my static ip in for the dns name server in my configuration?
0
 
LVL 13

Expert Comment

by:kenfcamp
ID: 11867446
>  So should I put my static ip in for the dns name server in my configuration?

No, you should put in the ip or domain information you used for the MX record *if * one exists.

But to see if it works simply use your local ip for your pop3 and smtp settings on your client, and send a email to a hotmail or yahoo account (if you don't have one, get one.. they're great for testing your email servers if you think you are having problems)

KC
0
 
LVL 13

Expert Comment

by:kenfcamp
ID: 11867453
humeniuk:

>  I stand corrected.

bah, you've handled yourself quite well from what I've seen ;)
0
 
LVL 33

Expert Comment

by:humeniuk
ID: 11867465
Thank you, Ken  :-)

In the words of Marshall McLuhan (I think), "if you don't like these opinions, I have others".
0
 
LVL 13

Expert Comment

by:kenfcamp
ID: 11867468
> "if you don't like these opinions, I have others".

ROFL .. I just may use that heh
0
 

Author Comment

by:willebug
ID: 11867473
Well I tried sending to human, my yahoo, my earthlink, my hotmail, my work email.  All returned the same result.  It says Temp Error 249 (temporary mx resolution error) resolving *.com. * = every domain I tried sending email to.  
0
 
LVL 13

Expert Comment

by:kenfcamp
ID: 11867486
hmmm

what is used for the smtp setting on your client ?

> temporary mx resolution error

Seems that there may be a issue with the MX record of your DNS listing(s)

If you have access to the configuration, post it so we can take a look at what you used.
0
 

Author Comment

by:willebug
ID: 11867504
Host                         TTL     TYPE      DATA
willebug.com            60       A           ***.**.***.***
mail.willebug.com    43200  MX         10 willebug.com
willebug.com           43200  MX          5 willebug.com

I also have some CNAMES but I'm not sure they will matter.

www & ftp. willebug.com 43200   CNAME willebug.com

I hope this is what you are after.  I'm not sure what you mean by settings in client.  Do you mean outlook or mercury?  And if you do mean mercury I'll have to figure out exactly what you need out of there.  It's not very user friendly.
0
 
LVL 13

Expert Comment

by:kenfcamp
ID: 11867552
try adding :


williebug.com 60 A 65.41.196.189
mail   A   65.41.196.189

Note: it will take a few days untill your DNS provider updates the record, then you have to wait until the rest of the world does
0
 

Author Comment

by:willebug
ID: 11867564
I'm not sure I understand that.  I have willebug.com 60 A ip address.  Are you saying add another mx record?  Or am I missing the point?
0
 
LVL 13

Accepted Solution

by:
kenfcamp earned 250 total points
ID: 11867587
you posted "willebug.com            60       A           ***.**.***.***"  and I wasn't sure if that was exact or if you just didn't post the actual ip (using * instead)

But I still want you to add "mail   A   65.41.196.189" to your record.

this will bind the IP to mail.willebug.com as well as willebug.com
0
 
LVL 33

Assisted Solution

by:humeniuk
humeniuk earned 250 total points
ID: 11867593
Sounds like you're on the right track.  I'm looking forward to getting an email from anything@willebug.com  :-)
0
 
LVL 33

Expert Comment

by:humeniuk
ID: 11870640
Willebug - if you are trying Ken's solution and waiting a few days for DNS propagation, let us know.  Good luck.
0
 

Author Comment

by:willebug
ID: 11870940
Yes I am waiting for that.  Is that going to affect the syntax of my email address?  Should it still be *@willebug.com or *@mail.willebug.com
0
 
LVL 13

Expert Comment

by:kenfcamp
ID: 11871253
@willebug.com

don't forget , your server is going to need to be setup to respond as both willebug.com and mail.willebug.com

I'm not sure how that would be done in windows as I don' t use it for this, but humeniuk should be able to assist you on it
0
 

Author Comment

by:willebug
ID: 11871294
Is there any need to rename my computer for this to work?  I have it named willserverhome right now but I didn't know if that would have anything to do with it.
0
 

Author Comment

by:willebug
ID: 11871322
While I'm waiting I'll try to pick your brains and see if there is anything else I'm missing.  Like I said before I feel that there is something simple/basic I'm missing.  I'm also going to put in a call to my isp today to see if they block port 25.  Anything in specific I need to ask them?
0
 
LVL 13

Expert Comment

by:kenfcamp
ID: 11871371
>  Is there any need to rename my computer for this to work?

Not usually

> Anything in specific I need to ask them?

1) are they blocking port 25
2) if you'll be able to send mail from your own network, or if it will need to be routed through theirs.

(smtp = mail.your-isp.com instead of mail.willebug.com)
0
 
LVL 33

Expert Comment

by:humeniuk
ID: 11871395
That depends on what your terms of service with them is.  A lot of ISP's don't allow web or mail servers.  If they don't allow them (you may want to look into this first, either on their website or your contract with them), they might not be glad to hear from you.  If you want to find out, though, all you can do is ask.  I would tell them that you are CONSIDERING setting up an SMTP server so that you can send mail from a domain that you own and ask them if they are blocking port 25.

As for it being something simple/basic, Ken's DNS solution would qualify :-)
0
 
LVL 33

Expert Comment

by:humeniuk
ID: 11871422
<< if you'll be able to send mail from your own network, or if it will need to be routed through theirs. >>

If that is the case, you can also configure Mercury as an SMTP relay server for outgoing mail.
0
 
LVL 13

Expert Comment

by:kenfcamp
ID: 11871551
> A lot of ISP's don't allow web or mail servers

This is very true.. Actually the way I'd approach them is "you're thinking about setting one up for learning (hobby) and you want to make sure it's ok with them" telling them "you're starting collage soon, and wanted to try to get a head start so you don't feel over whelmed" may be good for brownie points.

But since you've got DSL you "MAY" be ok though port 25 may be a issue as sometimes it's only enabled for commercial accounts.

Note: not all do this

0
 

Author Comment

by:willebug
ID: 11871628
In the case of port 25 not being available would another port be an alternative?  I am on hold with them right now.  My ISP is sprint if you guys know if they block port 25 or not.  I have asked them several times before about block ports and the answer was always no.  Maybe I'm just not asking them the right way I guess.
0
 
LVL 13

Expert Comment

by:kenfcamp
ID: 11871786
>  My ISP is sprint if you guys know if they block port 25 or not

ooooooo Sprint

Well sprint is part of Earthlink, which means you may need to use mail.spint.com (or whatever) for your smtp setting on your client.  you should still ask if you'll be able to sent through your own email server (port 25) but I believe you'll need to use their gateway.
0
 
LVL 33

Expert Comment

by:humeniuk
ID: 11871820
BTW - Ken's clearly more of a diplomat than me, so use his approach rather than mine . . . I would.

Switching to an alternate port might help, depending on how careful and watchful your ISP is.

<< I have asked them several times before about block ports and the answer was always no >>
Then they probably don't.  In my experience, few ISP's do, they prefer to monitor your traffic and send you nasty letters.  For example, if you aren't allowed to run a web server, but you have lots & lots of traffic coming in on Port 80, you can bet you'll hear about it.
0
 
LVL 13

Expert Comment

by:kenfcamp
ID: 11871841
I dont' know about what you're using.. but with Sendmail (under linux anyway) you can configure it to send through another network instead of the local network.

perhaps humeniuk  knows how to do it with what you're using for your email server.. else <google> ;)

It will be easier just to set your client to use whatever needs to be used.
0
Free Trending Threat Insights Every Day

Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

 
LVL 33

Expert Comment

by:humeniuk
ID: 11871884
<< Well sprint is part of Earthlink, which means you may need to use mail.spint.com (or whatever) for your smtp setting on your client.  you should still ask if you'll be able to sent through your own email server (port 25) but I believe you'll need to use their gateway. >>

This is certainly your easiest solution, although you don't get to have the fun of setting up and operating the SMTP part of your server . . . you are having fun, aren't you?  As mentioned abover, remember that you can use your server for incoming mail and Sprint for outgoing mail and still have your domain email address (ie. willebug@willebug.com) listed as the from and reply-to email.

The other alternative, as mentioned is to set up your server for SMTP relay through the Sprint server.
0
 
LVL 33

Expert Comment

by:humeniuk
ID: 11871930
<<  perhaps humeniuk  knows how to do it with what you're using for your email server.. else <google> ;)   >>

Alas, Ken, I don't know how to do it with Mercury, I only know that it can be done . . . thanks to Google.

Mercury is free software, but it costs $ to license the manual (interesting approach), to the tune of about $110/yr.  I've found a few Mercury newsgroups, but they are not as useful as one might hope.  Not many references to Mercury config on E-E either.
0
 

Author Comment

by:willebug
ID: 11871975
Yeah I even tried to use my earthlink smtp as my server and it was giving me the same errors.  So this further leads me to belive that something else isnt right.  I talked to sprint and they assured me NO PORT BLOCKING!!!  So I'm gonna believe them this time.  He even mentioned that lots of people do this so maybe there is something else I/we aren't thinking of.  You guys have been a great help by the way.  Any suggestions on an alternative email client???  Which one would be the easiest to use between mail enable and mercury.  
0
 
LVL 13

Expert Comment

by:kenfcamp
ID: 11872034
> Any suggestions on an alternative email client???

You have IE already (it comes with windows)
If you can get it to work, then either stick with that or try Thunderbird  http://www.mozilla.org

If "mercury" is your email server (I don't know what you're using)
other than sendmail, and the typical "MS" solutions, I don't know
0
 
LVL 33

Expert Comment

by:humeniuk
ID: 11872221
Right, I would stick with Outlook for now.  If you can't send mail using your ISP's SMTP server then your problems aren't with your server.  I'm sure you can get proper email client config from their website or support.  If you choose to dump Outlook, I also like Thunderbird.
0
 

Author Comment

by:willebug
ID: 11872458
Well I was wondering between mail enable, mercury, or other alternative for server software.  I am still considering that I have something wrong with my router maybe.  Is that even a possibility?  I cannot connect to mail.willebug.com or willebug.com or my ip address to use as a pop server from work using outlook.  Does that suggest anything?
0
 
LVL 33

Expert Comment

by:humeniuk
ID: 11872740
I think that suggests that Ken's DNS solution may be the right one.
0
 

Author Comment

by:willebug
ID: 11875714
I read some documentation about adding a PTR record?  Any ideas as to whether this might help out or not?  I also read something about being on a spam list.  
0
 
LVL 33

Expert Comment

by:humeniuk
ID: 11875897
I don't think it's you're router (the outgoing problem), because you are getting past your router when you try to send, even if the send isn't successful.  Your router could be blocking you POP access to the mail server from your office, if you don't have port 110 forwarding to your server's internal IP (same as port 80 and 25).

The DNS solution that Ken suggested seems like a good bet to solve both of the problems, but unfortunately you're going to have to way (probably a couple of days), to see.
0
 
LVL 33

Expert Comment

by:humeniuk
ID: 11875908
Just saw this above:

<< don't forget , your server is going to need to be setup to respond as both willebug.com and mail.willebug.com

I'm not sure how that would be done in windows as I don' t use it for this, but humeniuk should be able to assist you on it >>

Do you have that set up now or do you need some directions?
0
 

Author Comment

by:willebug
ID: 11875932
Yeah I am definately a beginner at this and please treat me as if I know nothing.  So help please!!!
0
 
LVL 33

Expert Comment

by:humeniuk
ID: 11876045
Hmm . . . could be interesting with WinXP.  I don't have IIS on XP in front of me, so I'm not entirely certain.  I'm used to IIS 6 with Win2k3 and IIS 5 with Win2k.  I'm going to do a little research and get back to you.
0
 

Author Comment

by:willebug
ID: 11876227
Ok.  Thanks.
0
 

Author Comment

by:willebug
ID: 11877142
Am I supposed to be running my virtual smtp sever in IIS for this???
0
 
LVL 33

Expert Comment

by:humeniuk
ID: 11882545
No, virtual SMTP is something else.  You don't want to use that with a third-party mail server.

Regarding this:
<< don't forget , your server is going to need to be setup to respond as both willebug.com and mail.willebug.com
I'm not sure how that would be done in windows as I don' t use it for this, but humeniuk should be able to assist you on it >>
This may not be applicable to WinXP/IIS5.  This sort of thing is generally done in a Win2k3/IIS6 environment to deal with multiple websites, virtual servers, etc.  Given that WinXP/IIS only allows one website, you don't have the ability to create host headers, etc.  Likewise, you don't have DNS controls as you do in the server example.

Having said that, you need to make sure that your router/firewall is forwarding the correct ports (25,110,80) to the server's local IP - as you have done.  Because there is one default website there, I suspect that there is no need for further configuration to make your server respond to port 80 traffic, because there is one web server platform (IIS) and one website (the default site).  This would likely be true of your mail server as well.  The DNS suggestions that Ken made will route mail.willebug.com traffic to your public IP, your router will forward traffic on the mail ports to your server's local IP where your mail server, if properly configured, will be listening for and receiving traffic on that port.

Disclaimer: I'm not 100% sure about this as I haven't used WinXP for this purpose, so don't take this as a finite answer.  If anyone has anything to add (either to confirm or disagree with this), please speak up.
0
 
LVL 13

Expert Comment

by:kenfcamp
ID: 11882781
>  Am I supposed to be running my virtual smtp sever in IIS for this???

?? SMTP and IIS are two different things.. If you're refering to "web based email (aka webmail)"
you'll first need to get your smtp issues resolved.

Virtual SMTP allows 1 smtp server to act as mutiple servers (xyz.com, 123.net, williebug.com, etc) at the same time.

> You don't want to use that with a third-party mail server.

100% true..

If this is your desired path, then I'd recommend either switching to a MS solution (exchange etc) or Sendmail (something that's better documented (ok so Sendmail docs leave alot to be desired), mature, and stable ( hmm, ok so maybe MS might be left behind there too. ;) )
0
 
LVL 33

Expert Comment

by:humeniuk
ID: 11882879
My original recommendation (in the last post) of MailEnable was largely due to the fact that there is good documentation & support available (and free, unlike Exchange).  Willebug switched to Mercury (correct me if I'm wrong) because he was having this same problem with MailEnable.  That fact (same problem common to both mail server platforms) makes me hopeful that the DNS solution will be the proper resolution rather than a server config solution (esp. since I don't know anything about Mercury and can't spend $110 on the manual).
0
 
LVL 13

Expert Comment

by:kenfcamp
ID: 11883138
Never tried MailEnable so I can't say..

"IF" the DNS doesn't fix the problem, then my suggestion would be for him to find someone willing to spend "alot" of time, and start from scratch. Or better yet maybe get someone to walk him through (start to finish)

On a different note

DNS seems to be complete on mail.williebug.com

*assuming the DNS he's using for his home connection updated the information

willie: try to ping mail.williebug.com .. "IF" you get a reply, try to send mail using it for you sntp setting
0
 
LVL 13

Expert Comment

by:kenfcamp
ID: 11883157
the only other issue he may have will be with reverse ip lookups.

For this he (willie) will need his ISP to make the necessary associations to willie.com and mail.willie.com
0
 

Author Comment

by:willebug
ID: 11884299
I pinged mail.willebug.com and didn't get a request.  Of course I'm doing it from work (my only way to check it from outside the network except from my g/f's house who is out of town for the week) and there is the possibility they block it since it's a government computer at work.  Same for willebug.com.  My dns settings are telling me that the next check will be saturday so I guess it will be at least until then before everything settles there correct?  As for reverse ip lookups...  What do I need to tell them.  I realize I've basically had you guys set this up for me.  And I greatly appreciate the help.  Had no idea it was going to be such a project.  Thanks again for all the help guys.
0
 
LVL 33

Expert Comment

by:humeniuk
ID: 11884320
I pinged both willebug.com and mail.willebug.com (resolved to proper IP address).

Also, I may have discovered a cause for some of these problems.  http://mail.willebug.com:8080 goes to the ArGoSoft Mail Server welcome/log-in screen. So, it appears you still have the ArGoSoft mail server installed and running, which can interfere with the Mercury mail server in several ways, the most obvious being that both are listening for port 25/110 traffic on the server.

You should either disable (or preferably uninstall) ArGoSoft, MailEnable and any other mail server software you have running on your server except for Mercury.
0
 
LVL 33

Expert Comment

by:humeniuk
ID: 11884372
You're right, it could be blocked or you may still be waiting for DNS propagation at that location.  You can try going to www.network-tools.com and you should be able to ping from there.  I did a trace as well and it routes to your proper IP address.

<< the only other issue he may have will be with reverse ip lookups.  For this he (willie) will need his ISP to make the necessary associations to willie.com and mail.willie.com >>
If they will do this for him.

But first, get rid of the other mail server software and test it out.  If you want to provide us with a willebug.com email address (here or by email), we could send you a test.
0
 

Author Comment

by:willebug
ID: 11884433
Turns out our work domain doesn't allow ping option.  I was unable to ping any domain.  So I guess I can't really do that from here.
0
 
LVL 33

Expert Comment

by:humeniuk
ID: 11884615
If you use www.network-tools.com, you ping from their server, not your location.  The results are given to you via the web.
0
 

Author Comment

by:willebug
ID: 11884674
Ok the ping worked fine.  I will set up an email account for you both.  Human@willebug.com password human and ken@willebug.com password ken.
0
 
LVL 13

Expert Comment

by:kenfcamp
ID: 11884784
<< the only other issue he may have will be with reverse ip lookups.  For this he (willie) will need his ISP to make the necessary associations to willie.com and mail.willie.com >>

> If they will do this for him.

Sheesh I thought I was the pestemist ;)

You are right though.. w/ earthlink it is a major "IF" they may not even be willing to hand over deligation to his existing DNS provider (if they'll even accept the request on that end) at which point he'll be pretty much looking at roughing it
0
 
LVL 33

Expert Comment

by:humeniuk
ID: 11885025
My shrink says I have to start looking at the bright side (yes, I see a shrink, but don't worry, it's just one of those silly 'court-ordered' things).

Ahem.

On that note . . .

I have configured Outlook to use the account you've set up.  Using mail.willebug.com as the mail server (also works with willebug.com or your public IP address), I am able to find both the incoming (POP) and outgoing (SMTP) servers.  However, I am not able to log on to either of them - error message: Unable to logon to the incoming mail server (POP3).  Please verify the settings in the User Name, Password and E-mail fields".  I tried both human and human@willebug.com as usernames.

BTW - the message is NOT timing out, the server is rejecting the connection.

I presume you haven't configured the mail server to use a secure (SSL connection), have you?

Also, have you removed the other mail server programs yet?  Or do you have to do that later at home?
0
 

Author Comment

by:willebug
ID: 11885203
Yeah I'm still at work.  I'll have to take care of all that stuff at home.  So you want me to go back to which program???  Mercury, mail enable???  Just let me know and I'll make the change.
0
 
LVL 33

Expert Comment

by:humeniuk
ID: 11885284
I don't think it matters which one, it's more a matter of making sure there aren't two or more mail server platforms running on the machine at any given time.  As of right now, I can't log in with the account info you gave me, but if you created the test account on Mercury and ArGoSoft is answering the request, it makes sense that my username/password would be rejected.

So, select one mail server platform, uninstall the other(s), and make sure whichever one remains has an account with the username/password you set up.
0
 

Author Comment

by:willebug
ID: 11886799
I created the addresses for human and ken with the above passwords.  I also made you both sysadmins.  Do your worst :-)
0
 
LVL 13

Expert Comment

by:kenfcamp
ID: 11886929
willebug erm,

You do realize that anybody who stumbles accross this posting now not only has the login information for either/both accounts, but also have admin rights ..

>  Do your worst

You could very well wind up with a paper weight if you don't kill the privelages,
or atleast change the passwords/logins

Just a friendly suggestion

0
 
LVL 33

Expert Comment

by:humeniuk
ID: 11886938
I would suggest you change the passwords right away and email us the new passwords.  You just created two admin accounts for a mail server exposed to the internet and posted the usernames/passwords in a public forum.  This is a significant security problem.
0
 
LVL 33

Expert Comment

by:humeniuk
ID: 11886945
(ie. someone else might do their worst)
0
 

Author Comment

by:willebug
ID: 11886960
Ok i changed the permission levels.  You are both just users.  Smack me on the hand why dontcha ;)  I see the error of my ways.
0
 
LVL 33

Expert Comment

by:humeniuk
ID: 11886979
Which server platform did you elect to keep?
0
 

Author Comment

by:willebug
ID: 11886993
I am using mail enable.  And I believe I got rid of everything with the other two after several restarts.  Pesky programs didn't want to go away.
0
 
LVL 13

Expert Comment

by:kenfcamp
ID: 11887022
> This is a significant security problem.

ya think??  ;)


Willebug,

Seriously, you didn't just make 1 serious mistake you made 3-4 of them in one foul swoop

I strongly suggest before you get too into playing w/ the server you review (buy) some network/security manuals

and yes there are "Dummy Guides" on the subject.
0
 
LVL 33

Expert Comment

by:humeniuk
ID: 11887117
I have connected to the POP server and received the automated 'your new email account has been activated' message.

However, I can't send mail ("unable to connect to the outgoing mail server").  I'm going to try some variations in the client (Outlook) config and see if that solves it.
0
 
LVL 33

Expert Comment

by:humeniuk
ID: 11887494
No luck.  I still can't connect to the SMTP.  Also, test emails sent from an outside email address to human@willebug.com never show up in my inbox.  Willebug, you may want to configure your Outlook to access the human@willebug.com account on the server via the network (rather than the internet) - use the server's local IP for the incoming and outgoing server names.  See if the test emails I sent made it to the server (I doubt it, but it's worth a look).

Ken, do you think there is a DNS explanation for this (ie. reverse IP lookups)?  Should Willebug speak to his ISP about this as you suggested above?

It's either that or a server config problem.
0
 
LVL 13

Expert Comment

by:kenfcamp
ID: 11887570
> do you think there is a DNS explanation

Are you getting any errors, server messages?

at this point I'd have to say configuration issue
0
 
LVL 33

Expert Comment

by:humeniuk
ID: 11887595
No errors or server messages.  No return message "your email couldn't be delivered, etc."

If it's config, at least we have more documentation with MailEnable than with Mercury.  I'll check back later, willebug, when I've had a chance to look at some ME config info.
0
 

Author Comment

by:willebug
ID: 11887605
Ok thanks.  I actually looked at a pdf that came with it.  It didn't mention anything about it being able to run on xp at all.  Could that be the underlying problem?  That it uses some server components/services that xp pro doesn't have?
0
 
LVL 13

Expert Comment

by:kenfcamp
ID: 11887690
O
K

I sent 1 message to 2 addresses

ken@willebug.com
and a address on my network

willebug.com was delivered OK (which is good since it's local)

However the "CC" didn't get delivered (nor did it error out) which leads me to believe your issue is configuration related.

NOTE: the field "server needs to be authenticated" needs to be checked.. but not SSL
0
 
LVL 13

Expert Comment

by:kenfcamp
ID: 11887746
one thing I did notice from the header of the message to the willebug.com account is

Received: from ([127.0.0.1]) <---- This should have been set to the IP I sent from

I'd suggest you review your configuration

0
 

Author Comment

by:willebug
ID: 11892641
I put in a call to Sprint/Earthlink about the PTR record.  They said that they couldn't do it with the type of service I have now.  So I am going to just give up on this for now.  I was able to get outbound smtp service from my dns provider for a small charge and that will suffice for now.  I was kinda hoping I would be able to do this myself but it just turned out to be too big of a task to make it happen.  I want to thank both of you for you help.
0
 
LVL 33

Expert Comment

by:humeniuk
ID: 11893996
I'm sorry to hear it isn't going to work out.
0
 
LVL 33

Expert Comment

by:humeniuk
ID: 11895903
Good choice.
0
 

Expert Comment

by:ammadeyy
ID: 14321428
I am using Mercury/32. I could receive the mails through the server and i could send the mail to internal machines. But i could not sent the mail to outside. from mercury SMTP Client (end-to-end version) getting the following error message

19:39:37: processing job MO000160
Temporary error 249 (temporary MX resolution error) resolving 'msa.hinet.net'.
19:40:57: processing job MO000002
Temporary error 249 (temporary MX resolution error) resolving 'comcast.net'.
19:46:01: processing job MO00015F
Temporary error 249 (temporary MX resolution error) resolving 'msn.com'.
19:46:01: processing job MO00053A
Temporary error 249 (temporary MX resolution error) resolving 'comcast.net'.
19:48:25: processing job MO00053D
Temporary error 249 (temporary MX resolution error) resolving 'msn.com'.
19:48:25: processing job MO00053E
Temporary error 249 (temporary MX resolution error) resolving 'comcast.net'.

Can you help me to fix this problem. Also i am using ISA2004 server in this server.

0

Featured Post

How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

Join & Write a Comment

If your business is like most, chances are you still need to maintain a fax infrastructure for your staff. It’s hard to believe that a communication technology that was thriving in the mid-80s could still be an essential part of your team’s modern I…
Join Greg Farro and Ethan Banks from Packet Pushers (http://packetpushers.net/podcast/podcasts/pq-show-93-smart-network-monitoring-paessler-sponsored/) and Greg Ross from Paessler (https://www.paessler.com/prtg) for a discussion about smart network …
Viewers will learn how to connect to a wireless network using the network security key. They will also learn how to access the IP address and DNS server for connections that must be done manually. After setting up a router, find the network security…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

758 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

16 Experts available now in Live!

Get 1:1 Help Now