• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1876
  • Last Modified:

Currency Symbol displaying $ instead of locale default in ASP.NET environment (Both server and client on English(UK)


The web front (ASP.NET) Reporting application has been developed using Visual Studio .NET (Microsoft Visual C# .NET) with crystal reports being displayed via the crystal report viewer (CrystalDecisions.Web – Version 9.2.3300.0).  The database is SQL Server 2000.

We design the reports using Crystal Reports Developer 9.2.3.970.

We have sites in the United Kingdom and wish to display currency values with the Pound symbol as opposed to the Dollar sign.  All relevant fields have been formatted using the System Default Currency Format.

The Regional settings and Browser “Language” settings have been changed to “United Kingdom” on both the web server machine and clients, but the $ symbol is still being displayed for all currency values on all crystal reports.





0
pgordon2
Asked:
pgordon2
  • 4
  • 2
  • 2
  • +1
1 Solution
 
GJParkerCommented:
Do you have CR installed on the UK web server ? if so have you tried changing the currency settings in CR Options ? go to the Fields tab and change the currency settings.

Gary
0
 
frodomanCommented:
If you always want the Pound symbol, you can format the field, select custom format, currency options, and enter the symbol that you wished to be displayed.

frodoman
0
 
mlmccCommented:
According to this link if you set the Windows defaults correctly it should xhange automatically.
http://support.businessobjects.com/library/kbase/articles/c2011510.asp

Here is a solution from a previous version.  It may still be applicable
http://support.businessobjects.com/library/kbase/articles/c2001783.asp

mlmcc
0
Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
pgordon2Author Commented:
Thanks for the comments.
GJParker, we have tried the issue on a local machine, and the currency symbol works correctly through the designer but not through the viewer on the same machine (We are using the ASP.NET Viewer).
frodoman, we want the currency symbol to change depending on the locale the report is used in, otherwise we would fix it.
mlmcc, thanks for the comments. This SHOULD work .. sounds like a bug somewhere. On the second link I would assume that problem is fixed since version 6 and the workaround they suggest is too much work and would make the reports harder to maintain.

thanks,
paul.
0
 
GJParkerCommented:
sorry I can't be of more help.

Gary
0
 
mlmccCommented:
WHere is the server the machines are running against?  Is it the same server or do the UK sites have a server located in the UK?

mlmcc
0
 
pgordon2Author Commented:
The server is situated in the UK and is set to use the UK Locale in Windows. The clients are accessing the reports via the Web using the ASP.NET viewer and are also in the UK.

Paul.
0
 
mlmccCommented:
Have you tried setting the language to something, reboot, then set it back to UK and reboot?

mlmcc
0
 
mlmccCommented:
I just tried to reset my regional settings.  I set the regional setting to English(UK) but the other settings remained the same.  Have you gone in and set the currency settings to use the appropriate symbols?

mlmcc
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Cloud Class® Course: MCSA MCSE Windows Server 2012

This course teaches how to install and configure Windows Server 2012 R2.  It is the first step on your path to becoming a Microsoft Certified Solutions Expert (MCSE).

  • 4
  • 2
  • 2
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now