• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 247
  • Last Modified:

DNS Server Pblm

Hi all
I am running a DNS server on my Solaris 2.5.1 system. It was working fine for a long time. recently i have changed the ip address of network interface ( eth0 ) to a private Ip and mapped to the public ip in CISCO PIX. all services are running fine except the DNS. whenever i tried to nslookup any server, my DNS server is not able to resolv the DNS , so it is sending it to the next DNS server and it is resolving. Earlier my servers ip adress was public IP. now it is private IP.

i am getting the error is like this.

#nslookup www.yahoo.com

*** Can't find server name for address xxx.xxx.xxx.xxx(public IP): No response from server
Server:  abc.com
Address:  yyy.yyy.yyyy.yyy ( my next level domain )

Non-authoritative answer:
Name:    www.yahoo.akadns.net
Addresses:  216.109.118.72, 216.109.117.107, 216.109.117.204, 216.109.118.68
          216.109.118.75, 216.109.117.106, 216.109.118.70, 216.109.117.207
Aliases:  www.yahoo.com


if any idea////?


0
bt74
Asked:
bt74
1 Solution
 
tfewsterCommented:
Check /etc/resolv.conf; It probably has the old IP address of your server as the first nameserver (And when nslookup fails to contact that address, it goes onto the next nameserver, the yahoo one)
0
 
jlevieCommented:
Have you included:

query-source address * port 53;

in the options {} of your named.conf? If there's a firewall between the DNS server and the Internet you'll usuall need that enabled for queries to work.
0
 
PsiCopCommented:
jlevie,

If he's still running Solaris v2.5.1, he probably has a BIND version 4.x. Your v8/9 notation is just gonna confuse him.
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
bt74Author Commented:
yes..mr. jlevie..

there is firewall between the DNS server and the internet./ in my solaris box, i don't know where i have to mention the

query-source address * port 53;

in my solaris sever.. there is only /etc/named.boot. not named.conf..

and the sysntax also little bit differen

format of my /etc/named.boot file is..
directory /var/named
cache           .                               aaa.ca
primary         xxx.xxxx.xxx                      aaa.hosts
primary         (public ip).in-addr.arpa        aaa.rev
primary         0.0.127.in-addr.arpa            aaa.local

i have mentioned only my public ip in all DNS related configurations.


my private ip is only in the interface..

0
 
palimaCommented:
i think another work must be done on the MAC address of the eth0 on the PIX side
0
 
jlevieCommented:
Oops, I missed a notif...

"query-source address * port 53;" isn't needed for the version of Bind you are running, so ignore that.

What does your /etc/resolv.conf contain?

When you start named is it logging any error messages (in /var/adm/messages I think)?
0
 
PsiCopCommented:
Might go to /var/log/syslog - altho that can be affected by the named.boot logging options. Mine does somewhere else completely.
0
 
PsiCopCommented:
Sure, no problem
0
 
CetusMODCommented:
PAQed - no points refunded (of 30)

CetusMOD
Community Support Moderator
0

Featured Post

Upgrade your Question Security!

Add Premium security features to your question to ensure its privacy or anonymity. Learn more about your ability to control Question Security today.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now