• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 279
  • Last Modified:

connecting two lans

   i have LAN1 with and LAN2 with . A linux setup has 2 NICs with addresses and . i type "ip route" and the shell shows
" dev eth1  proto kernel  scope link  src dev eth0  proto kernel  scope link  src
default via dev eth0"

No from what i understood
if i insert "ip route append via" and "ip route append via" i will  have a simple gateway. But the pings from the LAN1 to LAN2 does not work any ideas?
  • 4
  • 3
  • 2
  • +1
1 Solution
Hi ttsenis,
All you need to do is configure the network cards with their correct address, set a single default gateway if required and then turn on ip forwarding.
The command to turn on ip forwarding is "sysctl -w net.ipv4.ip_forward=1"
If you want to make forwarding permanent you can edit the entry in /etc/sysctl.conf
That sysctl command does the same as
echo 1 > /proc/sys/net/ipv4/ip_forward

Also things to check:
Can you ping all the machines from the junctionpoint machine?
Is your iptables policies for INPUT, FORWARD and OUTPUT set to ACCEPT and the firewall settings are clean?

Just checking that you are aware that you have to set those (not exactly those, but corrected versions of those, and different in different lans) routing lines to the client machines in the different lans to get it working.
Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

ttsenisAuthor Commented:
Well when i decided to bridge those 2 NICs the ip route returned : dev eth1 ... src dev eth0 ... src
With these 2 route roules the linux worked perfectly but without the ability to transfer packets between these to LANs.
Then I decided to make these 2 NICs as a bridge for my 2 LANs so i decide to make the gateaway technic that i described it previously. grblades proposed to make ip forwarding. I did set the ipv4.ip_forward flag but now i get back at ping command the message unreachable network. I do not have any kind of firewall. ttimonen please instruct how to see and change the iptables policy. Also any ideas to see if the rules inside the iptables really works. Eventually if i want to route packet from a certain NIC to other what argument do i use for the ip command syntax because  man ip  does not have a relative topic?
to clean up iptables (that is, disable the firewall),
#Deletes all rules from every built-in chain in default table
iptables --flush
#Deletes all rules from every built-in chain in nat(Network Address Translation) table
iptables -t nat --flush
#Deletes all usermade chains
iptables --delete-chain
#Changes default policies for the filter to accept all traffic.
iptables --policy OUTPUT ACCEPT
iptables --policy INPUT ACCEPT
iptables --policy FORWARD ACCEPT

That should get rid of a possible firewall problem.

The output of "ip route" looks fine for the gateway.
How the clients are configured?
Assuming that the client in network 17 has one NIC named as eth0, there should be something like via dev eth0
in the output of "ip route" besides the normal local routing .
(the above can be archived with command "ip route add via").

And symmetrically, in network 16 there should be via dev eth0
Now each machine should know where to send those packages when they are not located in local network.

Alternative way to configure this is to set clients to blindly use default gateway and configure the default gw to work smartly with all packages.

"(the above can be archived with command "ip route add via")."......
this is not possible and will return an error if you try it .....

once you have enabled the routing and cleaned/disabled the firewall thats all that is necessary in the gateway - the routes are learnt automatically since they are part of the nics configs.

2 other things to check -
there are no other firewalls - esp. on the pc you are trying to ping....
the gateways of LAN 1 and LAN 2 pcs are set properly.....
LAN1 pcs should have the gateway set as
for LAN2 pcs it should be

remember - no route modifcations are necessary - the networks are part of the nics .... and routes will be learnt -- boot the machine clean and do 'ip route' you will notice the routes.....

ttsenisAuthor Commented:
       i think that the problem is at peripheral w98 machines. I suppose i did not put the proper gateways. I will try it . By the way gn0 reffers to dynamic routing, does my SUSE 7.1 has such a router (is it consider built in.)
i dont know if u can call it 'dynamic' routing .... another term like 'link' or 'connected' or better yet 'implied' routing might be more appropriate....


It doesn't cause any errors on my config (well, 192.168.1 and 192.168.2 network with those routing settings).

The thing you are suggesting implies that the machine that connects those two networks do work as a default gateway; that is not always the case, possible or wanted. (that was my option two in my previous post, though).

aah.... upon carefully re-reading what u said i now see what u were saying.... but since the clients were w98, ur use of 'ip route' threw me off-track.....
i thought that u were doing "ip route add via" on the gw .... which was directly connected to the '' network ... this would result in "RTNETLINK answers: File exists" ....

u only said he had the 2 networks - if however u cannot change the gateways on any of the machines u could also add the routes (as ttimonen said)....
on the LAN1 pcs....
route add mask

on the LAN2 pcs....
route add mask

(u might need to put this in a '.bat' file and place a shortcut to the '.bat' file in the startup group... or somewhere where it would be run when the machine boots up ..... w98 hasn't the option to make routes permanent (as nt/2k or later))

u can leave the gateway settings to where ever u need default traffic to go....

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

The 14th Annual Expert Award Winners

The results are in! Meet the top members of our 2017 Expert Awards. Congratulations to all who qualified!

  • 4
  • 3
  • 2
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now