Solved

Dedicated Server Host not found

Posted on 2004-08-23
24
443 Views
Last Modified: 2010-03-18
why always that I try to use wget it says "failed: Host not found."
this is the output of what I see

[(11:31 AM)][(root@dedicated)] [(~)] $ wget ftp://ftp.ensim.com/download/pro/linux/4.0.1/ensim37-upgrader.sh
--11:22:59--  ftp://ftp.ensim.com/download/pro/linux/4.0.1/ensim37-upgrader.sh
           => `ensim37-upgrader.sh'
Resolving ftp.ensim.com... failed: Host not found.
0
Comment
Question by:Xtry
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 12
  • 8
  • 4
24 Comments
 
LVL 36

Expert Comment

by:grblades
ID: 11871435
Hi Xtry,
Have you checked to make sure resolving is working?
What do you get if you type "host ftp.ensim.com" ?
0
 

Author Comment

by:Xtry
ID: 11871597
[(11:43 AM)][(root@dedicated)] [(/var/named)] $ host ftp.ensim.com
;; connection timed out; no servers could be reached
0
 
LVL 14

Expert Comment

by:pablouruguay
ID: 11871670
add in the /etc/resolv.conf  

search yourisp.net
nameserver ISPNSIP example. 206.99.44.254
0
Secure Your WordPress Site: 5 Essential Approaches

WordPress is the web's most popular CMS, but its dominance also makes it a target for attackers. Our eBook will show you how to:

Prevent costly exploits of core and plugin vulnerabilities
Repel automated attacks
Lock down your dashboard, secure your code, and protect your users

 
LVL 36

Assisted Solution

by:grblades
grblades earned 200 total points
ID: 11871696
In /etc/resolv.conf there should be a line :-
nameserver w.x.y.z

w.x.y.z is the IP address of your ISP's dns server.
It sounds like this has not been configured on your system.
0
 

Author Comment

by:Xtry
ID: 11871702
I have that already
0
 

Author Comment

by:Xtry
ID: 11871719
I have this

nameserver 127.0.0.1
nameserver MY-1-IP
nameserver MY-2-IP
search localdomain
0
 
LVL 14

Expert Comment

by:pablouruguay
ID: 11871724
please check if you can ping yahoo.com
0
 
LVL 14

Expert Comment

by:pablouruguay
ID: 11871741
no is bad you need to resolv in the ISP i think. call your ISP and tell us bring you the ip number of the DNS server. modify the file and restart named
0
 

Author Comment

by:Xtry
ID: 11871748
[(11:58 AM)][(root@Alpha)] [(~)] $ ping yahoo.com
ping: unknown host yahoo.com
0
 
LVL 36

Expert Comment

by:grblades
ID: 11871776
> nameserver 127.0.0.1
Unless you are running a DNS on your box this wont work.

> nameserver MY-1-IP
> nameserver MY-2-IP
These are not valid. You have to specify IP addresses.
0
 

Author Comment

by:Xtry
ID: 11871780
well I think its something else, that file has been like that since I got it. I have never edited that file.
I think its something else, I have Fedora with Ensim on that dedicated server. Yesterday I was
trying to get ipv6 and make some AAAA records in a site and today this happens I really dont
know whats going on.
0
 
LVL 14

Expert Comment

by:pablouruguay
ID: 11871784
and  ping 66.94.231.99 ???
0
 

Author Comment

by:Xtry
ID: 11871806
grblades, im the 'nameserver' I do have my Ips in there.
0
 

Author Comment

by:Xtry
ID: 11871813
[(12:03 PM)][(root@dedicated)] [(~)] $ ping 66.94.231.99
PING 66.94.231.99 (66.94.231.99) 56(84) bytes of data.
64 bytes from 66.94.231.99: icmp_seq=0 ttl=56 time=96.7 ms
64 bytes from 66.94.231.99: icmp_seq=1 ttl=55 time=97.0 ms
64 bytes from 66.94.231.99: icmp_seq=2 ttl=55 time=96.5 ms
64 bytes from 66.94.231.99: icmp_seq=3 ttl=55 time=96.6 ms

[5]+  Stopped                 ping 66.94.231.99
0
 
LVL 14

Expert Comment

by:pablouruguay
ID: 11871827
yes xtry i give you the named for ipv6. but. the problem in here i think is you turn on bind. and the resolution try to make in your box and no in your ISP.

we need to change the resolv.conf to do that like grblade says   you need a specific IP ADDRESS
0
 
LVL 14

Expert Comment

by:pablouruguay
ID: 11871837
ok. please remove the ipv6 reverse resolution. if you create. because this is the problem you have an error in the reverse resolution. :(
0
 
LVL 36

Expert Comment

by:grblades
ID: 11871849
OK it sounds like your nameserver is not working in that case.
Can you try restarting it by typing "/etc/init.d/named restart" and then see if it works.
0
 

Author Comment

by:Xtry
ID: 11871898
they are specified, in my file '/etc/resolv.conf' this is what I have

nameserver 127.0.0.1
nameserver 207.218.245.135
nameserver 207.218.247.135
search localdomain
0
 

Author Comment

by:Xtry
ID: 11871913
[(12:05 PM)][(root@dedicated)] [(~)] $ /etc/init.d/named restart
Stopping named:                                            [FAILED]
Starting named:                                            [  OK  
0
 

Author Comment

by:Xtry
ID: 11871935
ok I just removed everything what I did yesterday about IPv6 =(
0
 
LVL 14

Expert Comment

by:pablouruguay
ID: 11872244
and now? work ping yahoo.com ??
0
 

Author Comment

by:Xtry
ID: 11872263
Nothing I restarted named then the network then the server and nothing still the same.
0
 
LVL 14

Accepted Solution

by:
pablouruguay earned 300 total points
ID: 11872346
change in the resolv.conf the ip numbers

nameserver 216.88.77.7



and remove the others. this ip number is the NS server of you connection. truy restart named after that and comment.
0
 

Author Comment

by:Xtry
ID: 11872900
thanks a lot for the quick response.
0

Featured Post

Are You Using the Best Web Development Editor?

The worlds of web hosting and web development are constantly evolving. Every year we see design trends change, coding standards adapt and new frameworks/CMS created. With such a quick pace of change it’s easy to get lost trying to keep up.

See if your editor made the list.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I have seen several blogs and forum entries elsewhere state that because NTFS volumes do not support linux ownership or permissions, they cannot be used for anonymous ftp upload through the vsftpd program.   IT can be done and here's how to get i…
Note: for this to work properly you need to use a Cross-Over network cable. 1. Connect both servers S1 and S2 on the second network slots respectively. Note that you can use the 1st slots but usually these would be occupied by the Service Provide…
If you're a developer or IT admin, you’re probably tasked with managing multiple websites, servers, applications, and levels of security on a daily basis. While this can be extremely time consuming, it can also be frustrating when systems aren't wor…
In this video, viewers will be given step by step instructions on adjusting mouse, pointer and cursor visibility in Microsoft Windows 10. The video seeks to educate those who are struggling with the new Windows 10 Graphical User Interface. Change Cu…

636 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question