Solved

Screen Flashes Black When Xp Desktop Loads and during high periods of I/O activity.

Posted on 2004-08-23
14
1,616 Views
Last Modified: 2008-01-09
Hi, Im wondering if anyone out there is experiencing the same problems as me on this one. Here are my system specs:

ECS L7VTA PCB v1.1 (using bios 1.7j)
AMD Athlon XP 2500+ (Barton)
512Mb DDR 333
Nvidia GeForce 440Mx (with latest drivers)
Via hyperion 4 in 1 chipset (with latest v4.53 drivers)
DirectX 9.0c
Xp Sp1


Overview of the problem:
When XP reaches the desktop, the screen flashes, as if changing to an incompatible resolution, then returns back to the normal desktop, the same happens when I right click on the Nvidia settings icon in the task tray or when the system is under heavy I/O.

In addition to this i think that this is having a 'knock on' effect on my other drivers, eg errors keep cropping up in Cmuda.sys (CMedia AC97 audio using newst drivers also), and asyncmac.sys (one of the windows RAS drivers), and Ndis.sys (network driver).

At present I am at a loss, any help will me much appreciated.

Supercomputeruk
0
Comment
Question by:Supercomputeruk
14 Comments
 
LVL 4

Assisted Solution

by:lexicon_dominus
lexicon_dominus earned 280 total points
Comment Utility
Hello Supercomputeruk;
Did you try uninstalling and removing the vga drivers, restarting the windows and re-installing them.
0
 
LVL 2

Author Comment

by:Supercomputeruk
Comment Utility
I have done a clean install of every driver on my system, recently I have reinstalled XP with a fresh set of drivers, it works with no problems with the VGA drivers, but as soon  as i install the Nvidia drivers it goes haywire, however i might now try not installing the Via chipset drivers yet, but that is not something i class as a solution.
0
 
LVL 4

Assisted Solution

by:lexicon_dominus
lexicon_dominus earned 280 total points
Comment Utility
Hello;
Installing latest nvidia drivers sometimes cause these kind of problems. You can try installing a previous version to see if the problem persists.
0
 
LVL 2

Author Comment

by:Supercomputeruk
Comment Utility
ive tried all the versions of the Nvidia drivers from 44_xxxx_xxxx to current day. Still no better
hmm
0
 
LVL 91

Assisted Solution

by:nobus
nobus earned 20 total points
Comment Utility
There are no yellow exclamation marks in Device manager? If not try another vga card, even a PCI will do, to check out the issue
0
 
LVL 2

Author Comment

by:Supercomputeruk
Comment Utility
no exclamation mark in Devmgmt.msc, and works fine with new VGA card, (albeit 2Mb Pci card), this leads me to think that VIA and Nvidia chipsets conflict. Howeverm, in msinfo32 under hardware resources and conflicts and sharing:

I/O Port 0x000003C0-0x000003DF      VIA CPU to AGP2.0/AGP3.0 Controller
I/O Port 0x000003C0-0x000003DF      NVIDIA GeForce4 MX 440
IRQ 16      NVIDIA GeForce4 MX 440
IRQ 16      Lucent Win Modem
Memory Address 0xD0000000-0xDFFFFFFF      VIA CPU to AGP2.0/AGP3.0 Controller
Memory Address 0xD0000000-0xDFFFFFFF      NVIDIA GeForce4 MX 440
Memory Address 0xE0000000-0xE1FFFFFF      VIA CPU to AGP2.0/AGP3.0 Controller
Memory Address 0xE0000000-0xE1FFFFFF      NVIDIA GeForce4 MX 440
Memory Address 0xA0000-0xBFFFF      PCI bus
Memory Address 0xA0000-0xBFFFF      VIA CPU to AGP2.0/AGP3.0 Controller
Memory Address 0xA0000-0xBFFFF      NVIDIA GeForce4 MX 440
I/O Port 0x000003B0-0x000003BB      VIA CPU to AGP2.0/AGP3.0 Controller
I/O Port 0x000003B0-0x000003BB      NVIDIA GeForce4 MX 440

There is a lot of sharing between the via agp chipset and the Nvidia card, I am begining to believe that this could be the source of the problem, but cannot change it in devmgmt.msc.
0
 
LVL 4

Assisted Solution

by:lexicon_dominus
lexicon_dominus earned 280 total points
Comment Utility
Hello SupercomputerUk;
There seem to be a IRQ Conflict between Nvidia VGA Card and Modem... Maybe you disable the modem... ?
0
Enabling OSINT in Activity Based Intelligence

Activity based intelligence (ABI) requires access to all available sources of data. Recorded Future allows analysts to observe structured data on the open, deep, and dark web.

 
LVL 2

Author Comment

by:Supercomputeruk
Comment Utility
Ill give that a whirl, ill have to go into the bios, to reassign it an IRQ mainly because Xp wont let me change it.
0
 
LVL 2

Author Comment

by:Supercomputeruk
Comment Utility
Right, ok why didnt I think of that one lol, it seems to work but, the modem is no use to me being disabled. Is there any way of forcing Xp to let me change the IRQ of the modem because the change this setting button is greyed out??
0
 
LVL 4

Assisted Solution

by:lexicon_dominus
lexicon_dominus earned 280 total points
Comment Utility
Maybe you can reassign PCI port IRQ from BIOS ?
0
 
LVL 2

Author Comment

by:Supercomputeruk
Comment Utility
Tried, it only has the option for Pci/Reserved and ive enabled manual options as well in the bios, still no result, if i change the location of the modem on the board will it change the IRQ, im not sure about this one but im goin to try it if it might pose as a solution.
0
 
LVL 3

Accepted Solution

by:
gfdos earned 200 total points
Comment Utility
I've seen this before --- try this:

in the bios look for a setting for "Assign IRQ to VGA".... try setting it to no.....
this may let windows assign the IRQ rather than the BIOS...
0
 
LVL 2

Author Comment

by:Supercomputeruk
Comment Utility
good point ill give that a try right now, im feeling very optimistic as ive just got my gcse results back :D.
0
 
LVL 2

Author Comment

by:Supercomputeruk
Comment Utility
right, it worked, but eventually i shelled out for a new card but thanks for all the input, ill distribute the points accordingly.
Regards
Supercomputeruk
0

Featured Post

Scale it in WD Gold

With up to ten times the workload capacity of desktop drives, WD Gold hard drives employ advanced technology to deliver among the best in reliability, capacity, power efficiency and performance.

Join & Write a Comment

Suggested Solutions

Upper back Pain: My back hurt for months. Upper back, mostly my neck, spine and across my shoulder blades. I was getting headaches too, that felt like they were caused by tension in my shoulders, but now I feel fine! I'm sharing this hoping someone…
This paper addresses the security of Sennheiser DECT Contact Center and Office (CC&O) headsets. It describes the DECT security chain comprised of “Pairing”, “Per Call Authentication” and “Encryption”, which are all part of the standard DECT protocol.
Polish reports in Access so they look terrific. Take yourself to another level. Equations, Back Color, Alternate Back Color. Write easy VBA Code. Tighten space to use less pages. Launch report from a menu, considering criteria only when it is filled…
This video shows how to remove a single email address from the Outlook 2010 Auto Suggestion memory. NOTE: For Outlook 2016 and 2013 perform the exact same steps. Open a new email: Click the New email button in Outlook. Start typing the address: …

763 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

8 Experts available now in Live!

Get 1:1 Help Now