Go Premium for a chance to win a PS4. Enter to Win

x
?
Solved

Problem with hard drive, jumpered as slave, thinks its master!?

Posted on 2004-08-23
7
Medium Priority
?
499 Views
Last Modified: 2010-04-25
Hey all,

Here's an interesting situation for you. I have a hardrive that seems to have a mind of its own. Before I mention anything further I'll bring you up to speed with what is in my system.

Motherboard      :ASUS A7N8X      
CPU            :Athlon XP 2800+ (Barton Core, 333 FSB)
RAM            :512Mb PC2700 RAM (1x512MB stick)
Audio            :Sound Blaster Audigy Gamer
CD/DVD Drives      :LG CD Burner & DVD Drive
NIC            :On board nVidia 10/100
HDD            :Maxtor 30Gb 7200 RPM & Fujitsu 30Gb 7200 RPM
            (Not sure of caches sizes)

This is what's happened so far, I tried booting up one day and got an "NTLDR not found" error. After some fooling around I noticed it was because my Fujitsu(Slave) drive was being detected as master, and the Maxtor drive was not being detected at all. Oh an all this happened as the Fujitsu drive was specifically jumpered for SLAVE. Interesting so far eh!

Ok so now I go into to trouble shooting mode, I disconnected the Fujitsu drive and only connected the Maxtor drive. My system booted fine, I then reconnect the Fujitsu drive and I get the same problem. Then I tried connecting the drives to separate IDE Lines. I put the Maxtor on IDE 1 and the Fujitsu on IDE 2, during this process I also unplugged both my CD-w/RW & DVD drives. I never touched any of the jumper's I only verified that the Fujitsu was still jumpered as slave. When I booted in this configuration again the Fujitsu was detected as master, the system booted fine.

It was at this point that I tried pulling the jumper completely from the Fujitsu drive. I then plugged it in on the IDE 1 line along with the Maxtor drive. They were both detected correctly and the system loaded fine. Hmmmm I started saying at this point.

Anyways I shutdown again, reattached the jumper in the correct slave position and the same error again.

Now seeing as this has become much longer winded than I thought I'll just ask the question. I'm guessing with a fair amount of certainty that the Fujitsu drive is now on it last legs, correct? Or is there a possibility of something else going wrong. I managed to back-up all the pertinent data from the drive when I managed to get them both to boot, now I'm wondering if I have to buy another drive, or can I fix this one.

Thanks for everyone help and input.
0
Comment
Question by:FreeLancer
  • 4
  • 3
7 Comments
 
LVL 69

Expert Comment

by:Callandor
ID: 11873388
I think it's just the jumper block detection that is faulty, no the entire drive.  Why don't you leave the jumper off? - it seems to detect drives correctly that way.
0
 
LVL 69

Expert Comment

by:Callandor
ID: 11873399
Correction - "not the entire drive".
0
 

Author Comment

by:FreeLancer
ID: 11873820
That's exactly what I did. I left the jumper off and the drive worked fine for a bit. Then I started running into trouble with Winamp, and playing my MP3's which I store on the Fujitsu drive. I'd be able to play 1-2 songs then the system would freeze. I wouldn't get a blue screen or anything, just the mouse cursor would become stuck, and I'd have to reboot. Also while this was happening I'd get some weird noises from one of the HDD's. Just a clicking noise, and not the clicking you get from the drive working, but more of a something bumping into something noise. Also while this was happening I could do just abou everything else with the system, I could play games(my page file is stored on the Fujitsu drive to speed up access), access the internet, and do just about anything.

Anyways I then rejumpered the drive and it worked fine again for a couple days then the same original error with the slave being detected as master.

Now the only other thing I should mention that might be of help is this. I had recently updated my motherboard drivers. I have a nVidia nForce 2 chipset on the ASUS board. As part of the drive package they had an alternate IDE drive that was supposed to "eliminate bandwidth bottleneck's" However as part of said driver's installation they warned they would not be held responsible for any lost data, etc. Anyways I installed these driver's before I started having any trouble what so ever with the system. I'd say I had the drivers in and running for 2-3 weeks before the problem cropped up.

This then made me think that the IDE driver was suspect, so I tried unistalling the IDE driver and that proceeded to make my system non-bootable. I couldn't boot into anything except the recovery console, everytime I tried to load into safe mode, or normal mode I got a BSOD. I also was unable to boot into last know good configuration.

This forced me to reinstall everything which I did, and I'm running into the same problems again. The drive is detected as slave without the jumpers for a bit, then I have to rejumper it when it stops working. But as soon as I put the jumper on it's detected as master no matter what I have the jumper set to. I then remove the jumper and the system will boot again with the Fujitsu again being detected as slave. Oh and I also don't have the nVidia IDE drivers installed right now, I'm running off the default Win XP IDE drivers.

I should have included this with the original post, sorry.
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 69

Accepted Solution

by:
Callandor earned 600 total points
ID: 11874971
If the hard drive is making funny noises, then I agree that it is failing, and it's time to replace it.
0
 

Author Comment

by:FreeLancer
ID: 11877447
Damn, but at least I'll get more Gb's for my buck this time. I should be able to pick up a 100+ drive for what I paid for that one! Or maybe an 80 GB with a large cache. Here's the points, thanks again. By the way what exactly did you mean by "Jumper Block Detection"?
0
 
LVL 69

Expert Comment

by:Callandor
ID: 11877463
I was referring to the position of the jumper being properly detected by the drive electronics - but your clarification showed that the drive was faulty, since it was making noises.
0
 

Author Comment

by:FreeLancer
ID: 11882390
Oh, yeah that makes sense. Thanks again for your help, in this and every other instance too!
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Article by: Firmin
The 5 R's 1. Repair 2. Restore 3. Reinstall 4. Remote admin 5. Run away OK so I'm not the most skilled engineer around but I definitely have an abundance of experience: electronic repairs since I was 13 and PC and computer hardware repair…
Windows 7 does not have the best desktop search built in. This is something Windows 7 users have struggled with. You type something in, and your search results don’t always match what you are looking for, or it doesn’t actually work at all. There ar…
Finding and deleting duplicate (picture) files can be a time consuming task. My wife and I, our three kids and their families all share one dilemma: Managing our pictures. Between desktops, laptops, phones, tablets, and cameras; over the last decade…
Want to learn how to record your desktop screen without having to use an outside camera. Click on this video and learn how to use the cool google extension called "Screencastify"! Step 1: Open a new google tab Step 2: Go to the left hand upper corn…
Suggested Courses

963 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question