Solved

Harddisk will not mount in XP Pro

Posted on 2004-08-23
10
248 Views
Last Modified: 2010-04-03
I think I had a similar problem to this in the past but it resolved with a new motherboard. Earlier this morning when my computer was doing its bi-weekly virus scan the scanner halted on one of my drives, stating that it could not read/write to the disk, and data was lost. Ok, weird, that out of no where this would happen, the drive isn't really used for anything other than mp3 storage and recent downloads, which isn't much considering I've been to busy to really do anything online. Anyway, I go into windows explorer and I get the same weird "read/write" error. So I check Disk Management and the drive isn't there, which tells me that somehow it was dismounted. I reboot and check the BIOS which shows the drive clear as day, even in loading the BIOS the drives comes up. So the computer does see the drive, its just something in Windows that happened last night that is preventing the OS from remounting the drive.

Right now and for the past year the drive has been on a EIDE Chain, as a Slave. The other drives in the system are on a RAID 0 Config.
This configuration has worked fine on my system for I would say at least 12 months. The only thing that has changed in the guts is I added a DVD-R drive three weeks ago, which ironically I was planning to use to back up the drive today.

Any ideas?
0
Comment
Question by:happyjohn14
  • 2
  • 2
  • 2
  • +4
10 Comments
 
LVL 10

Expert Comment

by:tfjeff
ID: 11874908
what format is the filesystem on the drive?  If its fat you could try mounting it using dos and see if you are having a windows problem or a hard drive problem...if it's ntfs there are boot disks out there that will allow you to do the same thing, but I prefer knoppix, which is a bootable linux CD, see if it can mount the drive.  Also, if both of these fail, run the manufacturer of the drive's diagnostics, it will probably fail if you can't mount the drive in DOS or Linux.
good luck
jeff
0
 
LVL 9

Expert Comment

by:BigC666
ID: 11875080
howdy,

have a look at this http://www.ultimatebootcd.com/

hope that this helps
0
 
LVL 8

Expert Comment

by:pjcrooks2000
ID: 11876270
Looks like spam to me BigC666 how sad that is.

Happyjohn I had the same problem and it will be either one of two problems, but they are both really in the same area.

Ok you think you have had this problem before I too had the same problem on different hard drives.  I actually sorted the problem by adjusting the metal sockets on my hard drive power cable.  Closed them up a bit so that the fit was tighter, if one of the connections is a bit loose then the hard drive will failter whilse in use.  Actually if you pull the lead on the HDD you will simulate the problem or sometimes it crashes the PC.

The other thing that may be causing it is a faulty HDD socket, actually the HDD socket itself try moving it around a bit and see if you can hear clicks from it as you go in and out of your MY Computer icon.

Add hardware through the control panel to see if it re appears when its not visible, as this will tell you if the drive has tripped out.  You can add it again from there, because normally it is only detected on boot up.

I am fairly sure that the power has somethign to do with it so try to make the power leads a much snugger fit and see hwo you go :)

0
 
LVL 2

Expert Comment

by:Supercomputeruk
ID: 11878708
Tip, open the case and listen carefully while going about your normal work, if you hear a loudish 'click' that is the hdds power dying out, if that happens goto device manager and do scan for new hardware, if the hard drive has disappeared that should confirm the problem. Solution, as above but its a bit risky as you risk snapping the pins on the hdd off, better solution would be to try a different power adapter from the PSU
0
 
LVL 8

Expert Comment

by:pjcrooks2000
ID: 11880329
Supercomputeruk you just repeated one of the things i said so it seems -

Hmmm yeah as i said above but I mean move the power connection around... I strongly doubt that you will risk damaging the pins on the HDD socket, Unless you use a pair of pliers.  :)
0
Save on storage to protect fatherhood memories

You're the dad who has everything. This Father's Day, make sure your family memories are protected. My Passport Ultra has automatic backup and password protection to keep your cherished photos and videos safe. With up to 3TB, you have plenty of room to hold the adventures ahead.

 

Expert Comment

by:NicIT7
ID: 11887832
Hmm,

If you are running SATA RAID, there are some virus that delete your raid config upon rebooting.
0
 
LVL 2

Expert Comment

by:Supercomputeruk
ID: 11891010
I was just clarifying, mainly because people have a tendency to use a sledgehammer to crack a nut, or as in this case over bend the pins. I had a similar problem and solved it by tying some insulation tape around the plug, and the wires leading to it to secure them so that they didnt wobble.
0
 

Accepted Solution

by:
MicahMicahMicah earned 250 total points
ID: 11897431
You also might want to check the PSU.  If you are using a stock OEM PSU, there is always a chance that the new optical drive has pushed your PSU past the limits of stability.  I had a similar problem when I setup a six drive raid 5 array in a machine with a stock 300W PSU.  Fortunately, it was dumping my optical drives instead of my HD's.  I switched up to a name brand 430W and haven't had a problem since.
0
 

Author Comment

by:happyjohn14
ID: 11914273
I'm not possitive that that is the perfect solution, but that and a combination did help me in moving the data over to another drive before I have to trade it out with a replacement.

After posting the question I tried a few other things that didn't work and had me come to the conclusion that the drive was bad, Seagate decided to replace it. I'm wondering now if that is even the case, but then again I'm not going to refuse a replacement.

Yesterday I tried to remove the power on an optical drive and one of my lesser used harddrives, and in return that keep the drive mounted long enough to get most of the data off it. The PSU is pretty new, I think I got it back in March after I had one die on me, its running at 400w, Likely not enough for my system.

Athlon 64 3000+
1 gig pc3200
3 hard drives at around 250 gigs
dvd*
cd-rw
geforce 4ti 4400
and a ton of system fans.
0
 

Expert Comment

by:MicahMicahMicah
ID: 11914876
Just to give you an idea of what a quality PSU can support.  I had a similar problem with a machine with the stock Powerman 300W PSU that came with my Inwin q500n case.  I was then running the following hardware.
Soyo Dragon 333 Ultra Platinum // AMD 2000XP // 3 x Geil 512mb DDR2100 // NEC 8x DVD // HP 12xCDRW // four 120GB Western Digital in Raid-0 (using onboard highpoint controller) // 60GB Western Digital // Chaintech Geforce ti4600 // SB Live 5.1// Adaptec Firewire card // 3 80mm case fans // Phillips USB webcam

The machine ran hot - roughly 149F cpu and a few degrees lower for the case.  Stability was an issue, the machine would sometimes last for weeks, other times it would go days - sometimes just hours.  Playing 3d games would kill the machine sometimes in a matter of minutes.  I'd usually lose my raid array shortly before, sometimes I would lose one of the optical drives.

Well, a few upgrades later I'm using an Antec TruePower430W with a Lian-Li PCV2000B case.  My cpu temp has dropped to 112F and I've actually updated a few itmes.  Now running the following.
Soyo Dragon 333 Ultra Platinum // AMD 2400XP // 3x Geil 512MB DDR2100 // Pioneer DVR-106D // six 250GB Western Digital in Raid-5 // Promise FastTrack SX6000 raid w/128MB // 60GB Western Digital // Chaintech Geforce FX5950ultra // SB Live 5.1 // Adaptec Firewire card // two 120mm case fans // Phillips USB Webcam.

No stability issues at all.  I always warn people not to cheap out on the PSU unless they are running a barebones setup.
0

Featured Post

Backup Your Microsoft Windows Server®

Backup all your Microsoft Windows Server – on-premises, in remote locations, in private and hybrid clouds. Your entire Windows Server will be backed up in one easy step with patented, block-level disk imaging. We achieve RTOs (recovery time objectives) as low as 15 seconds.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Netapp Snapshots 3 63
Very slow DFSR update to audit permissions on files 8 49
Windows 2012 Auto Grow Volume 11 74
Storage Space Configuration 6 53
AWS Glacier is Amazons cheapest storage option and is their answer to a ‘Cold’ storage service.  Customers primarily use this service for archival purposes and storage of infrastructure backups.  Its unlimited storage potential and low storage cost …
Finding original email is quite difficult due to their duplicates. From this article, you will come to know why multiple duplicates of same emails appear and how to delete duplicate emails from Outlook securely and instantly while vital emails remai…
This video teaches viewers how to encrypt an external drive that requires a password to read and edit the drive. All tasks are done in Disk Utility. Plug in the external drive you wish to encrypt: Make sure all previous data on the drive has been …
This tutorial will walk an individual through the process of installing the necessary services and then configuring a Windows Server 2012 system as an iSCSI target. To install the necessary roles, go to Server Manager, and select Add Roles and Featu…

896 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

13 Experts available now in Live!

Get 1:1 Help Now