• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1143
  • Last Modified:

Epson 1520 - cover open and pause indicators blinking

I have an Epson Stylus 1520. When I power up, the CR head makes a grinding noise for around 8 secs and then the "cover open" and "pause" leds start blinking (indicating a Fatal Error according to User Guide and Workshop Manual CD).

I have seen a very similar problem on this site where the problem appeared to be resolved by reloading the firmware by . .

When pressing PWR ON button, hold down
Alt + LF/FF + load/eject + Micro adjust

. . .  when I do this nothing much happens. What I mean is, the situation does not change, "cover open" and "pause" leds continue to blink and the printer remains in its error state.

Any advice what to do next? Is there any other way to reload the firmware? - there is no mention of "firmware" when I search the PDF versions of the User Guide and the Workshop Manual.

Many thanks in anticipation . . .
0
ianfrank
Asked:
ianfrank
1 Solution
 
TommyTupaCommented:
This is often solved with a little lubricant/cleaning.  Try here:
http://www.fixyourownprinter.com/printer/10/9225.html

0
 
ianfrankAuthor Commented:
The above URL points to a method for cleaning and lubing the cartridge guide and other components. I followed it and it did the trick! Many thanks . . .
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Cloud Class® Course: C++ 11 Fundamentals

This course will introduce you to C++ 11 and teach you about syntax fundamentals.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now