Solved

setting up a router as a internet gateway

Posted on 2004-08-23
7
179 Views
Last Modified: 2010-04-17
I got a 2611 router with e0/0 as the outside, and e0/1 for internal.  when I plug it in and ping my default gateway, given from the isp.

Reply frmo 192.168.1.1 :  Destination host unreachable.

Here is my running config

sh run
Building configuration...

Current configuration : 1157 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname Router
!
enable secret 5 $1$60dM$agBXmEfl295aosf75SOHN1
!
ip subnet-zero
!
!
ip dhcp excluded-address 192.168.1.1
!
ip dhcp pool dhcppool
   network 192.168.1.0 255.255.255.0
   default-router 68.106.112.1
   domain-name Farm.com
   dns-server 68.100.16.25
!
 --More--         !
call rsvp-sync
!
!
!
!
!
!
!
!
interface Ethernet0/0
 ip address dhcp
 ip access-group 101 in
 full-duplex
!
interface BRI0/0
 no ip address
 encapsulation hdlc
 shutdown
!
interface Serial0/0
 no ip address
 shutdown
 --More--         !
interface Ethernet0/1
 ip address 192.168.1.1 255.255.255.0
 ip nat inside
 full-duplex
!
ip nat inside source list 1 interface Ethernet0/0 overload
ip classless
ip route 0.0.0.0 0.0.0.0 68.106.112.1
no ip http server
!
access-list 1 permit any
access-list 101 permit udp any eq domain any
access-list 101 permit tcp any any established
access-list 101 permit icmp any any echo-reply
!
dial-peer cor custom
!
!
!
!
!
line con 0
 --More--          password 7 001012080354
 login
line aux 0
 password 7 105A08170218
 login
line vty 0 4
 password 7 105A08170218
 login
!
end

Router#
0
Comment
Question by:Pentrix2
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
  • 2
  • 2
  • +1
7 Comments
 
LVL 50

Accepted Solution

by:
Don Johnston earned 250 total points
ID: 11880026
Your default router needs to be changed from 68.106.112.1 to 192.168.1.1

no default-router 68.106.112.1
default-router 192.168.1.1

Don
0
 
LVL 43

Assisted Solution

by:JFrederick29
JFrederick29 earned 250 total points
ID: 11880225
In addition, you're missing "ip nat outside" on your Ethernet0/0 interface.
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 11880475
That'll teach me to stop looking once I find the obvious. ;-)

-Don
0
Resolve Critical IT Incidents Fast

If your data, services or processes become compromised, your organization can suffer damage in just minutes and how fast you communicate during a major IT incident is everything. Learn how to immediately identify incidents & best practices to resolve them quickly and effectively.

 
LVL 9

Author Comment

by:Pentrix2
ID: 11880820
Thanks guys, I'll have to try it out when I get home from work today.  :)

Pen
0
 
LVL 11

Expert Comment

by:PennGwyn
ID: 11885129
> ip route 0.0.0.0 0.0.0.0 68.106.112.1

The ISP should be supplying a default gateway address as part of its DHCP config for you.  Use it.

0
 
LVL 9

Author Comment

by:Pentrix2
ID: 11885224
the 68.106.112.1 is the default gateway given from my isp, by doing ipconfig all

so should i still use 192.168.1.1
0
 
LVL 43

Expert Comment

by:JFrederick29
ID: 11885653
Yes, the default-router command under the DHCP parameters is the default gateway the router hands out to the internal hosts.  The router's ethernet interface is the default router for your internet network so use 192.168.1.1.

default-router 192.168.1.1

In your "ip route" statement on the router, use the ISP supplied gateway address 68.106.112.1.
0

Featured Post

Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
using BGP Attributes 2 119
looking for a program or router to monitor internet connection 4 100
EIGRP Bandwidth 9 44
ACL not working 11 50
While it is possible to put two routes in place with the secondary having a higher metric, this may not always work. In the event of a failure that does not bring down the physical interface on the router the primary route is not removed. There is a…
Problem Description:   Couple of months ago we upgraded the ADSL line at our branch office from Home to Business line. The purpose of transforming the service to have static public IP’s. We were in need for public IP’s to publish our web resour…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

730 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question