Solved

Desktop will not load in Terminal Server session

Posted on 2004-08-23
8
157 Views
Last Modified: 2010-04-14
One of my terminal servers just started acting up and will not load the desktop for standard users.  The desktop will load properly for administrators.

What I have just found is that if I try to logon as a standard user and hit ctrl-alt-end, I am able to open taskmgr and launch programs such as notepad and word, but otherwise, the terminal session just shows a blue screen with no icons or taskbar.

I have tried switching terminal from application mode to admin mode and then back to application mode with no success.  I have also tried uninstalling the terminal components and re-installing.  I have also renamed the user account under c:/documents and settings/etc... with no success.

Any thoughts?
0
Comment
Question by:dwoodroofe
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
8 Comments
 
LVL 13

Expert Comment

by:TommyTupa
ID: 11878100
Are you using Roaming Profiles?
0
 

Author Comment

by:dwoodroofe
ID: 11878114
No, no roaming profiles.

Also noticed that I cannot load explorer.exe from taskmgr.
0
 
LVL 13

Expert Comment

by:TommyTupa
ID: 11882266
What do you see in the Event Log?
Also, here's a mskb: http://support.microsoft.com/default.aspx?scid=kb;en-us;Q256194
0
Get 15 Days FREE Full-Featured Trial

Benefit from a mission critical IT monitoring with Monitis Premium or get it FREE for your entry level monitoring needs.
-Over 200,000 users
-More than 300,000 websites monitored
-Used in 197 countries
-Recommended by 98% of users

 

Author Comment

by:dwoodroofe
ID: 11886138
Event log is clean.

MS kb references the version of the DLL. I compared the version on the problem server to a working server and they are the same.
0
 

Author Comment

by:dwoodroofe
ID: 11887359
Problem fixed.

Permissions on HKEY_CLASSES_ROOT tree were invalid.

Please refer to Experts-Exchange prior post.  The settings on the Advanced tab of permissions had to be adjusted (as referenced in previous solution).  Had to propagate to child objects in order to correct.

http://www.experts-exchange.com/Operating_Systems/Win2000/Q_21011721.html?query=terminal+desktop+load&clearTAFilter=true

Thanks robrandon!

Doug Woodroofe
0
 
LVL 1

Accepted Solution

by:
Computer101 earned 0 total points
ID: 12438881
PAQed, with points refunded (500)

Computer101
E-E Admin
0

Featured Post

Ransomware-A Revenue Bonanza for Service Providers

Ransomware – malware that gets on your customers’ computers, encrypts their data, and extorts a hefty ransom for the decryption keys – is a surging new threat.  The purpose of this eBook is to educate the reader about ransomware attacks.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

NTFS file system has been developed by Microsoft that is widely used by Windows NT operating system and its advanced versions. It is the mostly used over FAT file system as it provides superior features like reliability, security, storage, efficienc…
Originally, this post was published on Monitis Blog, you can check it here . In business circles, we sometimes hear that today is the “age of the customer.” And so it is. Thanks to the enormous advances over the past few years in consumer techno…
This is my first video review of Microsoft Bookings, I will be doing a part two with a bit more information, but wanted to get this out to you folks.
This tutorial will teach you the special effect of super speed similar to the fictional character Wally West aka "The Flash" After Shake : http://www.videocopilot.net/presets/after_shake/ All lightning effects with instructions : http://www.mediaf…

623 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question