Solved

MSDE installation problems

Posted on 2004-08-24
16
638 Views
Last Modified: 2008-01-09
500 points to the one who solves my problem.

I am facing a lot of problems installing MSDE on my machine. I have downloaded the latest MSDE from the Microsoft web site (which is service pack 3). The installation rolls back and gives a message saying "MSDE installation failed".

I used the commands:
Setup SAPASSWORD=mypassword /qb+ /L*v <logfile>
and
Setup SAPASSWORD=mypassword DISABLENETWORKPROTOCOLS=1 /qb+ /L*v <logfile>
but both failed. My machine configuration is:

Windows 2k Professional, service pack 4
IE 6
File and Print Sharing enabled
A network card, but no network (home use)
I meet the hardware requiredments for installing MSDE (like RAM, etc)
I had previously installed MS SQL Server 6.5 (no service packs), which I have "successfully" uninstalled, and manually deleted the sql folder.

The log file says the following:

MSI (s) (00:18): Note: 1: 2262 2: IniLocator 3: -2147287038
Action ended 18:47:56: AppSearch. Return value 1.
MSI (s) (00:18): Skipping action: ErrorCodeIE.2D02443E_7002_4C0B_ABC9_EAB2C064397B (condition is false)
MSI (s) (00:18): Skipping action: FatalErrorIE.2D02443E_7002_4C0B_ABC9_EAB2C064397B (condition is false)
MSI (s) (00:18): Doing action: GetSqlStates.2D02443E_7002_4C0B_ABC9_EAB2C064397B
Action start 18:47:56: GetSqlStates.2D02443E_7002_4C0B_ABC9_EAB2C064397B.
MSI (s) (00:18): Creating MSIHANDLE (101) of type 790542 for thread 280
SOFTWARE\Microsoft\Microsoft SQL Server Setup.{E09B48B5-E141-427A-AB0C-D3605127224A}
TempFolder is c:\temp\{E09B48B5-E141-427A-AB0C-D3605127224A}\
Loading extended custom action library c:\temp\{E09B48B5-E141-427A-AB0C-D3605127224A}\sqlcax.dll
SOFTWARE\Microsoft\Microsoft SQL Server Setup.{E09B48B5-E141-427A-AB0C-D3605127224A}
Property SqlStates: 0 (0x0)
Action ended 18:47:56: GetSqlStates.2D02443E_7002_4C0B_ABC9_EAB2C064397B. Return value 1.
MSI (s) (00:18): Skipping action: DetectUpgrade.2D02443E_7002_4C0B_ABC9_EAB2C064397B (condition is false)
MSI (s) (00:18): Skipping action: SqlDisableNetAccessError.2D02443E_7002_4C0B_ABC9_E AB2C064397B (condition is false)

I have searched all over the Net and could not find a single solution to my weird problem. This is the first time I am installing MSDE on my machine, and I am totally frustrated. Can somone please help me.
0
Comment
Question by:somecuriousguy
16 Comments
 
LVL 10

Expert Comment

by:AaronAbend
ID: 11883371
I am quite familiar with errors like this (unfortunately). Is the message limited to "MSDE installation failed"? any other words in the message?

Is MDAC installed? If so, which version?  
0
 
LVL 10

Expert Comment

by:AaronAbend
ID: 11883433
Also, which directory did you delete? I can't recall where 6.5 went, but check to see if there is anything in Program Files\Microsoft SQL Server and see if the date on that folder matches your attempted install. If it does not that is what has to be removed. Otherwise, I'll wait for that additional info.
0
 
LVL 14

Expert Comment

by:Daniel Junges
ID: 11884434
Try to install the lastest version of MSI and IE manualy and try again

regards
junges
0
 
LVL 4

Expert Comment

by:naivad
ID: 11886810
Get the new version of MSDE called SQL Express (it is in beta, but is way better than MSDE in my opinion)
0
 

Author Comment

by:somecuriousguy
ID: 11902619
There are no other words in the message other than "Msde setup failed". I had not installed mdac. I installed the latest verion 2.8.
Also, there is no microsoft sql folder in the program files folder. There was however an mssql folder in c:\ which I have deleted but still the same problem.

0
 
LVL 10

Expert Comment

by:AaronAbend
ID: 11903074
Try this link to remove anything that might still be on your machine...

http://support.microsoft.com/default.aspx?scid=kb;en-us;320873

- I don't have any better ideas. I just checked around on SQL Express. Beyond the fact that it was published less than a month ago, I'd probably stay away from it. "Beta" is probably too high a letter, given the blog notes I saw when I googled.
0
 

Accepted Solution

by:
somecuriousguy earned 0 total points
ID: 11919504
Guess what, I have answered my own question. Heres how:
I did the following:
1. Installed ms loopback adapter
2. Enabled my LAN (though there is no n/w)
3. Installed the following windows components: Management and monitoring tools, networking services, Other file and print services.
I ran the installation, restarted my machine, and yippeee, msde was installed. I tested it with VS.net and it worked fine.
Thanx for the help, people.
0
How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

 
LVL 10

Expert Comment

by:AaronAbend
ID: 11921188
Actually, of the steps you took, I believe the only one that mattered was enabling File and Print Services, which have to be installed and running to install MSDE unless you apply a very recent hotpatch.  I will not object to the refund, because (at least as far as I am concerned) I should have mentioned that in the first place, since it is a common problem installing MSDE.

0
 

Author Comment

by:somecuriousguy
ID: 11921327
You see as i mentioned in the question, file and print sharing was enabled. Yet i installed "other file and printer services" from add/remove windows components. Funny thing is I was able to successfully install msde on a mahcine with the same os and service pack as mine, although it did not have "other file and printer services" installed.
0
 
LVL 10

Expert Comment

by:AaronAbend
ID: 11921363
Oh - you are right. Sorry. Thanks - at least I was not asleep. What about the loopback adaptor? And the network adaptor - was it installed and bound to TCP/IP (even though you did not need it for networking at home)? I would have to check but  I believe SQL does require that tcp/ip be enabled even if the machine is not on a network. Just a thought.

0
 

Author Comment

by:somecuriousguy
ID: 11921392
yes tcp/ip was enabled. I dialed up to internet from it. But the loopback adapter was not installed.
0
 
LVL 10

Expert Comment

by:AaronAbend
ID: 11921552
So the loopback adapter was the exact cause of the problem? Do you think if that was all you did it would have worked? (I think I owe you points on this!)
0
 

Author Comment

by:somecuriousguy
ID: 11924445
it seems like. But trust me, i seriously dont want to go back and find out what "exactly" caused it to work. As long as it works, I am happy. And where are my points :)
0
 
LVL 10

Expert Comment

by:AaronAbend
ID: 11925856
I will go and find out for you (and for me). I actually need to know and I have the setup to determine the exact cause.  I will post once I learn the answer.
0

Featured Post

Do You Know the 4 Main Threat Actor Types?

Do you know the main threat actor types? Most attackers fall into one of four categories, each with their own favored tactics, techniques, and procedures.

Join & Write a Comment

Suggested Solutions

CCModeler offers a way to enter basic information like entities, attributes and relationships and export them as yEd or erviz diagram. It also can import existing Access or SQL Server tables with relationships.
Shadow IT is coming out of the shadows as more businesses are choosing cloud-based applications. It is now a multi-cloud world for most organizations. Simultaneously, most businesses have yet to consolidate with one cloud provider or define an offic…
Video by: Steve
Using examples as well as descriptions, step through each of the common simple join types, explaining differences in syntax, differences in expected outputs and showing how the queries run along with the actual outputs based upon a simple set of dem…
Polish reports in Access so they look terrific. Take yourself to another level. Equations, Back Color, Alternate Back Color. Write easy VBA Code. Tighten space to use less pages. Launch report from a menu, considering criteria only when it is filled…

705 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

18 Experts available now in Live!

Get 1:1 Help Now